aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2016-10-07 01:03:22 +0800
committerpawel <pawel@FreeBSD.org>2016-10-07 01:03:22 +0800
commit5cff2f3e599d4a227bd619cc2b9ea2a63f75fbd1 (patch)
treef0b3cb07f236b06ff447a88df9d65088746d5a42 /net
parentd082f692a0120127e31ad7555289682a6945d775 (diff)
downloadfreebsd-ports-gnome-5cff2f3e599d4a227bd619cc2b9ea2a63f75fbd1.tar.gz
freebsd-ports-gnome-5cff2f3e599d4a227bd619cc2b9ea2a63f75fbd1.tar.zst
freebsd-ports-gnome-5cff2f3e599d4a227bd619cc2b9ea2a63f75fbd1.zip
- Update to version 5.17.0
- Add LICENSE information - Register dependencies found by stage-qa - Drop maintainership
Diffstat (limited to 'net')
-rw-r--r--net/yaz/Makefile22
-rw-r--r--net/yaz/distinfo5
-rw-r--r--net/yaz/files/patch-src_malloc__info.c11
-rw-r--r--net/yaz/pkg-plist1
4 files changed, 27 insertions, 12 deletions
diff --git a/net/yaz/Makefile b/net/yaz/Makefile
index 66ac0efa3dea..6fcff1c4c870 100644
--- a/net/yaz/Makefile
+++ b/net/yaz/Makefile
@@ -2,28 +2,30 @@
# $FreeBSD$
PORTNAME= yaz
-PORTVERSION= 5.16.0
-PORTREVISION= 3
+PORTVERSION= 5.17.0
CATEGORIES= net
MASTER_SITES= http://ftp.indexdata.dk/pub/yaz/
-MAINTAINER= pawel@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= Z39.50/SR client and API library
-LIB_DEPENDS= libicuuc.so:devel/icu
+LIB_DEPENDS= libicuuc.so:devel/icu \
+ libgnutls.so:security/gnutls
-USES= execinfo iconv libtool pathfix pkgconfig shebangfix tcl
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= execinfo iconv libtool ncurses pathfix pkgconfig readline \
+ shebangfix tcl
SHEBANG_FILES= util/yaz-asncomp
GNU_CONFIGURE= yes
-USE_OPENSSL= yes
USE_GNOME= libxml2 libxslt
USE_LDCONFIG= yes
MAKE_JOBS_UNSAFE= yes
-CONFIGURE_ARGS+=--enable-shared --with-openssl=${OPENSSLBASE} \
- --with-iconv=${ICONV_PREFIX} --with-xml2=${LOCALBASE} \
- --with-xslt=${LOCALBASE} --with-icu=${LOCALBASE} \
- --enable-tcpd
+CONFIGURE_ARGS= --enable-shared --with-iconv=${ICONV_PREFIX} \
+ --with-xml2=${LOCALBASE} --with-xslt=${LOCALBASE} \
+ --with-icu=${LOCALBASE} --enable-tcpd
LDFLAGS+= -L${LOCALBASE}/lib
LIBS+= -lexecinfo
diff --git a/net/yaz/distinfo b/net/yaz/distinfo
index 869cc9894860..3b7623565705 100644
--- a/net/yaz/distinfo
+++ b/net/yaz/distinfo
@@ -1,2 +1,3 @@
-SHA256 (yaz-5.16.0.tar.gz) = 46708320152c1475f6a5ee6f29903caa76121c2440123051546c1b3403c78686
-SIZE (yaz-5.16.0.tar.gz) = 2586095
+TIMESTAMP = 1475698376
+SHA256 (yaz-5.17.0.tar.gz) = 9b735f0f6bc11856bf4d26ef3b9f2a2b92225d29d37f2e0b66ca9ecbd40965a0
+SIZE (yaz-5.17.0.tar.gz) = 2587243
diff --git a/net/yaz/files/patch-src_malloc__info.c b/net/yaz/files/patch-src_malloc__info.c
new file mode 100644
index 000000000000..1b4a2141a773
--- /dev/null
+++ b/net/yaz/files/patch-src_malloc__info.c
@@ -0,0 +1,11 @@
+--- src/malloc_info.c.orig 2016-10-05 20:17:14 UTC
++++ src/malloc_info.c
+@@ -12,7 +12,7 @@
+ #include <config.h>
+ #endif
+
+-#include <malloc.h>
++#include <stdlib.h>
+ #include <stdio.h>
+
+ #include <yaz/wrbuf.h>
diff --git a/net/yaz/pkg-plist b/net/yaz/pkg-plist
index 8d14e3d9fe79..2ea83a216710 100644
--- a/net/yaz/pkg-plist
+++ b/net/yaz/pkg-plist
@@ -35,6 +35,7 @@ include/yaz/item-req.h
include/yaz/json.h
include/yaz/log.h
include/yaz/logrpn.h
+include/yaz/malloc_info.h
include/yaz/marcdisp.h
include/yaz/match_glob.h
include/yaz/matchstr.h