aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorrm <rm@FreeBSD.org>2016-10-11 04:12:31 +0800
committerrm <rm@FreeBSD.org>2016-10-11 04:12:31 +0800
commit5e6f1200ddac9fe0c8b002afdc0de40171a9ae4a (patch)
treea00079f20a99b25bf67296e9fc46465046309cf9 /net
parentfb3a614cc1f94914ab9f4b75b7f443419e8cfd1f (diff)
downloadfreebsd-ports-gnome-5e6f1200ddac9fe0c8b002afdc0de40171a9ae4a.tar.gz
freebsd-ports-gnome-5e6f1200ddac9fe0c8b002afdc0de40171a9ae4a.tar.zst
freebsd-ports-gnome-5e6f1200ddac9fe0c8b002afdc0de40171a9ae4a.zip
pecl-oauth is a php interface to the oauth protocol.
Oauth is an authorization protocol built on top of HTTP which allows applications to securely access data without having to store usernames and passwords. WWW: http://pecl.php.net/package/oauth/ PR: 212773 Submitted by: dbaio@bsd.com.br
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/pecl-oauth2/Makefile29
-rw-r--r--net/pecl-oauth2/distinfo3
-rw-r--r--net/pecl-oauth2/pkg-descr6
4 files changed, 39 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 6bed47e43a50..2e0ab860d5ec 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -896,6 +896,7 @@
SUBDIR += pecl-ip2location
SUBDIR += pecl-mosquitto
SUBDIR += pecl-oauth
+ SUBDIR += pecl-oauth2
SUBDIR += pecl-radius
SUBDIR += pecl-smbclient
SUBDIR += pecl-yaz
diff --git a/net/pecl-oauth2/Makefile b/net/pecl-oauth2/Makefile
new file mode 100644
index 000000000000..16646cb99c37
--- /dev/null
+++ b/net/pecl-oauth2/Makefile
@@ -0,0 +1,29 @@
+# $FreeBSD$
+
+PORTNAME= oauth
+PORTVERSION= 2.0.2
+CATEGORIES= net pear
+MASTER_SITES= http://pecl.php.net/get/
+PKGNAMEPREFIX= pecl-
+PKGNAMESUFFIX= 2
+DIST_SUBDIR= PECL
+
+MAINTAINER= dbaio@bsd.com.br
+COMMENT= Php interface to the OAuth Protocol
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libcurl.so:ftp/curl
+
+PORTSCOUT= limit:^2.*
+
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ARGS+= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+
+USES= php:ext tar:tgz
+IGNORE_WITH_PHP= 55 56
+CONFLICTS= pecl-oauth-1*
+
+.include <bsd.port.mk>
diff --git a/net/pecl-oauth2/distinfo b/net/pecl-oauth2/distinfo
new file mode 100644
index 000000000000..5b6a7ea6cf1b
--- /dev/null
+++ b/net/pecl-oauth2/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1474130147
+SHA256 (PECL/oauth-2.0.2.tgz) = 87ce1a5d585f439f0ead2683f2f7dca76d538df9143da681978356b5e1c6e8e8
+SIZE (PECL/oauth-2.0.2.tgz) = 49115
diff --git a/net/pecl-oauth2/pkg-descr b/net/pecl-oauth2/pkg-descr
new file mode 100644
index 000000000000..9da4a1e33c5e
--- /dev/null
+++ b/net/pecl-oauth2/pkg-descr
@@ -0,0 +1,6 @@
+pecl-oauth is a php interface to the oauth protocol.
+Oauth is an authorization protocol built on top of
+HTTP which allows applications to securely access
+data without having to store usernames and passwords.
+
+WWW: http://pecl.php.net/package/oauth/