aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2015-03-04 13:18:31 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2015-03-04 13:18:31 +0800
commit5ed7cfa21d0b3145d3b34532f342b771b112b645 (patch)
tree4825d15ec470ba3db4024aa4d22b6175393dd987 /net
parentc7bbcff1b9fa9331cca5044a39816a31e1212fb0 (diff)
downloadfreebsd-ports-gnome-5ed7cfa21d0b3145d3b34532f342b771b112b645.tar.gz
freebsd-ports-gnome-5ed7cfa21d0b3145d3b34532f342b771b112b645.tar.zst
freebsd-ports-gnome-5ed7cfa21d0b3145d3b34532f342b771b112b645.zip
- Fix installation from non-root
- Mark broken: does not work properly
Diffstat (limited to 'net')
-rw-r--r--net/netselect/Makefile15
-rw-r--r--net/netselect/pkg-plist2
2 files changed, 6 insertions, 11 deletions
diff --git a/net/netselect/Makefile b/net/netselect/Makefile
index b34847d0bb38..1d881985ea34 100644
--- a/net/netselect/Makefile
+++ b/net/netselect/Makefile
@@ -12,21 +12,14 @@ COMMENT= Ultrafast implementation of ping
LICENSE= BSD3CLAUSE
+BROKEN= Does not work (sendto: Invalid argument)
+
OPTIONS_DEFINE= SUID
-SUID_DESC= Install with the sticky bit (mode 4110)
+OPTIONS_SUB= yes
+SUID_DESC= Install with the setuid bit (mode 4110)
WRKSRC= ${WRKDIR}/${PORTNAME}
-PLIST_FILES= bin/${PORTNAME}
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MSUID}
-BINMODE= 4110
-.else
-BINMODE= 0100
-.endif
-
do-build:
${CC} ${CFLAGS} -o ${WRKSRC}/${PORTNAME} ${WRKSRC}/${PORTNAME}.c
diff --git a/net/netselect/pkg-plist b/net/netselect/pkg-plist
new file mode 100644
index 000000000000..b5ddfc583a9b
--- /dev/null
+++ b/net/netselect/pkg-plist
@@ -0,0 +1,2 @@
+%%SUID%%@(root,wheel,4110) bin/netselect
+%%NO_SUID%%@(root,wheel,100) bin/netselect