aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorDiane Bruce <db@FreeBSD.org>2021-02-17 01:51:43 +0800
committerDiane Bruce <db@FreeBSD.org>2021-02-17 01:51:43 +0800
commit5f96b29efc0881641c7f52f2c7842c87f9d53834 (patch)
tree2944c72d551ed04adca8afe5c9f91b5d2090ca37 /net
parentc262f3b2502eb8c79ddffa2c560a8d40968752c1 (diff)
downloadfreebsd-ports-gnome-5f96b29efc0881641c7f52f2c7842c87f9d53834.tar.gz
freebsd-ports-gnome-5f96b29efc0881641c7f52f2c7842c87f9d53834.tar.zst
freebsd-ports-gnome-5f96b29efc0881641c7f52f2c7842c87f9d53834.zip
------------
* Reduce memory use significantly. The "last position of all stations" cache was unnecessarily holding a copy of the last packet from each station, eating 248 bytes per station (or more, if it was a long packet). It wasn't used for anything, so I removed the packet data from the structure, and it now uses 56 bytes per station. From about 13 megabytes to about 3 megabytes on a normal day. PR: ports/253296 Submitted by: freebsd-ports@dan.me.uk Reviewed by: portmgr Approved by: Maintainer
Diffstat (limited to 'net')
-rw-r--r--net/aprsc/Makefile11
-rw-r--r--net/aprsc/distinfo6
-rw-r--r--net/aprsc/files/patch-Makefile.in6
-rw-r--r--net/aprsc/files/patch-web_index.html4
-rw-r--r--net/aprsc/pkg-plist1
5 files changed, 16 insertions, 12 deletions
diff --git a/net/aprsc/Makefile b/net/aprsc/Makefile
index 77649d199a08..e5387461f87b 100644
--- a/net/aprsc/Makefile
+++ b/net/aprsc/Makefile
@@ -1,9 +1,8 @@
# $FreeBSD$
PORTNAME= aprsc
-PORTVERSION= 2.1.4
-DISTVERSIONSUFFIX= .g408ed49
-PORTREVISION= 3
+PORTVERSION= 2.1.8
+DISTVERSIONSUFFIX= .gf8824e8
CATEGORIES= net hamradio
MASTER_SITES= http://he.fi/aprsc/down/ \
LOCAL/db
@@ -16,13 +15,15 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libevent.so:devel/libevent
+USES= localbase:ldflags ssl perl5 gmake shebangfix
MAKEFILE= GNUmakefile
-
WRKSRC= ${WRKDIR}/${DISTNAME}/src
GNU_CONFIGURE= yes
-USES= localbase:ldflags ssl perl5 gmake shebangfix
SHEBANG_FILES= aprsc_munin
CONFIGURE_ARGS= --with-openssl
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/sbin/aprsc
+
.include <bsd.port.mk>
diff --git a/net/aprsc/distinfo b/net/aprsc/distinfo
index a2895f4826a0..0cf2e6cb9396 100644
--- a/net/aprsc/distinfo
+++ b/net/aprsc/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1485028042
-SHA256 (aprsc-2.1.4.g408ed49.tar.gz) = 85572232b4702b46eccbd646e4b0ad0b7535fb1788501b31a4ad45b0eb5ac8a3
-SIZE (aprsc-2.1.4.g408ed49.tar.gz) = 1649598
+TIMESTAMP = 1612522667
+SHA256 (aprsc-2.1.8.gf8824e8.tar.gz) = ff205f5f5fddbafda354288d4bf15403226c1b8e1d1d03cb9bfd672deb813604
+SIZE (aprsc-2.1.8.gf8824e8.tar.gz) = 1663599
diff --git a/net/aprsc/files/patch-Makefile.in b/net/aprsc/files/patch-Makefile.in
index 17c6c6a66f49..316faabbca47 100644
--- a/net/aprsc/files/patch-Makefile.in
+++ b/net/aprsc/files/patch-Makefile.in
@@ -1,4 +1,4 @@
---- Makefile.in.orig 2016-02-14 00:52:59 UTC
+--- Makefile.in.orig 2020-09-06 18:28:04 UTC
+++ Makefile.in
@@ -7,11 +7,8 @@
@@ -12,7 +12,7 @@
# generate version strings
VERSION:=$(shell cat VERSION)
-@@ -197,16 +194,13 @@ aprsc.8 : % : %.in VERSION Makefile
+@@ -217,17 +214,14 @@ aprsc.8 : % : %.in VERSION Makefile
.PHONY: install install-deb
install: all
@@ -22,9 +22,11 @@
- $(INSTALL_DIR) $(DESTDIR)/opt/aprsc/web
- $(INSTALL_PROGRAM) aprsc $(DESTDIR)$(SBINDIR)/aprsc
- $(INSTALL_PROGRAM) aprsc_munin $(DESTDIR)$(SBINDIR)/aprsc_munin
+- $(INSTALL_PROGRAM) aprsc-prepare-chroot.sh $(DESTDIR)$(SBINDIR)/aprsc-prepare-chroot.sh
+ $(INSTALL_DIR) $(DESTDIR)$(PREFIX)/etc/aprsc/web
+ $(INSTALL_PROGRAM) aprsc $(DESTDIR)$(PREFIX)$(SBINDIR)/aprsc
+ $(INSTALL_PROGRAM) aprsc_munin $(DESTDIR)$(PREFIX)$(SBINDIR)/aprsc_munin
++ $(INSTALL_PROGRAM) aprsc-prepare-chroot.sh $(DESTDIR)$(PREFIX)$(SBINDIR)/aprsc-prepare-chroot.sh
$(INSTALL_DATA) aprsc.8 $(DESTDIR)$(MANDIR)/man8/aprsc.8
- $(INSTALL_DATA) $(subst src/,,$(WEBFILES)) $(DESTDIR)/opt/aprsc/web
+ $(INSTALL_DATA) $(subst src/,,$(WEBFILES)) $(DESTDIR)$(PREFIX)/etc/aprsc/web
diff --git a/net/aprsc/files/patch-web_index.html b/net/aprsc/files/patch-web_index.html
index 915318f6df62..e55e65390575 100644
--- a/net/aprsc/files/patch-web_index.html
+++ b/net/aprsc/files/patch-web_index.html
@@ -1,5 +1,5 @@
---- web/index.html.orig 2017-01-21 19:58:24.223151000 +0000
-+++ web/index.html 2017-01-21 19:58:49.601855000 +0000
+--- web/index.html.orig 2018-06-01 09:25:08 UTC
++++ web/index.html
@@ -284,8 +284,7 @@
{{ sel_c.cert_issuer }}
</p>
diff --git a/net/aprsc/pkg-plist b/net/aprsc/pkg-plist
index aaa3e4cc8d3c..841488edf986 100644
--- a/net/aprsc/pkg-plist
+++ b/net/aprsc/pkg-plist
@@ -29,3 +29,4 @@
man/man8/aprsc.8.gz
sbin/aprsc
sbin/aprsc_munin
+sbin/aprsc-prepare-chroot.sh