aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authortobez <tobez@FreeBSD.org>2001-07-15 07:08:48 +0800
committertobez <tobez@FreeBSD.org>2001-07-15 07:08:48 +0800
commit607a7a83a3d6603b4d48ad51bcaae83c7ff42f41 (patch)
treed09f41f12fd7b98692d2de7d1771ace4ed88ad94 /net
parent0026f2c3547c17277d9062999ebcd1c7b8a91a1d (diff)
downloadfreebsd-ports-gnome-607a7a83a3d6603b4d48ad51bcaae83c7ff42f41.tar.gz
freebsd-ports-gnome-607a7a83a3d6603b4d48ad51bcaae83c7ff42f41.tar.zst
freebsd-ports-gnome-607a7a83a3d6603b4d48ad51bcaae83c7ff42f41.zip
Add p5-Net-DLookup 1.01, which is a perl module to perform domain
lookups on 2-letter and 3-letter TLDs. PR: 28092 Submitted by: Danny Howard <dannyman@tellme.com>
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-Net-DLookup/Makefile22
-rw-r--r--net/p5-Net-DLookup/distinfo1
-rw-r--r--net/p5-Net-DLookup/pkg-comment1
-rw-r--r--net/p5-Net-DLookup/pkg-descr3
-rw-r--r--net/p5-Net-DLookup/pkg-plist5
6 files changed, 33 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 90d73171812c..3fce38693800 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -245,6 +245,7 @@
SUBDIR += p5-IO-Interface
SUBDIR += p5-Mon
SUBDIR += p5-Net
+ SUBDIR += p5-Net-DLookup
SUBDIR += p5-Net-DNS
SUBDIR += p5-Net-Daemon
SUBDIR += p5-Net-IPv4Addr
diff --git a/net/p5-Net-DLookup/Makefile b/net/p5-Net-DLookup/Makefile
new file mode 100644
index 000000000000..e826e77ff539
--- /dev/null
+++ b/net/p5-Net-DLookup/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: p5-Net-DLookup
+# Date created: 11 June 2001
+# Whom: Danny Howard <dannyman@tellme.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-DLookup
+PORTVERSION= 1.01
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= dannyman@tellme.com
+
+PERL_CONFIGURE= YES
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Net::DLookup.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-Net-DLookup/distinfo b/net/p5-Net-DLookup/distinfo
new file mode 100644
index 000000000000..cbba8b661aef
--- /dev/null
+++ b/net/p5-Net-DLookup/distinfo
@@ -0,0 +1 @@
+MD5 (Net-DLookup-1.01.tar.gz) = 28efe2c7d62c858aded2e5a5cf68c490
diff --git a/net/p5-Net-DLookup/pkg-comment b/net/p5-Net-DLookup/pkg-comment
new file mode 100644
index 000000000000..8fc142e08581
--- /dev/null
+++ b/net/p5-Net-DLookup/pkg-comment
@@ -0,0 +1 @@
+Perform domain lookups on 2-letter and 3-letter TLDs
diff --git a/net/p5-Net-DLookup/pkg-descr b/net/p5-Net-DLookup/pkg-descr
new file mode 100644
index 000000000000..3ff5a9bb3f12
--- /dev/null
+++ b/net/p5-Net-DLookup/pkg-descr
@@ -0,0 +1,3 @@
+Net::DLookup performs domain lookups for 2-letter and 3-letter top level
+domains. It also verifies the validity of domain names by checking
+punctuation, length, metacharacters, etc..
diff --git a/net/p5-Net-DLookup/pkg-plist b/net/p5-Net-DLookup/pkg-plist
new file mode 100644
index 000000000000..b405599834c4
--- /dev/null
+++ b/net/p5-Net-DLookup/pkg-plist
@@ -0,0 +1,5 @@
+lib/perl5/site_perl/%%PERL_VER%%/Net/DLookup.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/DLookup/.packlist
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/DLookup 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Net 2>/dev/null || true