aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authordemon <demon@FreeBSD.org>2017-04-19 20:57:56 +0800
committerdemon <demon@FreeBSD.org>2017-04-19 20:57:56 +0800
commit610dbcef5b166abb7fda8922a04a0d2e16bfa09a (patch)
tree2b93c5c94375b794011553e57942d55515137b6d /net
parentf9cb2c2f68d09a991680e1ef1ea1396abc5da0cc (diff)
downloadfreebsd-ports-gnome-610dbcef5b166abb7fda8922a04a0d2e16bfa09a.tar.gz
freebsd-ports-gnome-610dbcef5b166abb7fda8922a04a0d2e16bfa09a.tar.zst
freebsd-ports-gnome-610dbcef5b166abb7fda8922a04a0d2e16bfa09a.zip
Do not override CFLAGS defined in Makefile; use OPTIONS_CFLAGS to pass our
CFLAGS env variable; Add -fwrap to CFLAGS to fix eventual haproxy spins when compiled with newer versions of clang (FreeBSD-11 is affected). -- obtained from haproxy source tree.
Diffstat (limited to 'net')
-rw-r--r--net/haproxy-devel/Makefile2
-rw-r--r--net/haproxy-devel/files/patch-Makefile11
-rw-r--r--net/haproxy/Makefile2
-rw-r--r--net/haproxy/files/patch-Makefile11
4 files changed, 24 insertions, 2 deletions
diff --git a/net/haproxy-devel/Makefile b/net/haproxy-devel/Makefile
index 2a99bbe93708..45d44f7fa992 100644
--- a/net/haproxy-devel/Makefile
+++ b/net/haproxy-devel/Makefile
@@ -24,7 +24,7 @@ DEVICEATLAS_DISTFILE= deviceatlas-enterprise-c-${DEVICEATLAS_VERSION}
DEVICEATLAS_REGISTRATION_URL= https://deviceatlas.com/deviceatlas-haproxy-module
MAKE_ARGS= TARGET=freebsd DEFINE=-DFREEBSD_PORTS USE_GETADDRINFO=1 \
- USE_ZLIB=1 USE_CPU_AFFINITY=1 CC="${CC}" CFLAGS="${CFLAGS}"
+ USE_ZLIB=1 USE_CPU_AFFINITY=1 CC="${CC}" DEBUG_CFLAGS="" OPTIONS_CFLAGS="${CFLAGS}"
OPTIONS_DEFINE= DOCS EXAMPLES LUA OPENSSL DEVICEATLAS
OPTIONS_RADIO= PCRE
diff --git a/net/haproxy-devel/files/patch-Makefile b/net/haproxy-devel/files/patch-Makefile
new file mode 100644
index 000000000000..3c74b35769c9
--- /dev/null
+++ b/net/haproxy-devel/files/patch-Makefile
@@ -0,0 +1,11 @@
+--- Makefile.orig 2017-04-19 13:18:14.404480000 +0300
++++ Makefile 2017-04-19 13:18:26.684393000 +0300
+@@ -128,7 +128,7 @@ DEBUG_CFLAGS = -g
+ #### Compiler-specific flags that may be used to disable some negative over-
+ # optimization or to silence some warnings. -fno-strict-aliasing is needed with
+ # gcc >= 4.4.
+-SPEC_CFLAGS = -fno-strict-aliasing -Wdeclaration-after-statement
++SPEC_CFLAGS = -fno-strict-aliasing -Wdeclaration-after-statement -fwrapv
+
+ #### Memory usage tuning
+ # If small memory footprint is required, you can reduce the buffer size. There
diff --git a/net/haproxy/Makefile b/net/haproxy/Makefile
index 2e086285e961..45e535d8fef4 100644
--- a/net/haproxy/Makefile
+++ b/net/haproxy/Makefile
@@ -23,7 +23,7 @@ DEVICEATLAS_DISTFILE= deviceatlas-enterprise-c-${DEVICEATLAS_VERSION}
DEVICEATLAS_REGISTRATION_URL= https://deviceatlas.com/deviceatlas-haproxy-module
MAKE_ARGS= TARGET=freebsd DEFINE=-DFREEBSD_PORTS USE_GETADDRINFO=1 \
- USE_ZLIB=1 USE_CPU_AFFINITY=1 CC="${CC}" CFLAGS="${CFLAGS}"
+ USE_ZLIB=1 USE_CPU_AFFINITY=1 CC="${CC}" DEBUG_CFLAGS="" OPTIONS_CFLAGS="${CFLAGS}"
OPTIONS_DEFINE= DOCS EXAMPLES LUA OPENSSL DEVICEATLAS
OPTIONS_RADIO= PCRE
diff --git a/net/haproxy/files/patch-Makefile b/net/haproxy/files/patch-Makefile
new file mode 100644
index 000000000000..3c74b35769c9
--- /dev/null
+++ b/net/haproxy/files/patch-Makefile
@@ -0,0 +1,11 @@
+--- Makefile.orig 2017-04-19 13:18:14.404480000 +0300
++++ Makefile 2017-04-19 13:18:26.684393000 +0300
+@@ -128,7 +128,7 @@ DEBUG_CFLAGS = -g
+ #### Compiler-specific flags that may be used to disable some negative over-
+ # optimization or to silence some warnings. -fno-strict-aliasing is needed with
+ # gcc >= 4.4.
+-SPEC_CFLAGS = -fno-strict-aliasing -Wdeclaration-after-statement
++SPEC_CFLAGS = -fno-strict-aliasing -Wdeclaration-after-statement -fwrapv
+
+ #### Memory usage tuning
+ # If small memory footprint is required, you can reduce the buffer size. There