aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2015-07-20 21:03:15 +0800
committerbapt <bapt@FreeBSD.org>2015-07-20 21:03:15 +0800
commit617546c255d8194e3391c619203f58b043fb52a7 (patch)
tree63eca285342c21507b4f067d1c05a8f7a2a9469f /net
parent61e302bc23ee8d8925d117de3dc5588d916f5207 (diff)
downloadfreebsd-ports-gnome-617546c255d8194e3391c619203f58b043fb52a7.tar.gz
freebsd-ports-gnome-617546c255d8194e3391c619203f58b043fb52a7.tar.zst
freebsd-ports-gnome-617546c255d8194e3391c619203f58b043fb52a7.zip
Fix with custom SYSCONF_DIR and fix qa tests
Change the home directory of the quagga user to /var/empty which prevent QA First the home does not need to be harcoded to /usr/local/etc/quagga, second it fixes issues where the home created by the user addition is 755 then the plist modifies it to 750 Reviewed by: mat Approved by: mat (maintainer) Sponsored by: gandi.net Differential Revision: https://reviews.freebsd.org/D3135
Diffstat (limited to 'net')
-rw-r--r--net/quagga/Makefile4
-rw-r--r--net/quagga/pkg-plist2
2 files changed, 3 insertions, 3 deletions
diff --git a/net/quagga/Makefile b/net/quagga/Makefile
index 56a6c98f3531..787dd26d6f7b 100644
--- a/net/quagga/Makefile
+++ b/net/quagga/Makefile
@@ -3,7 +3,7 @@
PORTNAME= quagga
PORTVERSION= 0.99.24.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net ipv6
MASTER_SITES= SAVANNAH
@@ -102,6 +102,6 @@ pre-everything::
post-install:
${MKDIR} ${STAGEDIR}${LOCALSTATE_DIR} ${STAGEDIR}${SYSCONF_DIR} \
${STAGEDIR}${EXAMPLESDIR}
- @${MV} ${STAGEDIR}${ETCDIR}/* ${STAGEDIR}${EXAMPLESDIR}
+ @${MV} ${STAGEDIR}${SYSCONF_DIR}/* ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.mk>
diff --git a/net/quagga/pkg-plist b/net/quagga/pkg-plist
index 80dcb9f43661..81afca378203 100644
--- a/net/quagga/pkg-plist
+++ b/net/quagga/pkg-plist
@@ -95,4 +95,4 @@ sbin/zebra
%%EXAMPLESDIR%%/vtysh.conf.sample
%%EXAMPLESDIR%%/zebra.conf.sample
@dir(%%ENABLE_USER%%,%%ENABLE_GROUP%%,750) %%LOCALSTATE_DIR%%
-@dir(%%ENABLE_USER%%,%%ENABLE_GROUP%%,750) %%ETCDIR%%
+@dir(%%ENABLE_USER%%,%%ENABLE_GROUP%%,750) %%SYSCONF_DIR%%