aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2001-03-20 03:14:32 +0800
committersobomax <sobomax@FreeBSD.org>2001-03-20 03:14:32 +0800
commit633461bbbf180655e5c8ddf98e24dee79cc0edb1 (patch)
tree85a32b8ddaf7475e1663dc2257416fefa14d132b /net
parente7745d987aeedde91b779ffb2cf9cae927a5d27d (diff)
downloadfreebsd-ports-gnome-633461bbbf180655e5c8ddf98e24dee79cc0edb1.tar.gz
freebsd-ports-gnome-633461bbbf180655e5c8ddf98e24dee79cc0edb1.tar.zst
freebsd-ports-gnome-633461bbbf180655e5c8ddf98e24dee79cc0edb1.zip
Use IGNORE macros to bug user that he/she has to manually download distfile
instead of failing rule. This will prevent bento from trying to build the port. Submitted by: bento
Diffstat (limited to 'net')
-rw-r--r--net/socks5/Makefile13
1 files changed, 3 insertions, 10 deletions
diff --git a/net/socks5/Makefile b/net/socks5/Makefile
index b1a2d3095ce3..a4206f69391c 100644
--- a/net/socks5/Makefile
+++ b/net/socks5/Makefile
@@ -36,15 +36,8 @@ MAN1= runsocks.1 socks5.1 stopsocks.1 socks5_clients.1
MAN5= libsocks5.conf.5 socks5.conf.5
CONFIGURE_ENV= LIBS=-lcrypt
-do-fetch:
- @if [ ! -f ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX} ]; then \
- ${ECHO} ""; \
- ${ECHO} "NEC requires that you grab the dist files from their"; \
- ${ECHO} "web site at http://www.socks.nec.com. Please make sure"; \
- ${ECHO} "you have ${DISTNAME}${EXTRACT_SUFX} in ${DISTDIR}"; \
- ${ECHO} "and run make again."; \
- ${ECHO} ""; \
- exit 1;\
- fi
+.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
+IGNORE="NEC requires that you grab the dist files from their web site at http://www.socks.nec.com. Please make sure you have ${DISTNAME}${EXTRACT_SUFX} in ${DISTDIR} and run make again."
+.endif
.include <bsd.port.mk>