aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2001-09-02 02:52:48 +0800
committerlioux <lioux@FreeBSD.org>2001-09-02 02:52:48 +0800
commit64e5821660f11b28a765315d5715d896cb379a48 (patch)
treee6b3892cca827f515f8f1f8a9441cd464c11fefa /net
parent5068f3a2ffa6d31d2f82328e2f04cacc4734bf76 (diff)
downloadfreebsd-ports-gnome-64e5821660f11b28a765315d5715d896cb379a48.tar.gz
freebsd-ports-gnome-64e5821660f11b28a765315d5715d896cb379a48.tar.zst
freebsd-ports-gnome-64e5821660f11b28a765315d5715d896cb379a48.zip
New port punkbuster version 0.0.956: Punkbuster is designed against
cheating at multiplayer online games
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/punkbuster/Makefile93
-rw-r--r--net/punkbuster/distinfo1
-rw-r--r--net/punkbuster/pkg-comment1
-rw-r--r--net/punkbuster/pkg-descr13
-rw-r--r--net/punkbuster/pkg-message6
-rw-r--r--net/punkbuster/pkg-plist23
7 files changed, 138 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index d18d97122ddb..362d7f333fdb 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -310,6 +310,7 @@
SUBDIR += priss
SUBDIR += proxy
SUBDIR += proxy-suite
+ SUBDIR += punkbuster
SUBDIR += punkbuster-data
SUBDIR += pvm
SUBDIR += pvm++
diff --git a/net/punkbuster/Makefile b/net/punkbuster/Makefile
new file mode 100644
index 000000000000..08da34a1e8a3
--- /dev/null
+++ b/net/punkbuster/Makefile
@@ -0,0 +1,93 @@
+# New ports collection makefile for: punkbuster anti cheat server
+# Date created: 29 Mar 2001
+# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= punkbuster
+PORTVERSION= 0.0.956
+CATEGORIES= net linux
+MASTER_SITES= http://www.punkbuster.com/downloads/
+DISTNAME= pbsv${PORTVERSION:E}
+DIST_SUBDIR= punkbuster
+
+MAINTAINER= lioux@FreeBSD.org
+
+RUN_DEPENDS= ${LINUXBASE}${PUNKBUSTER_DIR}${PUNKBUSTER_DATA}:${PUNKBUSTER_DATA_PORT}
+
+NO_PACKAGE= the software terms do not allow non-standard\
+ ${PORTNAME} distributions
+
+USE_LINUX_PREFIX= yes
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+PLIST_SUB= PUNKBUSTER_DIR="${PUNKBUSTER_DIR:S/^\///}" \
+ PUNKBUSTER_DOC_DIR="${PUNKBUSTER_DOC_DIR}"
+
+INSTALL_DIR= ${INSTALL} -d -o ${BINOWN} -g ${BINGRP} -m ${BINMODE}
+SORT?= /usr/bin/sort
+STRIP_LINUX= ${LINUXBASE}/usr/bin/strip
+
+PUNKBUSTER_DIR= /usr/games/punkbuster/
+PUNKBUSTER_PROGRAM= pb
+PUNKBUSTER_DATA_PORT= ../punkbuster-data
+PUNKBUSTER_DATA!= cd ${PUNKBUSTER_DATA_PORT} && ${MAKE} -V PUNKBUSTER_DATA
+PUNKBUSTER_DATA_DISTFILES!= cd ${PUNKBUSTER_DATA_PORT} && ${MAKE} -V DISTFILES
+PUNKBUSTER_DOC_DIR= usr/doc/${PKGNAME}/
+
+pre-everything: pkgmessage-output
+
+post-extract:
+.for file in ${PUNKBUSTER_DATA_DISTFILES}
+ @${RM} ${WRKSRC}/${file}
+.endfor
+
+post-patch:
+.for extension in cfg htm ini pbq txt
+ @${PERL} -pi -ne "s!\r\n!\n!" ${WRKSRC}/*.${extension}
+.endfor
+ @${PERL} -pi -ne "s!\r\n!\n!" ${WRKSRC}/README
+
+install-parse-plist: generate-plist
+ @${PERL} -e 'open(FHANDLER,"${TMPPLIST}");' \
+ -e 'open(FDIR,">${WRKDIR}/dirs.sh.tmp");' \
+ -e 'open(FFILES,">${WRKDIR}/files.sh");' \
+ -e 'while (!eof(FHANDLER)) {' \
+ -e 'chop($$file = <FHANDLER>);' \
+ -e '$$dir = $$file_partial = $$file;' \
+ -e '$$file_partial =~ s!^(${PUNKBUSTER_DIR:S/^\///}|${PUNKBUSTER_DOC_DIR})!!;' \
+ -e 'print FDIR "${INSTALL_DIR}", \
+ " ", "\"${PREFIX}/$$dir\"", \
+ "\n" if $$dir =~ s!(^\@dirrm\s+)!!;' \
+ -e 'print FFILES "${INSTALL_DATA}", \
+ " ", "\"${WRKSRC}/$$file_partial\"", \
+ " ", "\"${PREFIX}/$$file\" || true", \
+ "\n" if ($$file !~ m!^\@!);' \
+ -e '}' \
+ -e 'close(FFILES);' \
+ -e 'close(FDIR);' \
+ -e 'close(FHANDLER);'
+
+install-scripts:
+ @${INSTALL_DIR} ${PREFIX}${PUNKBUSTER_DIR}
+ @${SORT} ${WRKDIR}/dirs.sh.tmp > ${WRKDIR}/dirs.sh
+ @${SH} ${WRKDIR}/dirs.sh
+ @${SH} ${WRKDIR}/files.sh 2>/dev/true
+
+pkgmessage-output:
+ @${CAT} ${PKGMESSAGE}
+
+do-install: install-parse-plist install-scripts pkgmessage-output
+ @${CAT} ${PKGMESSAGE}
+
+ @${INSTALL_DATA} ${WRKSRC}/pbsvhl.cfg \
+ ${PREFIX}${PUNKBUSTER_DIR}/pbsvhl.cfg.sample
+.if !exists(${PREFIX}${PUNKBUSTER_DIR}/pbsvhl.cfg)
+ @${INSTALL_DATA} ${WRKSRC}/pbsvhl.cfg ${PREFIX}${PUNKBUSTER_DIR}
+.endif
+# humm, can we strip or the program will complain that the checksum changed?
+ @${STRIP_LINUX} ${PREFIX}${PUNKBUSTER_DIR}${PUNKBUSTER_PROGRAM}
+ @${CHMOD} ${BINMODE} ${PREFIX}${PUNKBUSTER_DIR}${PUNKBUSTER_PROGRAM}
+
+.include <bsd.port.mk>
diff --git a/net/punkbuster/distinfo b/net/punkbuster/distinfo
new file mode 100644
index 000000000000..92365e83e594
--- /dev/null
+++ b/net/punkbuster/distinfo
@@ -0,0 +1 @@
+MD5 (punkbuster/pbsv956.tar.gz) = f1861ac3469b81102e42b5614422bb4c
diff --git a/net/punkbuster/pkg-comment b/net/punkbuster/pkg-comment
new file mode 100644
index 000000000000..5f6ce078be4a
--- /dev/null
+++ b/net/punkbuster/pkg-comment
@@ -0,0 +1 @@
+Punkbuster is designed against cheating at multiplayer online games
diff --git a/net/punkbuster/pkg-descr b/net/punkbuster/pkg-descr
new file mode 100644
index 000000000000..a7f327e04c2e
--- /dev/null
+++ b/net/punkbuster/pkg-descr
@@ -0,0 +1,13 @@
+[from developer's web site]
+PunkBuster is a client/server software system that is designed to
+provide an online countermeasures system against cheating at
+multiplayer online games - specifically, games and mods based on
+the Half-Life engine by VALVe software.
+
+Additionally, PunkBuster has a global Clan Tag Registry system
+built in to allow Clans to register their Clan Tags for protection
+on monitored servers. This prevents people from wearing their clan
+tag who aren't really in the clan. The list of registered tags is
+stored on our publicly accessible Internet website.
+
+WWW: http://www.punkbuster.com/
diff --git a/net/punkbuster/pkg-message b/net/punkbuster/pkg-message
new file mode 100644
index 000000000000..abebbd9d2f72
--- /dev/null
+++ b/net/punkbuster/pkg-message
@@ -0,0 +1,6 @@
+ ATTENTIONATTENTION:
+
+DO NOT forget to read Punkbuster Software Terms.
+Ignorance is not an excuse. :-)
+
+http://www.punkbuster.com/softwareterms.html
diff --git a/net/punkbuster/pkg-plist b/net/punkbuster/pkg-plist
new file mode 100644
index 000000000000..f57f8bf7c4db
--- /dev/null
+++ b/net/punkbuster/pkg-plist
@@ -0,0 +1,23 @@
+%%PORTDOCS%%%%PUNKBUSTER_DOC_DIR%%README
+%%PORTDOCS%%%%PUNKBUSTER_DOC_DIR%%clreadme.txt
+%%PORTDOCS%%%%PUNKBUSTER_DOC_DIR%%cstags.htm
+%%PORTDOCS%%%%PUNKBUSTER_DOC_DIR%%dodtags.htm
+%%PORTDOCS%%%%PUNKBUSTER_DOC_DIR%%fatags.htm
+%%PORTDOCS%%%%PUNKBUSTER_DOC_DIR%%flftags.htm
+%%PORTDOCS%%%%PUNKBUSTER_DOC_DIR%%hltags.htm
+%%PORTDOCS%%%%PUNKBUSTER_DOC_DIR%%master.htm
+%%PORTDOCS%%%%PUNKBUSTER_DOC_DIR%%readme.txt
+%%PORTDOCS%%%%PUNKBUSTER_DOC_DIR%%tfctags.htm
+%%PORTDOCS%%%%PUNKBUSTER_DOC_DIR%%wiztags.htm
+%%PUNKBUSTER_DIR%%pb
+%%PUNKBUSTER_DIR%%pb.ini
+%%PUNKBUSTER_DIR%%pbclhl.dll
+%%PUNKBUSTER_DIR%%pbclhl.so
+%%PUNKBUSTER_DIR%%pbsvhl.cfg
+%%PUNKBUSTER_DIR%%pbsvhl.so
+%%PUNKBUSTER_DIR%%sample.pbq
+@unexec cmp -s %D/%%PUNKBUSTER_DIR%%/pbsvhl.cfg.sample %D/%%PUNKBUSTER_DIR%%/pbsvhl.cfg && rm -f %D/%%PUNKBUSTER_DIR%%/pbsvhl.cfg ; || echo "If you are permanently removing this port, you should also do an \`\`rm ${PKG_PREFIX}/%%PUNKBUSTER_DIR%%/pbsvhl.cfg'' to remove any configuration files left." | fmt
+%%PUNKBUSTER_DIR%%pbsvhl.cfg.sample
+@exec [ -f %D/%%PUNKBUSTER_DIR%%/pbsvhl.cfg ] || cp -p %D/%%PUNKBUSTER_DIR%%/pbsvhl.cfg.sample %D/%%PUNKBUSTER_DIR%%/pbsvhl.cfg
+@unexec rmdir %D/%%PUNKBUSTER_DIR%% 2>/dev/null || echo "If you are permanently removing this port, you should also do an \`\`rm -Rf ${PKG_PREFIX}/%%PUNKBUSTER_DIR%%'' to remove any data files left. DO NOT forget to remove the punkbuster-data port first." | fmt
+%%PORTDOCS%%@dirrm %%PUNKBUSTER_DOC_DIR%%