aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorjedgar <jedgar@FreeBSD.org>2000-11-15 08:22:24 +0800
committerjedgar <jedgar@FreeBSD.org>2000-11-15 08:22:24 +0800
commit6c7a8ed80acb1a6fb12bac3a8907e429b5ad9c23 (patch)
treeb0d9a9577495b6bde3f0141aba6b51865ceaa1b3 /net
parentf327751bd4922b83683c9ac1157f3cc554d067a9 (diff)
downloadfreebsd-ports-gnome-6c7a8ed80acb1a6fb12bac3a8907e429b5ad9c23.tar.gz
freebsd-ports-gnome-6c7a8ed80acb1a6fb12bac3a8907e429b5ad9c23.tar.zst
freebsd-ports-gnome-6c7a8ed80acb1a6fb12bac3a8907e429b5ad9c23.zip
- Fix buffer overflow when parsing HTML tags.
- Bump PORTREVISION Approved by: Maintainer Obtained from: Stan Bubrouski <stan@CCS.NEU.EDU> (via Bugtraq)
Diffstat (limited to 'net')
-rw-r--r--net/gaim-snapshot/Makefile1
-rw-r--r--net/gaim-snapshot/files/patch-ad19
-rw-r--r--net/gaim/Makefile1
-rw-r--r--net/gaim/files/patch-ad19
4 files changed, 40 insertions, 0 deletions
diff --git a/net/gaim-snapshot/Makefile b/net/gaim-snapshot/Makefile
index 62a68afd6baf..033d7f3fb05b 100644
--- a/net/gaim-snapshot/Makefile
+++ b/net/gaim-snapshot/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gaim
PORTVERSION= 0.10.3
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= ftp://ftp.marko.net/pub/gaim/ \
${MASTER_SITE_SOURCEFORGE}
diff --git a/net/gaim-snapshot/files/patch-ad b/net/gaim-snapshot/files/patch-ad
new file mode 100644
index 000000000000..ba20344ce77b
--- /dev/null
+++ b/net/gaim-snapshot/files/patch-ad
@@ -0,0 +1,19 @@
+--- src/gtkhtml.c.orig Mon Oct 9 13:34:59 2000
++++ src/gtkhtml.c Tue Nov 14 17:28:27 2000
+@@ -3251,7 +3251,7 @@
+ GdkFont *cfont;
+ GdkRectangle area;
+ char *ws,
+- tag[BUF_LONG],
++ *tag,
+ *c,
+ *url = NULL;
+ gint intag = 0,
+@@ -3295,6 +3295,7 @@
+ c = text;
+
+ ws = g_malloc(strlen(text) + 2);
++ tag = g_malloc(strlen(text) + 2);
+
+ while (*c)
+ {
diff --git a/net/gaim/Makefile b/net/gaim/Makefile
index 62a68afd6baf..033d7f3fb05b 100644
--- a/net/gaim/Makefile
+++ b/net/gaim/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gaim
PORTVERSION= 0.10.3
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= ftp://ftp.marko.net/pub/gaim/ \
${MASTER_SITE_SOURCEFORGE}
diff --git a/net/gaim/files/patch-ad b/net/gaim/files/patch-ad
new file mode 100644
index 000000000000..ba20344ce77b
--- /dev/null
+++ b/net/gaim/files/patch-ad
@@ -0,0 +1,19 @@
+--- src/gtkhtml.c.orig Mon Oct 9 13:34:59 2000
++++ src/gtkhtml.c Tue Nov 14 17:28:27 2000
+@@ -3251,7 +3251,7 @@
+ GdkFont *cfont;
+ GdkRectangle area;
+ char *ws,
+- tag[BUF_LONG],
++ *tag,
+ *c,
+ *url = NULL;
+ gint intag = 0,
+@@ -3295,6 +3295,7 @@
+ c = text;
+
+ ws = g_malloc(strlen(text) + 2);
++ tag = g_malloc(strlen(text) + 2);
+
+ while (*c)
+ {