aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorpi <pi@FreeBSD.org>2014-08-04 17:31:05 +0800
committerpi <pi@FreeBSD.org>2014-08-04 17:31:05 +0800
commit6ca9392f742e6500913fbbd73152e27d7544464b (patch)
tree78fca4404aa38d5cbd1ce63885e8eaeefccf31c4 /net
parentfcd6f8d75ee7bc70a90e313077df0bf705f4a56f (diff)
downloadfreebsd-ports-gnome-6ca9392f742e6500913fbbd73152e27d7544464b.tar.gz
freebsd-ports-gnome-6ca9392f742e6500913fbbd73152e27d7544464b.tar.zst
freebsd-ports-gnome-6ca9392f742e6500913fbbd73152e27d7544464b.zip
net/whois: 5.0.23 -> 5.1.4, unbreak, passing maintainership to submitter
PR: 190799 Submitted by: coco@executive-computing.de Approved by: lapo@lapo.it (old maintainer)
Diffstat (limited to 'net')
-rw-r--r--net/whois/Makefile18
-rw-r--r--net/whois/distinfo4
-rw-r--r--net/whois/files/patch-Makefile10
-rw-r--r--net/whois/files/patch-config.h11
-rw-r--r--net/whois/files/patch-mkpasswd.c12
-rw-r--r--net/whois/files/patch-po_Makefile6
-rw-r--r--net/whois/files/patch-whois.175
-rw-r--r--net/whois/files/patch-whois.conf.529
-rw-r--r--net/whois/pkg-plist3
9 files changed, 154 insertions, 14 deletions
diff --git a/net/whois/Makefile b/net/whois/Makefile
index 9daf3deb2c3b..9d91a96f9e83 100644
--- a/net/whois/Makefile
+++ b/net/whois/Makefile
@@ -2,19 +2,17 @@
# $FreeBSD$
PORTNAME= whois
-PORTVERSION= 5.0.23
+PORTVERSION= 5.1.4
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_DEBIAN_POOL}
DISTNAME= ${PORTNAME}_${PORTVERSION}
-MAINTAINER= lapo@lapo.it
+MAINTAINER= coco@executive-computing.de
COMMENT= Marco d'Itri whois client
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-BROKEN= Unfetchable
-
USES= iconv gmake perl5 tar:xz
USE_PERL5= build
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
@@ -28,11 +26,21 @@ NLS_USES= gettext
.include <bsd.port.options.mk>
post-patch:
- @${REINPLACE_CMD} -e "s|%%LOCALBASE%%|${LOCALBASE}|g" ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e "s|%%MWHOISCONF%%|${PREFIX}/etc/mwhois.conf|g" ${WRKSRC}/whois.1
+ @${REINPLACE_CMD} -e "s|%%MWHOIS%%|mwhois|g" ${WRKSRC}/whois.1
+ @${REINPLACE_CMD} -e "s|%%MWHOIST%%|MWHOIS|g" ${WRKSRC}/whois.1
+ @${REINPLACE_CMD} -e "s|%%MWHOIST%%|MWHOIS|g" ${WRKSRC}/whois.conf.5
+ @${REINPLACE_CMD} -e "s|%%MWHOIS%%|mwhois|g" ${WRKSRC}/whois.conf.5
+ @${REINPLACE_CMD} -e "s|%%MWHOISCONF%%|${PREFIX}/etc/mwhois.conf|g" ${WRKSRC}/whois.conf.5
+ @${REINPLACE_CMD} -e "s|%%MWHOISCONF%%|${PREFIX}/etc/mwhois.conf|g" ${WRKSRC}/config.h
.if ! ${PORT_OPTIONS:MNLS}
@${REINPLACE_CMD} -e "s| pos||" -e "s| install-pos||" \
-e "s|-lintl||" ${WRKSRC}/Makefile
@${REINPLACE_CMD} -e "s|# define ENABLE_NLS||" ${WRKSRC}/config.h
.endif
+post-stage:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/mwhois
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/mkpasswd
+
.include <bsd.port.mk>
diff --git a/net/whois/distinfo b/net/whois/distinfo
index f5fe2c0eab99..74d622885713 100644
--- a/net/whois/distinfo
+++ b/net/whois/distinfo
@@ -1,2 +1,2 @@
-SHA256 (whois_5.0.23.tar.xz) = 6b486a42a4aa83b5f921083d518176726b6d2d903bc8dab5c6126ebe2bea1bf1
-SIZE (whois_5.0.23.tar.xz) = 70116
+SHA256 (whois_5.1.4.tar.xz) = 678f8677d0e2d4836b14c8e95ad875ec569cec282572635f920888462cc5daef
+SIZE (whois_5.1.4.tar.xz) = 76804
diff --git a/net/whois/files/patch-Makefile b/net/whois/files/patch-Makefile
index cb73e3c22c4a..b25babf7bff3 100644
--- a/net/whois/files/patch-Makefile
+++ b/net/whois/files/patch-Makefile
@@ -1,5 +1,5 @@
---- Makefile.orig 2013-03-30 02:31:42.000000000 +0100
-+++ Makefile 2014-01-20 18:16:15.000000000 +0100
+--- Makefile.orig 2014-05-21 16:24:13.000000000 +0200
++++ Makefile 2014-06-08 18:14:09.000000000 +0200
@@ -1,6 +1,8 @@
-prefix = /usr
+prefix = ${PREFIX}
@@ -10,16 +10,20 @@
PERL = perl
INSTALL = install
-@@ -92,15 +94,15 @@
+@@ -98,17 +100,17 @@
install-whois: whois
$(INSTALL) -d $(BASEDIR)$(prefix)/bin/
- $(INSTALL) -d $(BASEDIR)$(prefix)/share/man/man1/
+- $(INSTALL) -d $(BASEDIR)$(prefix)/share/man/man5/
- $(INSTALL) -m 0755 whois $(BASEDIR)$(prefix)/bin/
- $(INSTALL) -m 0644 whois.1 $(BASEDIR)$(prefix)/share/man/man1/
+- $(INSTALL) -m 0644 whois.conf.5 $(BASEDIR)$(prefix)/share/man/man5/
+ $(INSTALL) -d $(BASEDIR)$(prefix)/man/man1/
++ $(INSTALL) -d $(BASEDIR)$(prefix)/man/man5/
+ $(INSTALL) -m 0755 whois $(BASEDIR)$(prefix)/bin/mwhois
+ $(INSTALL) -m 0644 whois.1 $(BASEDIR)$(prefix)/man/man1/mwhois.1
++ $(INSTALL) -m 0644 whois.conf.5 $(BASEDIR)$(prefix)/man/man5/mwhois.conf.5
install-mkpasswd: mkpasswd
$(INSTALL) -d $(BASEDIR)$(prefix)/bin/
diff --git a/net/whois/files/patch-config.h b/net/whois/files/patch-config.h
new file mode 100644
index 000000000000..58e2bc16c986
--- /dev/null
+++ b/net/whois/files/patch-config.h
@@ -0,0 +1,11 @@
+--- config.h.orig 2014-06-08 18:25:19.000000000 +0200
++++ config.h 2014-06-08 18:25:39.000000000 +0200
+@@ -8,7 +8,7 @@
+
+ /* Configuration file */
+ /*
+-#define CONFIG_FILE "/etc/whois.conf"
++#define CONFIG_FILE "%%MWHOISCONF%%"
+ */
+
+
diff --git a/net/whois/files/patch-mkpasswd.c b/net/whois/files/patch-mkpasswd.c
new file mode 100644
index 000000000000..06fc9b9f8f23
--- /dev/null
+++ b/net/whois/files/patch-mkpasswd.c
@@ -0,0 +1,12 @@
+--- mkpasswd.orig 2014-06-08 17:57:46.000000000 +0200
++++ mkpasswd.c 2014-06-08 17:58:02.000000000 +0200
+@@ -17,7 +17,9 @@
+ */
+
+ /* for crypt, snprintf and strcasecmp */
++#ifndef __FreeBSD__
+ #define _XOPEN_SOURCE 500
++#endif
+ #define _BSD_SOURCE 1
+ #define __EXTENSIONS__ 1
+
diff --git a/net/whois/files/patch-po_Makefile b/net/whois/files/patch-po_Makefile
index 4161407cf29c..84f485cda04d 100644
--- a/net/whois/files/patch-po_Makefile
+++ b/net/whois/files/patch-po_Makefile
@@ -1,5 +1,5 @@
---- po/Makefile.orig 2013-03-30 02:31:41.000000000 +0100
-+++ po/Makefile 2014-01-20 17:52:17.051238058 +0100
+--- po/Makefile.orig 2014-06-08 18:22:54.000000000 +0200
++++ po/Makefile 2014-06-08 18:23:37.000000000 +0200
@@ -1,4 +1,4 @@
-prefix = /usr
+prefix = ${PREFIX}
@@ -10,7 +10,7 @@
POTFILES=../whois.c ../mkpasswd.c
-+.SUFFIXES: .po .mo
++.SUFFIXES: .po .mo
+
all: $(PACKAGE).pot $(CATALOGS)
diff --git a/net/whois/files/patch-whois.1 b/net/whois/files/patch-whois.1
new file mode 100644
index 000000000000..cde50d59ad66
--- /dev/null
+++ b/net/whois/files/patch-whois.1
@@ -0,0 +1,75 @@
+--- whois.1.orig 2013-12-26 07:48:10.000000000 +0100
++++ whois.1 2014-06-08 18:34:54.000000000 +0200
+@@ -1,8 +1,8 @@
+-.TH "WHOIS" "1" "20 December 2009" "Marco d'Itri" "Debian GNU/Linux"
++.TH "%%MWHOIST%%" "1" "20 December 2009" "Marco d'Itri" "Debian GNU/Linux"
+ .SH "NAME"
+-whois \- client for the whois directory service
++%%MWHOIS%% \- client for the whois directory service
+ .SH "SYNOPSIS"
+-.B whois
++.B %%MWHOIS%%
+ [\~{\~\fB\-h\fP | \fB\-\-host\fP\~}\~\fIHOST\fP\~]
+ [\~{\~\fB\-p\fP | \fB\-\-port\fP\~}\~\fIPORT\fP\~]
+ [\~\fB\-abBcdGHKlLmMrRx\fP\~]
+@@ -13,27 +13,27 @@
+ [\~\fB\-\-verbose\fP\~]
+ .I OBJECT
+
+-.B whois
++.B %%MWHOIS%%
+ .B \-q
+ .I KEYWORD
+
+-.B whois
++.B %%MWHOIS%%
+ .B \-t
+ .I TYPE
+
+-.B whois
++.B %%MWHOIS%%
+ .B \-v
+ .I TYPE
+
+-.B whois
++.B %%MWHOIS%%
+ .B \-\-help
+
+-.B whois
++.B %%MWHOIS%%
+ .B \-\-version
+
+ .PP
+ .SH "DESCRIPTION"
+-\fBwhois\fP searches for an object in a \fIRFC\ 3912\fP database.
++\fB%%MWHOIS%%\fP searches for an object in a \fIRFC\ 3912\fP database.
+
+ This version of the whois client tries to guess the right server to
+ ask for the specified object. If no guess can be made it will connect
+@@ -171,7 +171,7 @@
+ to be interpreted by the client should always follow the \fI\-\-\fP
+ separator (which marks the beginning of the query string).
+ .P
+-If the \fI/etc/whois.conf\fR configuration file exists, it will be consulted
++If the \fI%%MWHOISCONF%%\fR configuration file exists, it will be consulted
+ to find a server before applying the normal rules. Each line of the
+ file should contain a regular expression to be matched against the query
+ text and the whois server to use, separated by white space.
+@@ -186,7 +186,7 @@
+ Command line arguments will always be interpreted accordingly to the
+ current system locale and converted to the IDN ASCII Compatible Encoding.
+ .SH "FILES"
+-/etc/whois.conf
++%%MWHOISCONF%%
+ .SH "ENVIRONMENT"
+ .IP LANG
+ When querying \fIwhois.nic.ad.jp\fP and \fIwhois.jprs.jp\fP English text
+@@ -200,7 +200,7 @@
+ of objects are located. If the variable does not exist then
+ \fIwhois.arin.net\fP will be queried.
+ .SH "SEE ALSO"
+-\fBwhois.conf\fP(5)
++\fB%%MWHOISCONF%%\fP(5)
+ .PP
+ \fIRFC 3912\fP: WHOIS Protocol Specification
+ .PP
diff --git a/net/whois/files/patch-whois.conf.5 b/net/whois/files/patch-whois.conf.5
new file mode 100644
index 000000000000..0e1cd392e8a1
--- /dev/null
+++ b/net/whois/files/patch-whois.conf.5
@@ -0,0 +1,29 @@
+--- whois.conf.5.orig 2014-01-05 20:00:36.000000000 +0100
++++ whois.conf.5 2014-06-08 18:42:59.000000000 +0200
+@@ -1,10 +1,10 @@
+-.TH "WHOIS.CONF" "5" "9 April 2013" "Petr Písař" "Debian GNU/Linux"
++.TH "%%MWHOIST%%.CONF" "5" "9 April 2013" "Petr Písař" "Debian GNU/Linux"
+
+ .SH "NAME"
+-whois.conf \- alternative WHOIS servers list for whois client
++%%MWHOIS%%.conf \- alternative WHOIS servers list for whois client
+
+ .SH "SYNOPSIS"
+-.B /etc/whois.conf
++.B %%MWHOISCONF%%
+
+ .SH "DESCRIPTION"
+ This file contains a list of WHOIS servers which can augment or override
+@@ -37,10 +37,10 @@
+ ^as645(1[2-9]|2[0-9]|3[0-4])$ whois.example.net
+
+ .SH "FILES"
+-/etc/whois.conf
++%%MWHOISCONF%%
+
+ .SH "SEE ALSO"
+-\fBwhois\fP(1)
++\fB%%MWHOIS%%\fP(1)
+
+ .SH "AUTHOR"
+ This manual page was written by Petr Písař <\fIppisar@redhat.com\fP>
diff --git a/net/whois/pkg-plist b/net/whois/pkg-plist
index fb1a8c46784c..ce2ccc548666 100644
--- a/net/whois/pkg-plist
+++ b/net/whois/pkg-plist
@@ -2,6 +2,7 @@ bin/mkpasswd
bin/mwhois
man/man1/mkpasswd.1.gz
man/man1/mwhois.1.gz
+man/man5/mwhois.conf.5.gz
%%NLS%%share/locale/cs/LC_MESSAGES/whois.mo
%%NLS%%share/locale/da/LC_MESSAGES/whois.mo
%%NLS%%share/locale/de/LC_MESSAGES/whois.mo
@@ -12,7 +13,7 @@ man/man1/mwhois.1.gz
%%NLS%%share/locale/fr/LC_MESSAGES/whois.mo
%%NLS%%share/locale/it/LC_MESSAGES/whois.mo
%%NLS%%share/locale/ja/LC_MESSAGES/whois.mo
-%%NLS%%share/locale/no/LC_MESSAGES/whois.mo
+%%NLS%%share/locale/nb/LC_MESSAGES/whois.mo
%%NLS%%share/locale/pl/LC_MESSAGES/whois.mo
%%NLS%%share/locale/pt_BR/LC_MESSAGES/whois.mo
%%NLS%%share/locale/ru/LC_MESSAGES/whois.mo