aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorbrooks <brooks@FreeBSD.org>2013-10-18 22:33:34 +0800
committerbrooks <brooks@FreeBSD.org>2013-10-18 22:33:34 +0800
commit6e8cf61826f86dfc820c001bc122fab6b26e14ad (patch)
tree0a6f25d3e945469b3be16830e6bb7aeb83e48eb7 /net
parentac803938a57d852f24f94b94ff8150513352ba3b (diff)
downloadfreebsd-ports-gnome-6e8cf61826f86dfc820c001bc122fab6b26e14ad.tar.gz
freebsd-ports-gnome-6e8cf61826f86dfc820c001bc122fab6b26e14ad.tar.zst
freebsd-ports-gnome-6e8cf61826f86dfc820c001bc122fab6b26e14ad.zip
STAGIFY
Allow to build on amd64 and ia64 since pvm has had shared libs on all platforms for quite some time. Mark DEPRECATED as it seems unlikely there are any actual users given that it hasn't worked on amd64 ever and the upstream hasn't made any changes for 8 years or so. Drop maintainership.
Diffstat (limited to 'net')
-rw-r--r--net/pypvm/Makefile25
1 files changed, 10 insertions, 15 deletions
diff --git a/net/pypvm/Makefile b/net/pypvm/Makefile
index c1fde8513492..171c3d51144f 100644
--- a/net/pypvm/Makefile
+++ b/net/pypvm/Makefile
@@ -6,11 +6,14 @@ PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= SF
-MAINTAINER= brooks@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= PVM for Python
BUILD_DEPENDS= pvm:${PORTSDIR}/net/pvm
+DEPRECATED= Dead upstream and suspected that there are no users of port
+EXPIRATION_DATE= 2014-01-01
+
USE_PYTHON= yes
USE_PYDISTUTILS=yes
@@ -22,24 +25,16 @@ EXAMPLEFILES= master_test.py \
slave_test.py
PLIST_FILES+= ${EXAMPLEFILES:S|^|%%EXAMPLESDIR%%/|}
PLIST_DIRS+= %%EXAMPLESDIR%%
-.if !defined(NOPORTDOCS)
PORTDOCS= ChangeLog \
README
-.endif
-
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "ia64" || ${ARCH} == "amd64"
-BROKEN= pvm port needs to provide shared libraries
-.endif
post-install:
- ${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_SCRIPT} ${EXAMPLEFILES:S|^|${WRKSRC}/|} ${EXAMPLESDIR}
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_SCRIPT} ${EXAMPLEFILES:S|^|${WRKSRC}/|} \
+ ${STAGEDIR}${EXAMPLESDIR}
.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>