aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2018-11-07 01:17:33 +0800
committergarga <garga@FreeBSD.org>2018-11-07 01:17:33 +0800
commit70000612b621245b2aabbca3c9bf2c4a52c4e82f (patch)
tree2a1b3af064c7fc63eee9771f3abaf35c7c7cbd24 /net
parent51a514e47761c588eab63bf8a1101c92419cf904 (diff)
downloadfreebsd-ports-gnome-70000612b621245b2aabbca3c9bf2c4a52c4e82f.tar.gz
freebsd-ports-gnome-70000612b621245b2aabbca3c9bf2c4a52c4e82f.tar.zst
freebsd-ports-gnome-70000612b621245b2aabbca3c9bf2c4a52c4e82f.zip
- Do not include deprecated header sys/capability.h [1]
- Remove unnecessary include of bsd.port.pre.mk - Add LICENSE_FILE - Fix USES order - Bump PORTREVISION PR: 233008 [1] Reported by: emaste@ [1] Sponsored by: Rubicon Communications, LLC (Netgate)
Diffstat (limited to 'net')
-rw-r--r--net/tcpdump/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/net/tcpdump/Makefile b/net/tcpdump/Makefile
index b9161af83852..0ac0b2678b9f 100644
--- a/net/tcpdump/Makefile
+++ b/net/tcpdump/Makefile
@@ -3,7 +3,7 @@
PORTNAME= tcpdump
PORTVERSION= 4.9.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net ipv6
MASTER_SITES= http://www.tcpdump.org/release/
@@ -11,12 +11,13 @@ MAINTAINER= garga@FreeBSD.org
COMMENT= Ubiquitous network traffic analysis tool
LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libpcap.so.1:net/libpcap
-GNU_CONFIGURE= yes
USES= gmake
+GNU_CONFIGURE= yes
UNPRIV_USER?= tcpdump
CHROOTDIR?= /var/run/tcpdump
@@ -44,7 +45,9 @@ CHROOT_CONFIGURE_ON= --with-chroot=${CHROOTDIR}
PLIST_FILES= sbin/tcpdump \
man/man1/tcpdump.1.gz
-.include <bsd.port.pre.mk>
+post-patch:
+ @${REINPLACE_CMD} -e 's,sys/capability.h,sys/capsicum.h,' \
+ ${WRKSRC}/tcpdump.c
post-configure:
@${REINPLACE_CMD} -e "s,\./\.\./${LIBPCAP_FORCE_VER}/libpcap\.a,${LOCALBASE}/lib/libpcap.so.1," \
@@ -54,4 +57,4 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/tcpdump ${STAGEDIR}/${PREFIX}/sbin
${INSTALL_MAN} ${WRKSRC}/tcpdump.1 ${STAGEDIR}/${MAN1PREFIX}/man/man1
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>