aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2011-08-07 01:05:18 +0800
committerswills <swills@FreeBSD.org>2011-08-07 01:05:18 +0800
commit731afc4148b64c901e99e9fa89571f03f8ce49ad (patch)
tree481d67b1267161c1104804a9081f03fa21ab93a7 /net
parent7159208892538e5782dd6680a39e2c69cb9d6b17 (diff)
downloadfreebsd-ports-gnome-731afc4148b64c901e99e9fa89571f03f8ce49ad.tar.gz
freebsd-ports-gnome-731afc4148b64c901e99e9fa89571f03f8ce49ad.tar.zst
freebsd-ports-gnome-731afc4148b64c901e99e9fa89571f03f8ce49ad.zip
Command line utilies for interacting with AMQP compliant queues.
The intention is provide simple management tools that can be used to complete ad hoc housework on an AMQP queue. In addition, simple scripts can be layered over the tools when needed. WWW: http://rubygems.org/gems/amqp-utils PR: ports/158816 Submitted by: Loic Pefferkorn <loic-freebsd at loicp.eu>
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/rubygem-amqp-utils/Makefile30
-rw-r--r--net/rubygem-amqp-utils/distinfo2
-rw-r--r--net/rubygem-amqp-utils/pkg-descr6
4 files changed, 39 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 7304e2acef1b..36ad12ba1330 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -948,6 +948,7 @@
SUBDIR += ruby-tcpsocketpipe
SUBDIR += ruby-tserver
SUBDIR += rubygem-amqp
+ SUBDIR += rubygem-amqp-utils
SUBDIR += rubygem-bunny
SUBDIR += rubygem-geoip
SUBDIR += rubygem-http_parser.rb
diff --git a/net/rubygem-amqp-utils/Makefile b/net/rubygem-amqp-utils/Makefile
new file mode 100644
index 000000000000..43d2a6edaa7b
--- /dev/null
+++ b/net/rubygem-amqp-utils/Makefile
@@ -0,0 +1,30 @@
+# Ports collection makefile for: rubygem-amqp-utils
+# Date created: 11 July 2011
+# Whom: Loic Pefferkorn <loic-freebsd@loicp.eu>
+#
+# $FreeBSD$
+
+PORTNAME= amqp-utils
+PORTVERSION= 0.4.3
+CATEGORIES= net rubygems
+MASTER_SITES= RG
+
+MAINTAINER= loic-freebsd@loicp.eu
+COMMENT= Command line utilies for interacting with AMQP compliant queues
+
+RUN_DEPENDS= rubygem-amqp>=0.7.1:${PORTSDIR}/net/rubygem-amqp \
+ rubygem-clio>=0.3.0:${PORTSDIR}/devel/rubygem-clio \
+ rubygem-facets>=2.9.1:${PORTSDIR}/devel/rubygem-facets \
+ rubygem-heredoc_unindent>=1.1.2:${PORTSDIR}/textproc/rubygem-heredoc_unindent \
+ rubygem-json>=1.5.3:${PORTSDIR}/devel/rubygem-json \
+ rubygem-msgpack>=0.4.5:${PORTSDIR}/devel/rubygem-msgpack \
+ rubygem-trollop>=1.16.2:${PORTSDIR}/devel/rubygem-trollop
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+PLIST_FILES+= bin/amqp-deleteq bin/amqp-dequeue bin/amqp-enqueue bin/amqp-peek bin/amqp-pop \
+ bin/amqp-purge bin/amqp-spy bin/amqp-statq bin/amqp-unbind
+
+.include <bsd.port.mk>
diff --git a/net/rubygem-amqp-utils/distinfo b/net/rubygem-amqp-utils/distinfo
new file mode 100644
index 000000000000..2f03de33c74f
--- /dev/null
+++ b/net/rubygem-amqp-utils/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/amqp-utils-0.4.3.gem) = ed251b25d044c7bbd00a2bb5b43e7a760bd725215d9e20b9eaf774b8664d1231
+SIZE (rubygem/amqp-utils-0.4.3.gem) = 11264
diff --git a/net/rubygem-amqp-utils/pkg-descr b/net/rubygem-amqp-utils/pkg-descr
new file mode 100644
index 000000000000..5617bb7f7a59
--- /dev/null
+++ b/net/rubygem-amqp-utils/pkg-descr
@@ -0,0 +1,6 @@
+Command line utilies for interacting with AMQP compliant queues.
+The intention is provide simple management tools that can be used to complete
+ad hoc housework on an AMQP queue.
+In addition, simple scripts can be layered over the tools when needed.
+
+WWW: http://rubygems.org/gems/amqp-utils