aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authordemon <demon@FreeBSD.org>2003-12-30 20:03:43 +0800
committerdemon <demon@FreeBSD.org>2003-12-30 20:03:43 +0800
commit753dfe282ed9b5e167ea946c85ce75243fe70ab7 (patch)
tree70b149fad730346fe93518ad974da0155c7a7d73 /net
parent40e507068ad17f60a513e1d1c160581594c69c74 (diff)
downloadfreebsd-ports-gnome-753dfe282ed9b5e167ea946c85ce75243fe70ab7.tar.gz
freebsd-ports-gnome-753dfe282ed9b5e167ea946c85ce75243fe70ab7.tar.zst
freebsd-ports-gnome-753dfe282ed9b5e167ea946c85ce75243fe70ab7.zip
Add WITH_PGSQL knob;
Minor general fixes.
Diffstat (limited to 'net')
-rw-r--r--net/jabberd/Makefile44
-rw-r--r--net/jabberd/files/patch-configure9
2 files changed, 32 insertions, 21 deletions
diff --git a/net/jabberd/Makefile b/net/jabberd/Makefile
index 739f06a1149a..654e27fd84ae 100644
--- a/net/jabberd/Makefile
+++ b/net/jabberd/Makefile
@@ -16,29 +16,49 @@ MAINTAINER= demon@FreeBSD.org
COMMENT= Online presence and instant messaging server
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-openssl=/usr \
- --with-libiconv-prefix=${LOCALBASE}
+CONFIGURE_ARGS= --with-libiconv-prefix=${LOCALBASE} \
+ --enable-storage='${STORAGE}' \
+ --enable-authreg='${AUTHREG}'
-.if defined(WITH_BDB)
-LIB_DEPENDS+= db41.1:${PORTSDIR}/databases/db41
-CONFIGURE_ARGS+=--with-berkeley-db=${LOCALBASE} \
- --enable-storage=db \
- --enable-authreg=db
-LDFLAGS+= -ldb41
-CFLAGS+= -I${LOCALBASE}/include/db41
+STORAGE+= fs
+AUTHREG+= anon pipe
+
+.if defined(WITH_PGSQL)
+LIB_DEPENDS+= pq.3:${PORTSDIR}/databases/postgresql-client
+CONFIGURE_ARGS+=--with-pgsql=${LOCALBASE}/include:${LOCALBASE}/lib
+STORAGE+= pgsql
+AUTHREG+= pgsql
.endif
.if defined(WITH_MYSQL)
USE_MYSQL= yes
-CONFIGURE_ARGS+=--with-mysql=${LOCALBASE} \
- --enable-storage=mysql \
- --enable-authreg=mysql
+CONFIGURE_ARGS+=--with-mysql=${LOCALBASE}/include/mysql:${LOCALBASE}/lib/mysql
+STORAGE+= mysql
+AUTHREG+= mysql
+.endif
+
+.if defined(WITH_BDB)
+LIB_DEPENDS+= db41.1:${PORTSDIR}/databases/db41
+CONFIGURE_ARGS+=--with-berkeley-db=${LOCALBASE}/include/db41:${LOCALBASE}/lib
+STORAGE+= db
+AUTHREG+= db
.endif
.if defined(WITH_LDAP)
USE_OPENLDAP= yes
+CONFIGURE_ARGS+=--with-ldap=${LOCALBASE}/include:${LOCALBASE}/lib
+AUTHREG+= ldap
.endif
MAN8= c2s.8 jabberd.8 resolver.8 router.8 s2s.8 sm.8
+pre-everything::
+ @${ECHO}
+ @${ECHO} "You can build jabberd with the following options:"
+ @${ECHO} "WITH_PGSQL use PostgreSQL for storage and authentication"
+ @${ECHO} "WITH_BDB use Berkeley DB for storage and authentication"
+ @${ECHO} "WITH_MYSQL use MySQL for storage and authentication"
+ @${ECHO} "WITH_LDAP use LDAP for authentication"
+ @${ECHO}
+
.include <bsd.port.mk>
diff --git a/net/jabberd/files/patch-configure b/net/jabberd/files/patch-configure
index 39311cb7a000..2ce43d89bc23 100644
--- a/net/jabberd/files/patch-configure
+++ b/net/jabberd/files/patch-configure
@@ -1,14 +1,5 @@
--- configure.orig Mon Dec 29 16:07:44 2003
+++ configure Mon Dec 29 16:07:56 2003
-@@ -23698,7 +23698,7 @@
- fi;
-
- if test "$places" = "search"; then
-- places="std /usr/local/include/db4:/usr/local/lib /usr/local
-+ places="std /usr/local/include/db41:/usr/local/lib /usr/local
- /usr/local/BerkeleyDB.4.1 /usr/include/db4:/usr/lib
- /sw/include/db4:/sw/lib"
- fi
@@ -23734,7 +23734,7 @@
;;
esac