aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorRyan Steinmetz <zi@FreeBSD.org>2019-09-11 05:49:57 +0800
committerRyan Steinmetz <zi@FreeBSD.org>2019-09-11 05:49:57 +0800
commit75b1f8cef4d791f83bfaea988e882ead812c40c6 (patch)
tree241bf600643989fadc8095d1b239d316f20c9376 /net
parentb9fc4923fa542f34551711d1fe0888c2e1dc5247 (diff)
downloadfreebsd-ports-gnome-75b1f8cef4d791f83bfaea988e882ead812c40c6.tar.gz
freebsd-ports-gnome-75b1f8cef4d791f83bfaea988e882ead812c40c6.tar.zst
freebsd-ports-gnome-75b1f8cef4d791f83bfaea988e882ead812c40c6.zip
New port: net/ip2proxy:
This library is the C programming language library to support all IP2Proxy™ BIN database products to query proxy IP address and its country, region, city, ISP name and proxy types. It has been optimized for speed and memory utilization. WWW: https://ip2location.com/development-libraries/ip2proxy/c
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/ip2proxy/Makefile29
-rw-r--r--net/ip2proxy/distinfo3
-rw-r--r--net/ip2proxy/pkg-descr6
-rw-r--r--net/ip2proxy/pkg-plist6
5 files changed, 45 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index f167ee308108..99cf87dc5701 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -269,6 +269,7 @@
SUBDIR += intel-ixl-kmod
SUBDIR += iodine
SUBDIR += ip2location
+ SUBDIR += ip2proxy
SUBDIR += ip6_int
SUBDIR += ipdecap
SUBDIR += ipgrab
diff --git a/net/ip2proxy/Makefile b/net/ip2proxy/Makefile
new file mode 100644
index 000000000000..91c2aa94b177
--- /dev/null
+++ b/net/ip2proxy/Makefile
@@ -0,0 +1,29 @@
+# Created by: Ryan Steinmetz <zi@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= ip2proxy
+PORTVERSION= 20190910
+CATEGORIES= net
+
+MAINTAINER= zi@FreeBSD.org
+COMMENT= C library to lookup proxies
+
+LICENSE= MIT
+
+USE_GITHUB= yes
+GH_ACCOUNT= ip2location
+GH_PROJECT= ${PORTNAME}-c
+GH_TAGNAME= 40abce6
+
+USES= autoreconf libtool
+HAS_CONFIGURE= yes
+USE_LDCONFIG= yes
+INSTALL_TARGET= install-strip
+
+post-patch:
+ ${CHMOD} +x ${WRKSRC}/configure
+
+post-install:
+ (cd ${WRKSRC} && ${MAKE} install-data DESTDIR=${STAGEDIR})
+
+.include <bsd.port.mk>
diff --git a/net/ip2proxy/distinfo b/net/ip2proxy/distinfo
new file mode 100644
index 000000000000..c0cae02cbbaf
--- /dev/null
+++ b/net/ip2proxy/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1568151757
+SHA256 (ip2location-ip2proxy-c-20190910-40abce6_GH0.tar.gz) = e016ab59376c90554df7712f20aca0f43697b90f12dd749dd8e7f30e4032e549
+SIZE (ip2location-ip2proxy-c-20190910-40abce6_GH0.tar.gz) = 7934388
diff --git a/net/ip2proxy/pkg-descr b/net/ip2proxy/pkg-descr
new file mode 100644
index 000000000000..4ce45d9c6bbb
--- /dev/null
+++ b/net/ip2proxy/pkg-descr
@@ -0,0 +1,6 @@
+This library is the C programming language library to support all IP2Proxy™
+BIN database products to query proxy IP address and its country, region,
+city, ISP name and proxy types. It has been optimized for speed and memory
+utilization.
+
+WWW: https://ip2location.com/development-libraries/ip2proxy/c
diff --git a/net/ip2proxy/pkg-plist b/net/ip2proxy/pkg-plist
new file mode 100644
index 000000000000..5c6a2a0a2019
--- /dev/null
+++ b/net/ip2proxy/pkg-plist
@@ -0,0 +1,6 @@
+include/IP2Proxy.h
+include/IP2Proxy_DB.h
+lib/libIP2Proxy.a
+lib/libIP2Proxy.so
+lib/libIP2Proxy.so.1
+lib/libIP2Proxy.so.1.0.0