aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authoryuri <yuri@FreeBSD.org>2018-01-06 04:02:03 +0800
committeryuri <yuri@FreeBSD.org>2018-01-06 04:02:03 +0800
commit76d8bf048cde3ed4b57b193be33eefb5482b3fce (patch)
treec7c8b5d263f8fd187e65af3dad981ad626141a6a /net
parentf9bc438886191a89a5e241e54a0e4fb48473809e (diff)
downloadfreebsd-ports-gnome-76d8bf048cde3ed4b57b193be33eefb5482b3fce.tar.gz
freebsd-ports-gnome-76d8bf048cde3ed4b57b193be33eefb5482b3fce.tar.zst
freebsd-ports-gnome-76d8bf048cde3ed4b57b193be33eefb5482b3fce.zip
Corrected shared library names that got the .abi3 suffix for python-36 and up after devel/py-cffi upgrade to 1.11.2
This is the followup for the r457997 commit that updated devel/py-cffi to 1.11.2. As it turned out, the shared object names built by py-cffi has changed in python 36. Dependent ports can choose between installing such shared object as part of their plist, or generating them in the runtime and placing them into ~/.cache/{port-name}/ The former ones, that include the shared objects in their plist, got affected. 4 of the ports were failing explicitly in their py36 flavor during the strip phase. The other 6 were either missing strip entirely, or performed the strip operation without using explicit shared object names. These 6 ports didn't trigger any build errors, and were failing silently during the runtime, making the problem very hard to detect. Precisely, .abi3 suffix is now added for the py36 flavor of relevant ports. Here are the 10 ports that got affected and are now corrected: databases/py-psycopg2cffi devel/py-pygit2 devel/py-xattr devel/py-pyopencl devel/py-atomiclong multimedia/py-librtmp net/py-nnpy security/py-bcrypt security/py-cryptography security/py-pynacl All of them got the * in the stripped shared object name, and a PORTREVISION bump.
Diffstat (limited to 'net')
-rw-r--r--net/py-nnpy/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/net/py-nnpy/Makefile b/net/py-nnpy/Makefile
index 47c4567e8b3b..2e561b949815 100644
--- a/net/py-nnpy/Makefile
+++ b/net/py-nnpy/Makefile
@@ -2,6 +2,7 @@
PORTNAME= nnpy
PORTVERSION= 1.3
+PORTREVISION= 1
CATEGORIES= net python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -18,4 +19,7 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= python
USE_PYTHON= autoplist distutils
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/_nnpy*.so
+
.include <bsd.port.mk>