aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2011-12-22 01:34:52 +0800
committerSergey Matveychuk <sem@FreeBSD.org>2011-12-22 01:34:52 +0800
commit78e1dd1ed9f38277d742a18afadb4856be2e4b99 (patch)
treedfa13a1b94ee24689a44d905da16c4a9d8f3ca0c /net
parent8576025438977ce29cb67bcf7ecfd571972cf4ef (diff)
downloadfreebsd-ports-gnome-78e1dd1ed9f38277d742a18afadb4856be2e4b99.tar.gz
freebsd-ports-gnome-78e1dd1ed9f38277d742a18afadb4856be2e4b99.tar.zst
freebsd-ports-gnome-78e1dd1ed9f38277d742a18afadb4856be2e4b99.zip
Netgraph node for Mikrotik's EoIP tunneling support
WWW: http://imax.in.ua/ng_mikrotik_eoip/ PR: ports/163484 Submitted by: Maxim Ignatenko <gelraen.ua_at_gmail.com>
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/ng_mikrotik_eoip/Makefile41
-rw-r--r--net/ng_mikrotik_eoip/distinfo2
-rw-r--r--net/ng_mikrotik_eoip/pkg-descr3
-rw-r--r--net/ng_mikrotik_eoip/pkg-plist4
5 files changed, 51 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 01bbbe22704a..922b9292c62a 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -415,6 +415,7 @@
SUBDIR += nfsshell
SUBDIR += ng_car
SUBDIR += ng_daphne
+ SUBDIR += ng_mikrotik_eoip
SUBDIR += ngrep
SUBDIR += ngrep-lib
SUBDIR += nifmon
diff --git a/net/ng_mikrotik_eoip/Makefile b/net/ng_mikrotik_eoip/Makefile
new file mode 100644
index 000000000000..3575b58913c0
--- /dev/null
+++ b/net/ng_mikrotik_eoip/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: ng_mikrotik_eoip
+# Date created: 19 Dec 2011
+# Whom: Maxim Ignatenko
+#
+# $FreeBSD$
+#
+
+PORTNAME= ng_mikrotik_eoip
+PORTVERSION= 1.0
+CATEGORIES= net kld
+MASTER_SITES= http://projects.ukrweb.net/files/ \
+ http://imax.in.ua/files/
+
+MAINTAINER= gelraen.ua@gmail.com
+COMMENT= Netgraph node for Mikrotik EoIP tunneling
+
+LICENSE= BSD
+
+OPTIONS= PTABLE "Use O(1) lookup for tunnel hooks" OFF
+# This option enables usage of static pointer table to find needed decimal-named hook,
+# which increases memory usage for each node by 65536*sizeof(hook_p). You probably want
+# this option if you have many tunnels with single remote IP.
+
+KMODDIR?= /boot/modules
+PLIST_SUB+= KMODDIR=${KMODDIR} \
+ PORTNAME=${PORTNAME}
+
+.if !exists(${SRC_BASE}/sys/sys/module.h)
+IGNORE= requires kernel source files
+.endif
+
+.include <bsd.port.options.mk>
+
+.if defined(WITH_PTABLE)
+MAKE_ARGS+= NO_LINEAR_HOOK_LOOKUP=1
+.endif
+
+do-install:
+ @${INSTALL_KLD} ${WRKSRC}/${PORTNAME}.ko ${KMODDIR}
+
+.include <bsd.port.mk>
diff --git a/net/ng_mikrotik_eoip/distinfo b/net/ng_mikrotik_eoip/distinfo
new file mode 100644
index 000000000000..32049025b929
--- /dev/null
+++ b/net/ng_mikrotik_eoip/distinfo
@@ -0,0 +1,2 @@
+SHA256 (ng_mikrotik_eoip-1.0.tar.gz) = 3180b68660d110fc217e3b5b5e4cc94bee69dee2933a811b5c0349ea644952c8
+SIZE (ng_mikrotik_eoip-1.0.tar.gz) = 4154
diff --git a/net/ng_mikrotik_eoip/pkg-descr b/net/ng_mikrotik_eoip/pkg-descr
new file mode 100644
index 000000000000..244376af3903
--- /dev/null
+++ b/net/ng_mikrotik_eoip/pkg-descr
@@ -0,0 +1,3 @@
+Netgraph node for Mikrotik Ethernet-over-IP tunneling support
+
+WWW: http://imax.in.ua/ng_mikrotik_eoip/
diff --git a/net/ng_mikrotik_eoip/pkg-plist b/net/ng_mikrotik_eoip/pkg-plist
new file mode 100644
index 000000000000..1be1dafaa643
--- /dev/null
+++ b/net/ng_mikrotik_eoip/pkg-plist
@@ -0,0 +1,4 @@
+@cwd /
+%%KMODDIR%%/%%PORTNAME%%.ko
+@exec /usr/sbin/kldxref /%%KMODDIR%%
+@unexec /usr/sbin/kldxref /%%KMODDIR%%