aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2003-12-24 06:43:07 +0800
committerkrion <krion@FreeBSD.org>2003-12-24 06:43:07 +0800
commit798e125d61fd87f7014c078ae5501b98a8e6c00b (patch)
tree982f4a31e117f10174d2f322fc89137aaec63ef5 /net
parent5b5645efbab87f5c965644f64c3722a5a8c561c4 (diff)
downloadfreebsd-ports-gnome-798e125d61fd87f7014c078ae5501b98a8e6c00b.tar.gz
freebsd-ports-gnome-798e125d61fd87f7014c078ae5501b98a8e6c00b.tar.zst
freebsd-ports-gnome-798e125d61fd87f7014c078ae5501b98a8e6c00b.zip
Add latd 1.19, the linux-decnet project LAT protocol suite.
This is a redistribution of the linux-decnet project's software, with FreeBSD compatability added. It is based very closely on the NetBSD port by Matt Fredette and has benefitted from the assistance of Patrick Caulfield (the original author). PR: 60519 Submitted by: Tillman Hodgson <tillman@seekingfire.com>
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/latd/Makefile28
-rw-r--r--net/latd/distinfo1
-rw-r--r--net/latd/files/patch-interfaces-bpf.cc10
-rw-r--r--net/latd/pkg-descr13
-rw-r--r--net/latd/pkg-plist5
6 files changed, 58 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index ab0a2475819a..b1c263f52e28 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -273,6 +273,7 @@
SUBDIR += l2tpd
SUBDIR += lam
SUBDIR += lambdamoo
+ SUBDIR += latd
SUBDIR += ldap2dns
SUBDIR += ldapbrowser
SUBDIR += ldapdiff
diff --git a/net/latd/Makefile b/net/latd/Makefile
new file mode 100644
index 000000000000..f99e07b20dd5
--- /dev/null
+++ b/net/latd/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: latd
+# Date created: 19 December 2003
+# Whom: Tillman Hodgson <tillman@seekingfire.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= latd
+PORTVERSION= 1.19
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= linux-decnet
+
+MAINTAINER= tillman@seekingfire.com
+COMMENT= The linux-decnet project LAT protocol suite
+
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+MAN1= llogin.1
+MAN5= latd.conf.5
+MAN8= latd.8 latcp.8 moprc.8
+
+pre-configure:
+ @${CP} ${WRKSRC}/latd.conf ${WRKSRC}/latd.conf.sample
+ @${SED} -i .dist -e 's/sysconf_DATA = latd.conf/sysconf_DATA = latd.conf.sample/' ${WRKSRC}/Makefile.in
+
+.include <bsd.port.mk>
diff --git a/net/latd/distinfo b/net/latd/distinfo
new file mode 100644
index 000000000000..33c4408437fd
--- /dev/null
+++ b/net/latd/distinfo
@@ -0,0 +1 @@
+MD5 (latd-1.19.tar.gz) = 4ec5969354601d72550d1b4d00af01cd
diff --git a/net/latd/files/patch-interfaces-bpf.cc b/net/latd/files/patch-interfaces-bpf.cc
new file mode 100644
index 000000000000..7f0f9e34ee30
--- /dev/null
+++ b/net/latd/files/patch-interfaces-bpf.cc
@@ -0,0 +1,10 @@
+--- interfaces-bpf.cc.orig Tue Dec 23 23:40:11 2003
++++ interfaces-bpf.cc Tue Dec 23 23:40:32 2003
+@@ -25,6 +25,7 @@
+ #include <sys/time.h>
+ #include <sys/socket.h>
+ #include <sys/uio.h>
++#include <assert.h>
+
+ #include <net/if.h>
+ #include <net/bpf.h>
diff --git a/net/latd/pkg-descr b/net/latd/pkg-descr
new file mode 100644
index 000000000000..9a701d178e88
--- /dev/null
+++ b/net/latd/pkg-descr
@@ -0,0 +1,13 @@
+The linux-decnet project is an effort to bring full DECnet
+support to Linux; however, they also separately offer the latd
+package, a collection of programs that speak Digital's old Local
+Area Terminal (LAT) protocol. These programs enable network
+clients to reach serial devices connected to old LAT-only
+terminal servers, such as the DECserver 200/MC.
+
+This is a redistribution of the linux-decnet project's software,
+with FreeBSD compatability added. It is based very closely on the
+NetBSD port by Matt Fredette and has benefitted from the
+wonderful assistance of Patrick Caulfield (the original author).
+
+WWW: http://linux-decnet.sourceforge.net/
diff --git a/net/latd/pkg-plist b/net/latd/pkg-plist
new file mode 100644
index 000000000000..bbfd153f4901
--- /dev/null
+++ b/net/latd/pkg-plist
@@ -0,0 +1,5 @@
+sbin/latd
+sbin/latcp
+sbin/moprc
+bin/llogin
+etc/latd.conf.sample