aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authoraaron <aaron@FreeBSD.org>2006-05-26 01:45:25 +0800
committeraaron <aaron@FreeBSD.org>2006-05-26 01:45:25 +0800
commit7d97cf68a7259bd8fdb9502e6a5f167511d15a83 (patch)
treef765487cdda023ad2868484c7d8452cb0eecfd5d /net
parentc13a6cf793721c6c2fab7a984ee01b2a09f2b2b8 (diff)
downloadfreebsd-ports-gnome-7d97cf68a7259bd8fdb9502e6a5f167511d15a83.tar.gz
freebsd-ports-gnome-7d97cf68a7259bd8fdb9502e6a5f167511d15a83.tar.zst
freebsd-ports-gnome-7d97cf68a7259bd8fdb9502e6a5f167511d15a83.zip
Adding port net/p5-Net-FTP-File, a sub-classed replacement for Net::FTP with a number of useful new features.
Approved by: tobez (implicit)
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-Net-FTP-File/Makefile31
-rw-r--r--net/p5-Net-FTP-File/distinfo3
-rw-r--r--net/p5-Net-FTP-File/pkg-descr19
-rw-r--r--net/p5-Net-FTP-File/pkg-plist7
5 files changed, 61 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 4191f1e2f0fe..f0d36c4f7eae 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -413,6 +413,7 @@
SUBDIR += p5-Net-EPP-Client
SUBDIR += p5-Net-EPP-Frame
SUBDIR += p5-Net-EPP-Proxy
+ SUBDIR += p5-Net-FTP-File
SUBDIR += p5-Net-Finger
SUBDIR += p5-Net-Gnats
SUBDIR += p5-Net-Google
diff --git a/net/p5-Net-FTP-File/Makefile b/net/p5-Net-FTP-File/Makefile
new file mode 100644
index 000000000000..65e58ce04aeb
--- /dev/null
+++ b/net/p5-Net-FTP-File/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-Net-FTP-File
+# Date created: 25 May 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-FTP-File
+PORTVERSION= 0.05
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Perl extension for simplifying FTP file operations
+
+BUILD_DEPENDS= ${SITE_PERL}/Net/FTP.pm:${PORTSDIR}/net/p5-Net
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= Net::FTP::File.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires at least Perl 5.6.0 due to dependencies. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/p5-Net-FTP-File/distinfo b/net/p5-Net-FTP-File/distinfo
new file mode 100644
index 000000000000..2686fe69a4d9
--- /dev/null
+++ b/net/p5-Net-FTP-File/distinfo
@@ -0,0 +1,3 @@
+MD5 (Net-FTP-File-0.05.tar.gz) = d101bfab70ff9f421fd784c277dc2803
+SHA256 (Net-FTP-File-0.05.tar.gz) = cbed8f8f78c7d558d1054026788f5710d8377c666e1ba03fcbee546228837864
+SIZE (Net-FTP-File-0.05.tar.gz) = 6208
diff --git a/net/p5-Net-FTP-File/pkg-descr b/net/p5-Net-FTP-File/pkg-descr
new file mode 100644
index 000000000000..0714a7fe65e3
--- /dev/null
+++ b/net/p5-Net-FTP-File/pkg-descr
@@ -0,0 +1,19 @@
+Is this module just like Net::FTP? No it is not!
+
+ 1. It is a subclass and not a new class that uses Net::FTP underneath.
+That means the object is a normal Net::FTP object and has all the methods
+Net::FTP has.
+ 2. It does not override Net::FTP methods (IE does not have methods the
+same name as Net::FTP) which means you don't have to sort through how the
+function differs from the standard version in the Net::FTP module.
+ 3. Its waaaay simpler to use without a bunch of weird config stuff to
+cloud the issue, odd hard to remember arguments, obscure methods to
+replace valid existing ones that are part of Net::FTP, or new methods that
+are badly named (IE think "grep" on this one). There are other things as
+well.
+ 4. It follows the paradigm of Perl name spaces, objects, and general
+good practice much better and in a way that is more intuitive and
+expandable.
+
+WWW: http://search.cpan.org/dist/Net-FTP-File
+Author: Daniel Muey, http://drmuey.com/cpan_contact.pl
diff --git a/net/p5-Net-FTP-File/pkg-plist b/net/p5-Net-FTP-File/pkg-plist
new file mode 100644
index 000000000000..9575fceb89ec
--- /dev/null
+++ b/net/p5-Net-FTP-File/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Net/FTP/File.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/FTP/File/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/FTP/File
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/FTP
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net
+@dirrmtry %%SITE_PERL%%/Net/FTP
+@dirrmtry %%SITE_PERL%%/Net