aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorFernando ApesteguĂ­a <fernape@FreeBSD.org>2021-03-10 19:50:00 +0800
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2021-03-10 19:50:00 +0800
commit7f18ba62fca2aad63f339c53e3161c54c4d386e2 (patch)
tree22395312e06c5bcac594e9f6bfb0ca17c76f14cf /net
parent0d254aae9f9224b6810430678c18f6b7127c38b6 (diff)
downloadfreebsd-ports-gnome-7f18ba62fca2aad63f339c53e3161c54c4d386e2.tar.gz
freebsd-ports-gnome-7f18ba62fca2aad63f339c53e3161c54c4d386e2.tar.zst
freebsd-ports-gnome-7f18ba62fca2aad63f339c53e3161c54c4d386e2.zip
net/megacmd: Update to 1.4.0
PR: 254168 Submitted by: menelkir@itroll.org (maintainer)
Diffstat (limited to 'net')
-rw-r--r--net/megacmd/Makefile41
-rw-r--r--net/megacmd/distinfo10
-rw-r--r--net/megacmd/pkg-plist11
3 files changed, 39 insertions, 23 deletions
diff --git a/net/megacmd/Makefile b/net/megacmd/Makefile
index f4c233de2d9c..c2307b9f61b2 100644
--- a/net/megacmd/Makefile
+++ b/net/megacmd/Makefile
@@ -1,8 +1,8 @@
# $FreeBSD$
PORTNAME= megacmd
-DISTVERSION= 1.0.0
-PORTREVISION= 1
+DISTVERSION= 1.4.0
+DISTVERSIONSUFFIX= _Linux
CATEGORIES= net
MAINTAINER= menelkir@itroll.org
@@ -20,21 +20,9 @@ USES= autoreconf libtool sqlite:3 readline shebangfix ssl
USE_GITHUB= yes
GH_ACCOUNT= meganz
GH_PROJECT= MEGAcmd sdk:sdk
-GH_TAGNAME= v3.4.1:sdk
GH_SUBDIR= sdk:sdk
+GH_TAGNAME= v3.7.3c:sdk
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-examples \
- --disable-java --disable-php --disable-python \
- --disable-chat --without-freeimage \
- --without-termcap --without-ffmpeg --without-libraw \
- --without-libzen --without-libmediainfo \
- --enable-gcc-hardening \
- --with-cares=${LOCALBASE} --with-cryptopp=${LOCALBASE} \
- --with-curl=${LOCALBASE} --with-sodium=${LOCALBASE} \
- --with-sqlite=${LOCALBASE} --with-libuv=${LOCALBASE} \
- --with-zlib --with-readline=${LOCALBASE}
-CXXFLAGS+= `pkgconf --cflags-only-other libcryptopp`
USE_LDCONFIG= yes
SHEBANG_FILES= src/client/mega-lpwd \
@@ -89,6 +77,27 @@ SHEBANG_FILES= src/client/mega-lpwd \
src/client/mega-killsession \
src/client/mega-sync \
src/client/mega-users \
- src/client/mega-export
+ src/client/mega-export \
+ src/client/mega-cat \
+ src/client/mega-mediainfo \
+ src/client/mega-proxy \
+ src/client/mega-df \
+ src/client/mega-tree
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-examples \
+ --disable-java --disable-php --disable-python \
+ --disable-chat --without-freeimage \
+ --without-termcap --without-ffmpeg --without-libraw \
+ --without-libzen --without-libmediainfo \
+ --enable-gcc-hardening \
+ --with-cares=${LOCALBASE} --with-cryptopp=${LOCALBASE} \
+ --with-curl=${LOCALBASE} --with-sodium=${LOCALBASE} \
+ --with-sqlite=${LOCALBASE} --with-libuv=${LOCALBASE} \
+ --with-zlib --with-readline=${LOCALBASE}
+
+INSTALL_TARGET= install-strip
+
+CXXFLAGS+= `pkgconf --cflags-only-other libcryptopp`
.include <bsd.port.mk>
diff --git a/net/megacmd/distinfo b/net/megacmd/distinfo
index e79158431691..124320bc33eb 100644
--- a/net/megacmd/distinfo
+++ b/net/megacmd/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1591495680
-SHA256 (meganz-MEGAcmd-1.0.0_GH0.tar.gz) = 1200363bee2f387a2287e286b38d15b1a01079967e20b8c489815cc7c8d9ff63
-SIZE (meganz-MEGAcmd-1.0.0_GH0.tar.gz) = 1940815
-SHA256 (meganz-sdk-v3.4.1_GH0.tar.gz) = 94dfa5ac6e9cfea70d0a4f2a3e5577e718343f569309f39163167f1874def150
-SIZE (meganz-sdk-v3.4.1_GH0.tar.gz) = 2889992
+TIMESTAMP = 1615318747
+SHA256 (meganz-MEGAcmd-1.4.0_Linux_GH0.tar.gz) = 2a3626a9f1d22303fe2123f984a8ecf3779d6d59ac6c67c1bf43c2423dcb832d
+SIZE (meganz-MEGAcmd-1.4.0_Linux_GH0.tar.gz) = 2028593
+SHA256 (meganz-sdk-v3.7.3c_GH0.tar.gz) = 0b55c1752d590a0367b9fcddd2465ea574308eb97e065540121f6261807aa111
+SIZE (meganz-sdk-v3.7.3c_GH0.tar.gz) = 3323303
diff --git a/net/megacmd/pkg-plist b/net/megacmd/pkg-plist
index 263969781979..dde117d00f80 100644
--- a/net/megacmd/pkg-plist
+++ b/net/megacmd/pkg-plist
@@ -1,6 +1,7 @@
bin/mega-attr
bin/mega-backup
bin/mega-cancel
+bin/mega-cat
bin/mega-cd
bin/mega-cmd
bin/mega-cmd-server
@@ -9,6 +10,7 @@ bin/mega-confirmcancel
bin/mega-cp
bin/mega-debug
bin/mega-deleteversions
+bin/mega-df
bin/mega-du
bin/mega-errorcode
bin/mega-exclude
@@ -30,12 +32,14 @@ bin/mega-login
bin/mega-logout
bin/mega-lpwd
bin/mega-ls
+bin/mega-mediainfo
bin/mega-mkdir
bin/mega-mount
bin/mega-mv
bin/mega-passwd
bin/mega-permissions
bin/mega-preview
+bin/mega-proxy
bin/mega-put
bin/mega-pwd
bin/mega-quit
@@ -49,6 +53,7 @@ bin/mega-speedlimit
bin/mega-sync
bin/mega-thumbnail
bin/mega-transfers
+bin/mega-tree
bin/mega-userattr
bin/mega-users
bin/mega-version
@@ -100,6 +105,7 @@ include/mega/posix/megasys.h
include/mega/posix/megawaiter.h
include/mega/proxy.h
include/mega/pubkeyaction.h
+include/mega/raid.h
include/mega/request.h
include/mega/serialize64.h
include/mega/share.h
@@ -115,12 +121,13 @@ include/mega/transferslot.h
include/mega/treeproc.h
include/mega/types.h
include/mega/user.h
+include/mega/useralerts.h
include/mega/utils.h
include/mega/version.h
include/mega/waiter.h
include/megaapi.h
include/megaapi_impl.h
lib/libmega.so
-lib/libmega.so.30401
-lib/libmega.so.30401.0.0
+lib/libmega.so.30703
+lib/libmega.so.30703.0.0
libdata/pkgconfig/libmega.pc