aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2006-01-31 10:46:29 +0800
committermarcus <marcus@FreeBSD.org>2006-01-31 10:46:29 +0800
commit800820ff95553ecffb520258c3e904c73f7f7df8 (patch)
tree8ba7ae654d4fa03ff11086fd6a53fea5aa40f97d /net
parent8e093df58ce17e15086423ee876883f0309936c1 (diff)
downloadfreebsd-ports-gnome-800820ff95553ecffb520258c3e904c73f7f7df8.tar.gz
freebsd-ports-gnome-800820ff95553ecffb520258c3e904c73f7f7df8.tar.zst
freebsd-ports-gnome-800820ff95553ecffb520258c3e904c73f7f7df8.zip
Adjust the order of variable declarations to fix a problem getting the
signal strength from Aironet cards.
Diffstat (limited to 'net')
-rw-r--r--net/gnome-netstatus/Makefile2
-rw-r--r--net/gnome-netstatus/files/patch-src_netstatus-sysdeps.c18
-rw-r--r--net/gnomenetstatus/Makefile2
-rw-r--r--net/gnomenetstatus/files/patch-src_netstatus-sysdeps.c18
4 files changed, 34 insertions, 6 deletions
diff --git a/net/gnome-netstatus/Makefile b/net/gnome-netstatus/Makefile
index 5c8a5647d921..c903839e594d 100644
--- a/net/gnome-netstatus/Makefile
+++ b/net/gnome-netstatus/Makefile
@@ -8,7 +8,7 @@
PORTNAME= gnomenetstatus
PORTVERSION= 2.12.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/gnome-netstatus/2.12
diff --git a/net/gnome-netstatus/files/patch-src_netstatus-sysdeps.c b/net/gnome-netstatus/files/patch-src_netstatus-sysdeps.c
index bf655bd6a0a8..b674048d5ef2 100644
--- a/net/gnome-netstatus/files/patch-src_netstatus-sysdeps.c
+++ b/net/gnome-netstatus/files/patch-src_netstatus-sysdeps.c
@@ -1,5 +1,19 @@
---- src/netstatus-sysdeps.c.orig Mon Jun 27 14:29:53 2005
-+++ src/netstatus-sysdeps.c Mon Jun 27 14:30:18 2005
+--- src/netstatus-sysdeps.c.orig Mon Mar 14 09:34:06 2005
++++ src/netstatus-sysdeps.c Mon Jan 30 21:44:49 2006
+@@ -430,11 +430,11 @@ static inline char *
+ get_an_data (const char *iface,
+ int *signal_strength)
+ {
++ struct an_ltv_status *sts;
++ struct an_req areq;
+ #ifdef AN_RID_RSSI_MAP
+ struct an_ltv_rssi_map an_rssimap;
+ #endif
+- struct an_req areq;
+- struct an_ltv_status *sts;
+ int level;
+ char *error = NULL;
+ gboolean rssimap_valid = FALSE;
@@ -548,6 +548,8 @@ netstatus_sysdeps_read_iface_wireless_de
g_strncasecmp (iface, "wi", 2) &&
g_strncasecmp (iface, "ath", 3) &&
diff --git a/net/gnomenetstatus/Makefile b/net/gnomenetstatus/Makefile
index 5c8a5647d921..c903839e594d 100644
--- a/net/gnomenetstatus/Makefile
+++ b/net/gnomenetstatus/Makefile
@@ -8,7 +8,7 @@
PORTNAME= gnomenetstatus
PORTVERSION= 2.12.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/gnome-netstatus/2.12
diff --git a/net/gnomenetstatus/files/patch-src_netstatus-sysdeps.c b/net/gnomenetstatus/files/patch-src_netstatus-sysdeps.c
index bf655bd6a0a8..b674048d5ef2 100644
--- a/net/gnomenetstatus/files/patch-src_netstatus-sysdeps.c
+++ b/net/gnomenetstatus/files/patch-src_netstatus-sysdeps.c
@@ -1,5 +1,19 @@
---- src/netstatus-sysdeps.c.orig Mon Jun 27 14:29:53 2005
-+++ src/netstatus-sysdeps.c Mon Jun 27 14:30:18 2005
+--- src/netstatus-sysdeps.c.orig Mon Mar 14 09:34:06 2005
++++ src/netstatus-sysdeps.c Mon Jan 30 21:44:49 2006
+@@ -430,11 +430,11 @@ static inline char *
+ get_an_data (const char *iface,
+ int *signal_strength)
+ {
++ struct an_ltv_status *sts;
++ struct an_req areq;
+ #ifdef AN_RID_RSSI_MAP
+ struct an_ltv_rssi_map an_rssimap;
+ #endif
+- struct an_req areq;
+- struct an_ltv_status *sts;
+ int level;
+ char *error = NULL;
+ gboolean rssimap_valid = FALSE;
@@ -548,6 +548,8 @@ netstatus_sysdeps_read_iface_wireless_de
g_strncasecmp (iface, "wi", 2) &&
g_strncasecmp (iface, "ath", 3) &&