aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorcy <cy@FreeBSD.org>2019-09-21 03:39:17 +0800
committercy <cy@FreeBSD.org>2019-09-21 03:39:17 +0800
commit817d2424f2edf4d32475603abcc7059ebf2436c8 (patch)
treec8c15427bf650bf140f3fb1784f11a35d7ac8ac2 /net
parentcfce19de08539565f8f2826f6b42b51fca9b3e78 (diff)
downloadfreebsd-ports-gnome-817d2424f2edf4d32475603abcc7059ebf2436c8.tar.gz
freebsd-ports-gnome-817d2424f2edf4d32475603abcc7059ebf2436c8.tar.zst
freebsd-ports-gnome-817d2424f2edf4d32475603abcc7059ebf2436c8.zip
Chase src r352540:
Follow up on ports r511987 (base r352304) which disabled default mlockall() at startup. Unfortunately though the original tarball supports this in ./configure (for Linux), to fully support disabling of mlockall() by default requires a little extra help otherwise the following is logged in syslog: Cannot set RLIMIT_MEMLOCK: Operation not permitted
Diffstat (limited to 'net')
-rw-r--r--net/ntp-devel/Makefile2
-rw-r--r--net/ntp-devel/files/patch-ntpd_ntp.c11
-rw-r--r--net/ntp/Makefile2
-rw-r--r--net/ntp/files/patch-ntpd_ntp.c11
4 files changed, 24 insertions, 2 deletions
diff --git a/net/ntp-devel/Makefile b/net/ntp-devel/Makefile
index dd379521d6ab..46b7590d4a47 100644
--- a/net/ntp-devel/Makefile
+++ b/net/ntp-devel/Makefile
@@ -3,7 +3,7 @@
PORTNAME= ntp
PORTVERSION= 4.3.99
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= net ipv6
MASTER_SITES= http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/ntp-dev/ \
http://archive.ntp.org/ntp4/ntp-dev/
diff --git a/net/ntp-devel/files/patch-ntpd_ntp.c b/net/ntp-devel/files/patch-ntpd_ntp.c
new file mode 100644
index 000000000000..f25751470f47
--- /dev/null
+++ b/net/ntp-devel/files/patch-ntpd_ntp.c
@@ -0,0 +1,11 @@
+--- ntpd/ntpd.c.orig 2019-06-07 01:59:15.000000000 -0700
++++ ntpd/ntpd.c 2019-09-20 12:13:28.810552000 -0700
+@@ -999,7 +999,7 @@
+ # if defined(HAVE_MLOCKALL)
+ # ifdef HAVE_SETRLIMIT
+ ntp_rlimit(RLIMIT_STACK, DFLT_RLIMIT_STACK * 4096, 4096, "4k");
+-# ifdef RLIMIT_MEMLOCK
++# if defined(RLIMIT_MEMLOCK) && defined(DFLT_RLIMIT_MEMLOCK) && DFLT_RLIMIT_MEMLOCK != -1
+ /*
+ * The default RLIMIT_MEMLOCK is very low on Linux systems.
+ * Unless we increase this limit malloc calls are likely to
diff --git a/net/ntp/Makefile b/net/ntp/Makefile
index eb40a2d5ee27..c2c32faf4829 100644
--- a/net/ntp/Makefile
+++ b/net/ntp/Makefile
@@ -3,7 +3,7 @@
PORTNAME= ntp
PORTVERSION= 4.2.8p13
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= net ipv6
MASTER_SITES= http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/ntp-4.2/ \
http://archive.ntp.org/ntp4/ntp-4.2/ \
diff --git a/net/ntp/files/patch-ntpd_ntp.c b/net/ntp/files/patch-ntpd_ntp.c
new file mode 100644
index 000000000000..3f8187a072e4
--- /dev/null
+++ b/net/ntp/files/patch-ntpd_ntp.c
@@ -0,0 +1,11 @@
+--- ntpd/ntpd.c.orig 2019-02-20 09:21:44.000000000 -0800
++++ ntpd/ntpd.c 2019-09-20 12:11:54.469651000 -0700
+@@ -999,7 +999,7 @@
+ # if defined(HAVE_MLOCKALL)
+ # ifdef HAVE_SETRLIMIT
+ ntp_rlimit(RLIMIT_STACK, DFLT_RLIMIT_STACK * 4096, 4096, "4k");
+-# ifdef RLIMIT_MEMLOCK
++# if defined(RLIMIT_MEMLOCK) && defined(DFLT_RLIMIT_MEMLOCK) && DFLT_RLIMIT_MEMLOCK != -1
+ /*
+ * The default RLIMIT_MEMLOCK is very low on Linux systems.
+ * Unless we increase this limit malloc calls are likely to