aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorpi <pi@FreeBSD.org>2016-08-28 02:11:18 +0800
committerpi <pi@FreeBSD.org>2016-08-28 02:11:18 +0800
commit855eb773c2794ee8203f44d705e212191b5ea70a (patch)
tree3af5a92ee441e10d17f9e8ae3788307b7c395156 /net
parent57280ea1505e234285376d6a69efba0ca585dcc3 (diff)
downloadfreebsd-ports-gnome-855eb773c2794ee8203f44d705e212191b5ea70a.tar.gz
freebsd-ports-gnome-855eb773c2794ee8203f44d705e212191b5ea70a.tar.zst
freebsd-ports-gnome-855eb773c2794ee8203f44d705e212191b5ea70a.zip
New port: net/sbm
sbm is a simple bandwidth monitor. Besides the basic bandwith monitor it comes with two scripts. sbm-rt-plot can be used for realtime bandwidth graphs and sbm-plot can be used to generate static graphs for bandwith usage over a period of time. WWW: http://git.2f30.org/sbm/ PR: 211595 Submitted by: Tobias Kortkamp <t@tobik.me>
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/sbm/Makefile28
-rw-r--r--net/sbm/distinfo3
-rw-r--r--net/sbm/pkg-descr8
-rw-r--r--net/sbm/pkg-message1
5 files changed, 41 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 39891a3b6122..02cbf9ebba5e 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -1209,6 +1209,7 @@
SUBDIR += samba44
SUBDIR += samplicator
SUBDIR += sbd
+ SUBDIR += sbm
SUBDIR += scamper
SUBDIR += scapy
SUBDIR += scnc
diff --git a/net/sbm/Makefile b/net/sbm/Makefile
new file mode 100644
index 000000000000..da662051e8a3
--- /dev/null
+++ b/net/sbm/Makefile
@@ -0,0 +1,28 @@
+# Created by: Tobias Kortkamp <t@tobik.me>
+# $FreeBSD$
+
+PORTNAME= sbm
+PORTVERSION= 0.8
+CATEGORIES= net
+MASTER_SITES= http://dl.2f30.org/releases/
+
+MAINTAINER= t@tobik.me
+COMMENT= Simple bandwidth monitor
+
+LICENSE= ISCL
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+MAKE_ARGS= CFLAGS="${CFLAGS}"
+
+PLIST_FILES= bin/sbm \
+ bin/sbm-plot \
+ bin/sbm-rt-plot \
+ man/man1/sbm.1.gz
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/sbm ${STAGEDIR}${PREFIX}/bin/
+ ${INSTALL_SCRIPT} ${WRKSRC}/sbm-plot ${WRKSRC}/sbm-rt-plot \
+ ${STAGEDIR}${PREFIX}/bin/
+ ${INSTALL_MAN} ${WRKSRC}/sbm.1 ${STAGEDIR}${MANPREFIX}/man/man1/
+
+.include <bsd.port.mk>
diff --git a/net/sbm/distinfo b/net/sbm/distinfo
new file mode 100644
index 000000000000..9a1df06968c6
--- /dev/null
+++ b/net/sbm/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1470401983
+SHA256 (sbm-0.8.tar.gz) = c0963b0040db7966fd68a00432fadd4e8b823f3fd3da87319ee48fa7451a3b4c
+SIZE (sbm-0.8.tar.gz) = 5012
diff --git a/net/sbm/pkg-descr b/net/sbm/pkg-descr
new file mode 100644
index 000000000000..70ec4932b29e
--- /dev/null
+++ b/net/sbm/pkg-descr
@@ -0,0 +1,8 @@
+sbm is a simple bandwidth monitor.
+
+Besides the basic bandwith monitor it comes with two scripts.
+sbm-rt-plot can be used for realtime bandwidth graphs and sbm-plot can
+be used to generate static graphs for bandwith usage over a period of
+time.
+
+WWW: http://git.2f30.org/sbm/
diff --git a/net/sbm/pkg-message b/net/sbm/pkg-message
new file mode 100644
index 000000000000..8eb884105826
--- /dev/null
+++ b/net/sbm/pkg-message
@@ -0,0 +1 @@
+Both sbm-plot and sbm-rt-plot require that math/gnuplot is installed.