aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2014-01-28 08:16:57 +0800
committerAntoine Brodin <antoine@FreeBSD.org>2014-01-28 08:16:57 +0800
commit864284545c6823762414172864b5be11fb77aaed (patch)
treeabfd68b8753cc6bcc11cad568d57d71208cdb0a1 /net
parent177c914d3187ddcd6c6f541dd00936f2c1cf0b6c (diff)
downloadfreebsd-ports-gnome-864284545c6823762414172864b5be11fb77aaed.tar.gz
freebsd-ports-gnome-864284545c6823762414172864b5be11fb77aaed.tar.zst
freebsd-ports-gnome-864284545c6823762414172864b5be11fb77aaed.zip
Stage support
Diffstat (limited to 'net')
-rw-r--r--net/fpc-ldap/Makefile5
-rw-r--r--net/fpc-pcap/Makefile5
2 files changed, 6 insertions, 4 deletions
diff --git a/net/fpc-ldap/Makefile b/net/fpc-ldap/Makefile
index ef1482a4d990..9061a7c11fd9 100644
--- a/net/fpc-ldap/Makefile
+++ b/net/fpc-ldap/Makefile
@@ -12,11 +12,12 @@ USE_FPC= hash
MASTERDIR= ${.CURDIR}/../../lang/fpc
WRKUNITDIR= ${FPCSRCDIR}/packages/${PKGNAMESUFFIX:S/-//}
-EXTRACTUNITDIR+= ${WRKUNITDIR}
+EXTRACTUNITDIR= ${WRKUNITDIR}
OPTIONS_DEFINE= OPENLDAP
OPENLDAP_DESC= Install OpenLDAP libraries
OPTIONS_DEFAULT= OPENLDAP
-NO_STAGE= yes
+OPENLDAP_USE= OPENLDAP=yes
+
.include "${MASTERDIR}/Makefile"
diff --git a/net/fpc-pcap/Makefile b/net/fpc-pcap/Makefile
index 682850307ab6..4bb6c1d0aba2 100644
--- a/net/fpc-pcap/Makefile
+++ b/net/fpc-pcap/Makefile
@@ -12,11 +12,12 @@ USE_FPC= yes
MASTERDIR= ${.CURDIR}/../../lang/fpc
WRKUNITDIR= ${FPCSRCDIR}/packages/${PKGNAMESUFFIX:S/-//}
-EXTRACTUNITDIR+= ${WRKUNITDIR}
+EXTRACTUNITDIR= ${WRKUNITDIR}
OPTIONS_DEFINE= LIBPCAP
LIBPCAP_DESC= Install ubiquitous network traffic capture library
OPTIONS_DEFAULT= LIBPCAP
-NO_STAGE= yes
+LIBPCAP_LIB_DEPENDS= libpcap.so:${PORTSDIR}/net/libpcap
+
.include "${MASTERDIR}/Makefile"