aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2013-09-10 02:18:57 +0800
committersunpoet <sunpoet@FreeBSD.org>2013-09-10 02:18:57 +0800
commit8717c4427bff84c556735bc4f6864991cf2c5cab (patch)
treec73221365d37604e9582a9374b4625d4a85e2912 /net
parentbafae00d6295bde8ff4b12096a707e4496571736 (diff)
downloadfreebsd-ports-gnome-8717c4427bff84c556735bc4f6864991cf2c5cab.tar.gz
freebsd-ports-gnome-8717c4427bff84c556735bc4f6864991cf2c5cab.tar.zst
freebsd-ports-gnome-8717c4427bff84c556735bc4f6864991cf2c5cab.zip
- Use USES=shebangfix
- Sort *_DEPENDS and PLIST
Diffstat (limited to 'net')
-rw-r--r--net/p5-SOAP-Lite/Makefile23
-rw-r--r--net/p5-SOAP-Lite/pkg-plist56
2 files changed, 40 insertions, 39 deletions
diff --git a/net/p5-SOAP-Lite/Makefile b/net/p5-SOAP-Lite/Makefile
index 7f0a06c88c9e..48ab0d90926d 100644
--- a/net/p5-SOAP-Lite/Makefile
+++ b/net/p5-SOAP-Lite/Makefile
@@ -13,14 +13,14 @@ COMMENT= SOAP::Lite - Client and server side SOAP implementation
LICENSE= ART10 GPLv1
LICENSE_COMB= dual
-RUN_DEPENDS= p5-MIME-Lite>=0:${PORTSDIR}/mail/p5-MIME-Lite \
- p5-MIME-Tools>=0:${PORTSDIR}/mail/p5-MIME-Tools \
- p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
+BUILD_DEPENDS= p5-Class-Inspector>=0:${PORTSDIR}/devel/p5-Class-Inspector \
p5-Crypt-SSLeay>=0:${PORTSDIR}/security/p5-Crypt-SSLeay \
- p5-XML-Parser>=2.23:${PORTSDIR}/textproc/p5-XML-Parser \
+ p5-MIME-Lite>=0:${PORTSDIR}/mail/p5-MIME-Lite \
+ p5-MIME-Tools>=0:${PORTSDIR}/mail/p5-MIME-Tools \
p5-Task-Weaken>=0:${PORTSDIR}/devel/p5-Task-Weaken \
- p5-Class-Inspector>=0:${PORTSDIR}/devel/p5-Class-Inspector
-BUILD_DEPENDS:= ${RUN_DEPENDS}
+ p5-XML-Parser>=2.23:${PORTSDIR}/textproc/p5-XML-Parser \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww
+RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Devel-Cycle>=0:${PORTSDIR}/devel/p5-Devel-Cycle \
p5-Test-MockObject>=0:${PORTSDIR}/devel/p5-Test-MockObject
@@ -28,10 +28,12 @@ CONFLICTS= p5-SOAP-Lite-0.60* p5-SOAP-[0-9]*
CONFIGURE_ARGS= --noprompt
INSTALL_TARGET= pure_install
-USES= perl5
USE_PERL5= configure
+USES= perl5 shebangfix
-MAN1= SOAPsh.pl.1 XMLRPCsh.pl.1 stubmaker.pl.1
+MAN1= SOAPsh.pl.1 \
+ XMLRPCsh.pl.1 \
+ stubmaker.pl.1
MAN3= Apache::SOAP.3 \
Apache::XMLRPC::Lite.3 \
SOAP::Client.3 \
@@ -61,8 +63,7 @@ MAN3= Apache::SOAP.3 \
XMLRPC::Transport::POP3.3 \
XMLRPC::Transport::TCP.3
-post-patch:
- @${REINPLACE_CMD} -i '' -e 's|^#!.*perl|#!${PERL}|' \
- ${WRKSRC}/bin/* ${WRKSRC}/t/*.pl ${WRKSRC}/t/*.t
+SHEBANG_FILES= bin/* t/*.pl t/*.t
+perl_OLD_CMD= .*perl
.include <bsd.port.mk>
diff --git a/net/p5-SOAP-Lite/pkg-plist b/net/p5-SOAP-Lite/pkg-plist
index f894664677b1..14e2edd69442 100644
--- a/net/p5-SOAP-Lite/pkg-plist
+++ b/net/p5-SOAP-Lite/pkg-plist
@@ -1,20 +1,13 @@
bin/SOAPsh.pl
-bin/stubmaker.pl
bin/XMLRPCsh.pl
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/SOAP/Lite/.packlist
-%%SITE_PERL%%/SOAP/Packager.pm
+bin/stubmaker.pl
+%%SITE_PERL%%/Apache/SOAP.pm
+%%SITE_PERL%%/Apache/XMLRPC/Lite.pm
+%%SITE_PERL%%/SOAP/Client.pod
+%%SITE_PERL%%/SOAP/Constants.pm
%%SITE_PERL%%/SOAP/Data.pod
-%%SITE_PERL%%/SOAP/Test.pm
-%%SITE_PERL%%/SOAP/Transport.pod
%%SITE_PERL%%/SOAP/Deserializer.pod
-%%SITE_PERL%%/SOAP/Trace.pod
-%%SITE_PERL%%/SOAP/Schema.pod
-%%SITE_PERL%%/SOAP/Server.pod
-%%SITE_PERL%%/SOAP/Utils.pod
-%%SITE_PERL%%/SOAP/Constants.pm
-%%SITE_PERL%%/SOAP/Serializer.pod
-%%SITE_PERL%%/SOAP/Client.pod
-%%SITE_PERL%%/SOAP/SOM.pod
+%%SITE_PERL%%/SOAP/Fault.pod
%%SITE_PERL%%/SOAP/Header.pod
%%SITE_PERL%%/SOAP/Lite.pm
%%SITE_PERL%%/SOAP/Lite/Deserializer/XMLSchema1999.pm
@@ -23,32 +16,39 @@ bin/XMLRPCsh.pl
%%SITE_PERL%%/SOAP/Lite/Deserializer/XMLSchemaSOAP1_2.pm
%%SITE_PERL%%/SOAP/Lite/Packager.pm
%%SITE_PERL%%/SOAP/Lite/Utils.pm
-%%SITE_PERL%%/SOAP/Fault.pod
+%%SITE_PERL%%/SOAP/Packager.pm
+%%SITE_PERL%%/SOAP/SOM.pod
+%%SITE_PERL%%/SOAP/Schema.pod
+%%SITE_PERL%%/SOAP/Serializer.pod
+%%SITE_PERL%%/SOAP/Server.pod
+%%SITE_PERL%%/SOAP/Test.pm
+%%SITE_PERL%%/SOAP/Trace.pod
+%%SITE_PERL%%/SOAP/Transport.pod
+%%SITE_PERL%%/SOAP/Transport/HTTP.pm
+%%SITE_PERL%%/SOAP/Transport/IO.pm
+%%SITE_PERL%%/SOAP/Transport/LOCAL.pm
%%SITE_PERL%%/SOAP/Transport/LOOPBACK.pm
%%SITE_PERL%%/SOAP/Transport/MAILTO.pm
%%SITE_PERL%%/SOAP/Transport/POP3.pm
-%%SITE_PERL%%/SOAP/Transport/IO.pm
-%%SITE_PERL%%/SOAP/Transport/HTTP.pm
-%%SITE_PERL%%/SOAP/Transport/LOCAL.pm
+%%SITE_PERL%%/SOAP/Utils.pod
+%%SITE_PERL%%/UDDI/Lite.pm
%%SITE_PERL%%/XML/Parser/Lite.pm
%%SITE_PERL%%/XMLRPC/Lite.pm
%%SITE_PERL%%/XMLRPC/Test.pm
-%%SITE_PERL%%/XMLRPC/Transport/TCP.pm
%%SITE_PERL%%/XMLRPC/Transport/HTTP.pm
%%SITE_PERL%%/XMLRPC/Transport/POP3.pm
-%%SITE_PERL%%/Apache/SOAP.pm
-%%SITE_PERL%%/Apache/XMLRPC/Lite.pm
-%%SITE_PERL%%/UDDI/Lite.pm
+%%SITE_PERL%%/XMLRPC/Transport/TCP.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/SOAP/Lite/.packlist
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/SOAP/Lite
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/SOAP
-@dirrm %%SITE_PERL%%/Apache/XMLRPC
-@dirrm %%SITE_PERL%%/SOAP/Lite/Deserializer
-@dirrm %%SITE_PERL%%/SOAP/Lite
-@dirrmtry %%SITE_PERL%%/SOAP/Transport
-@dirrm %%SITE_PERL%%/UDDI
@dirrm %%SITE_PERL%%/XMLRPC/Transport
@dirrmtry %%SITE_PERL%%/XMLRPC
-@dirrmtry %%SITE_PERL%%/Apache
-@dirrmtry %%SITE_PERL%%/SOAP
@dirrmtry %%SITE_PERL%%/XML/Parser
@dirrmtry %%SITE_PERL%%/XML
+@dirrm %%SITE_PERL%%/UDDI
+@dirrmtry %%SITE_PERL%%/SOAP/Transport
+@dirrm %%SITE_PERL%%/SOAP/Lite/Deserializer
+@dirrm %%SITE_PERL%%/SOAP/Lite
+@dirrmtry %%SITE_PERL%%/SOAP
+@dirrm %%SITE_PERL%%/Apache/XMLRPC
+@dirrmtry %%SITE_PERL%%/Apache