aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorkoobs <koobs@FreeBSD.org>2014-03-08 11:24:56 +0800
committerkoobs <koobs@FreeBSD.org>2014-03-08 11:24:56 +0800
commit884d427663bb0d9a23f2f0cb5087f857faad9972 (patch)
tree488e05bb767fb1dda9609d4eff5003480dca5f0c /net
parent59805689475d7edb66dd35d544d0cb2f28a52fcb (diff)
downloadfreebsd-ports-gnome-884d427663bb0d9a23f2f0cb5087f857faad9972.tar.gz
freebsd-ports-gnome-884d427663bb0d9a23f2f0cb5087f857faad9972.tar.zst
freebsd-ports-gnome-884d427663bb0d9a23f2f0cb5087f857faad9972.zip
net/py-beanstalkc: Update to 0.4.0, Add QA bits
- Update to 0.4.0 - Add TEST_DEPENDS and regression-test: target for QA - Patch setup.py to integrate the test command with py-nose - Remove setup.py patch adding zip_safe=False (no longer needed) - pkg-descr: Update WWW: homepage link Changes: * https://github.com/earl/beanstalkc/commits/v0.4.0
Diffstat (limited to 'net')
-rw-r--r--net/py-beanstalkc/Makefile9
-rw-r--r--net/py-beanstalkc/distinfo4
-rw-r--r--net/py-beanstalkc/files/patch-setup.py10
-rw-r--r--net/py-beanstalkc/pkg-descr2
4 files changed, 15 insertions, 10 deletions
diff --git a/net/py-beanstalkc/Makefile b/net/py-beanstalkc/Makefile
index 674894650c3c..55d1f222ff2b 100644
--- a/net/py-beanstalkc/Makefile
+++ b/net/py-beanstalkc/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= beanstalkc
-PORTVERSION= 0.3.0
-PORTREVISION= 1
+PORTVERSION= 0.4.0
CATEGORIES= net python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -13,6 +12,9 @@ COMMENT= Simple beanstalkd client library for Python
LICENSE= APACHE20
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nose>0:${PORTSDIR}/devel/py-nose \
+ ${PYTHON_PKGNAMEPREFIX}yaml>0:${PORTSDIR}/devel/py-yaml
+
USE_PYTHON= yes
USE_PYDISTUTILS= yes
PYDISTUTILS_AUTOPLIST= yes
@@ -23,4 +25,7 @@ YAML_DESC= Support parsing YAML responses
YAML_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}yaml>0:${PORTSDIR}/devel/py-yaml
+regression-test: build
+ @cd ${WRKSRC} && ${PYTHON_CMD} ${PYSETUP} test
+
.include <bsd.port.mk>
diff --git a/net/py-beanstalkc/distinfo b/net/py-beanstalkc/distinfo
index c9d09080793e..77c66e70d62f 100644
--- a/net/py-beanstalkc/distinfo
+++ b/net/py-beanstalkc/distinfo
@@ -1,2 +1,2 @@
-SHA256 (beanstalkc-0.3.0.tar.gz) = 45c3915ed876f80712fcafadee0feaaf0628e5c297e33aaea7f7b229deb80467
-SIZE (beanstalkc-0.3.0.tar.gz) = 3849
+SHA256 (beanstalkc-0.4.0.tar.gz) = 98978e57797320146f4b233286d9a02f65d20bad0168424118839fc608085280
+SIZE (beanstalkc-0.4.0.tar.gz) = 13921
diff --git a/net/py-beanstalkc/files/patch-setup.py b/net/py-beanstalkc/files/patch-setup.py
index d188cf06a012..574f2df7dea9 100644
--- a/net/py-beanstalkc/files/patch-setup.py
+++ b/net/py-beanstalkc/files/patch-setup.py
@@ -1,8 +1,8 @@
---- ./setup.py.orig 2012-07-15 01:01:36.000000000 +1000
-+++ ./setup.py 2012-07-15 01:01:49.000000000 +1000
-@@ -30,4 +30,5 @@
- 'Programming Language :: Python',
+--- ./setup.py.orig 2014-03-08 14:16:00.573786621 +1100
++++ ./setup.py 2014-03-08 14:16:32.606016182 +1100
+@@ -29,4 +29,5 @@
+ 'Operating System :: OS Independent',
'Topic :: Software Development :: Libraries :: Python Modules',
],
-+ zip_safe=False,
++ test_suite = 'nose.collector',
)
diff --git a/net/py-beanstalkc/pkg-descr b/net/py-beanstalkc/pkg-descr
index 15efd0923172..ad28fc06028b 100644
--- a/net/py-beanstalkc/pkg-descr
+++ b/net/py-beanstalkc/pkg-descr
@@ -1,3 +1,3 @@
beanstalkc is a simple beanstalkd client library for Python.
-WWW: https://pypi.python.org/pypi/beanstalkc/
+WWW: https://github.com/earl/beanstalkc/