aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorrafan <rafan@FreeBSD.org>2007-02-24 15:52:26 +0800
committerrafan <rafan@FreeBSD.org>2007-02-24 15:52:26 +0800
commit8d1d2137184149e76d9118d947340db222ce26d3 (patch)
treecb8d3c649dd3c5dbf63d217c9f1d8431c1d71d57 /net
parent973f8a7bcea722bcc49f39c20399fb2ad2a54816 (diff)
downloadfreebsd-ports-gnome-8d1d2137184149e76d9118d947340db222ce26d3.tar.gz
freebsd-ports-gnome-8d1d2137184149e76d9118d947340db222ce26d3.tar.zst
freebsd-ports-gnome-8d1d2137184149e76d9118d947340db222ce26d3.zip
Add iodine 0.3.4, tunnel IPv4 data through a DNS server.
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/iodine/Makefile36
-rw-r--r--net/iodine/distinfo3
-rw-r--r--net/iodine/pkg-descr5
-rw-r--r--net/iodine/pkg-message19
5 files changed, 64 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index bd2c40e1bd8c..1b922dd024ed 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -195,6 +195,7 @@
SUBDIR += ifstated
SUBDIR += ilbc
SUBDIR += imapproxy
+ SUBDIR += iodine
SUBDIR += ip6_int
SUBDIR += ipa_ip6fw
SUBDIR += ipa_ipfw
diff --git a/net/iodine/Makefile b/net/iodine/Makefile
new file mode 100644
index 000000000000..82d4ae8cb8a0
--- /dev/null
+++ b/net/iodine/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: iodine
+# Date created: Feb 15 2006
+# Whom: Rong-En Fan <rafan@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= iodine
+PORTVERSION= 0.3.4
+CATEGORIES= net
+MASTER_SITES= http://code.kryo.se/iodine/
+
+MAINTAINER= rafan@FreeBSD.org
+COMMENT= Tunnel IPv4 data through a DNS server
+
+PLIST_FILES= bin/iodine sbin/iodined
+
+PORTDOCS= CHANGELOG README TODO
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,^CC =,CC ?=,' -e 's,^CFLAGS =,CFLAGS +=,' \
+ ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/iodine ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/iodined ${PREFIX}/sbin
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/iodine/distinfo b/net/iodine/distinfo
new file mode 100644
index 000000000000..e0ca2204ae2f
--- /dev/null
+++ b/net/iodine/distinfo
@@ -0,0 +1,3 @@
+MD5 (iodine-0.3.4.tar.gz) = dfbc5037fe0229e15f6f15775117aef5
+SHA256 (iodine-0.3.4.tar.gz) = 08a60f1dde655e37e136a498f73abcf25562239b02aa7c272c3cceb34ca2a5d5
+SIZE (iodine-0.3.4.tar.gz) = 14207
diff --git a/net/iodine/pkg-descr b/net/iodine/pkg-descr
new file mode 100644
index 000000000000..e82af63f2062
--- /dev/null
+++ b/net/iodine/pkg-descr
@@ -0,0 +1,5 @@
+This is a piece of software that lets you tunnel IPv4 data through a DNS
+server. This can be usable in different situations where Internet access is
+firewalled, but DNS queries are allowed.
+
+WWW: http://code.kryo.se/iodine/
diff --git a/net/iodine/pkg-message b/net/iodine/pkg-message
new file mode 100644
index 000000000000..4d92bce671bc
--- /dev/null
+++ b/net/iodine/pkg-message
@@ -0,0 +1,19 @@
+
+=== Quick Start ===
+
+Server:
+
+iodined -f -u nobody 10.0.0.1 tunnelhost.example.net
+
+Client:
+
+iodine -f -u nobody 192.168.1.1 tunnelhost.example.net
+
+You need add these lines to the DNS zone file:
+
+tunnelhost IN A 192.168.1.1
+tunnel IN NS tunnelhost.example.net
+
+The server side of the tunnel is 10.0.0.1.
+
+Please check README for details.