aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorleeym <leeym@FreeBSD.org>2006-02-18 02:44:32 +0800
committerleeym <leeym@FreeBSD.org>2006-02-18 02:44:32 +0800
commit8faded4ce270681dcbd70e3846295bb55e1e9842 (patch)
treedb6e6bb4d16bc7f1a446f8ff030fac1c8ff6b3a3 /net
parent0b00bbfc1e636ffde60f579fcd96f04e561aa0ad (diff)
downloadfreebsd-ports-gnome-8faded4ce270681dcbd70e3846295bb55e1e9842.tar.gz
freebsd-ports-gnome-8faded4ce270681dcbd70e3846295bb55e1e9842.tar.zst
freebsd-ports-gnome-8faded4ce270681dcbd70e3846295bb55e1e9842.zip
- add l4ip-v1.0.b294, the L4 health check daemon for IPFILTER.
The idea is that IPFilter in its current state can already do a simple L4 round-robin in its NAT rules. However, it does not detect or sense when a service and/or host is down. It will continue to send requests to a downed service/host. However, IPFilter lets us add and remove rules on-the-fly so it should be possible to build a daemon that lets you specify "clusters". In each cluster you would specify its members/hosts and services. As well as a health-check for the service to determine its current state. Once a service was deemed "up" we would add a Round-Robin rule to the NAT table, and naturally, the reverse once we detect a service as being "down". In addition to this, this program can optionally add ipf rules to log for RST (reset) packets coming from the members of your clusters. In the situations where the software/port goes down, but the host itself is still working, we would detect failure instantly. (Since the forwarded connections to the service would trigger a RST packet back). If this option is enabled, l4ip spawns the "ipmon" command to monitor for the "log" entries given when such a packet is detected. l4ip will then mark the service down. This is an add-on feature and is strictly not necessary for functional usage. It is currently only supported for TCP. WWW: http://www.lundman.net/unix/l4ip.php
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/l4ip/Makefile31
-rw-r--r--net/l4ip/distinfo3
-rw-r--r--net/l4ip/pkg-descr24
-rw-r--r--net/l4ip/pkg-plist12
5 files changed, 71 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index b83394026f20..3c59cf340d4d 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -221,6 +221,7 @@
SUBDIR += kphone
SUBDIR += krdesktop
SUBDIR += l2tpd
+ SUBDIR += l4ip
SUBDIR += lam
SUBDIR += lam7
SUBDIR += lambdamoo
diff --git a/net/l4ip/Makefile b/net/l4ip/Makefile
new file mode 100644
index 000000000000..594daf563378
--- /dev/null
+++ b/net/l4ip/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: l4ip
+# Date created: 17 February 2006
+# Whom: Yen-Ming Lee <leeym@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= l4ip
+PORTVERSION= 1.0.294
+CATEGORIES= net
+MASTER_SITES= http://www.lundman.net/ftp/l4ip/
+DISTNAME= ${PORTNAME}-${PORTVERSION:C/([0-9]*)\.([0-9]*)\.([0-9]*)/v\1.\2.b\3/}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= leeym@FreeBSD.org
+COMMENT= L4 and Health-Check project for IPFilter
+
+USE_GMAKE= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}/src
+
+post-patch:
+ ${REINPLACE_CMD} -e 's,service_type_t,script_type_t,g' ${WRKSRC}/service.c
+ ${REINPLACE_CMD} -e 's,/usr/sbin,/sbin,g' ${WRKSRC}/l4ip.conf
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/l4ip ${PREFIX}/sbin
+ ${INSTALL_DATA} ${WRKSRC}/l4ip.conf ${PREFIX}/etc
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL} ${WRKSRC}/../samples/*.conf ${EXAMPLESDIR}
+
+.include <bsd.port.mk>
diff --git a/net/l4ip/distinfo b/net/l4ip/distinfo
new file mode 100644
index 000000000000..d292f89268e2
--- /dev/null
+++ b/net/l4ip/distinfo
@@ -0,0 +1,3 @@
+MD5 (l4ip-v1.0.b294.tgz) = b5c56255e411cc41966e5af31b132506
+SHA256 (l4ip-v1.0.b294.tgz) = 5d2a0793cc75b0219f409a95a0448be08ef0a27881dc75e86917aaafe055baf5
+SIZE (l4ip-v1.0.b294.tgz) = 222162
diff --git a/net/l4ip/pkg-descr b/net/l4ip/pkg-descr
new file mode 100644
index 000000000000..5763656b6a0a
--- /dev/null
+++ b/net/l4ip/pkg-descr
@@ -0,0 +1,24 @@
+The idea is that IPFilter in its current state can already do a simple L4
+round-robin in its NAT rules. However, it does not detect or sense when a
+service and/or host is down. It will continue to send requests to a downed
+service/host.
+
+However, IPFilter lets us add and remove rules on-the-fly so it should be
+possible to build a daemon that lets you specify "clusters". In each cluster
+you would specify its members/hosts and services. As well as a health-check
+for the service to determine its current state.
+
+Once a service was deemed "up" we would add a Round-Robin rule to the NAT
+table, and naturally, the reverse once we detect a service as being "down".
+
+In addition to this, this program can optionally add ipf rules to log for RST
+(reset) packets coming from the members of your clusters. In the situations
+where the software/port goes down, but the host itself is still working, we
+would detect failure instantly. (Since the forwarded connections to the service
+would trigger a RST packet back). If this option is enabled, l4ip spawns the
+"ipmon" command to monitor for the "log" entries given when such a packet is
+detected. l4ip will then mark the service down. This is an add-on feature and
+is strictly not necessary for functional usage. It is currently only supported
+for TCP.
+
+WWW: http://www.lundman.net/unix/l4ip.php
diff --git a/net/l4ip/pkg-plist b/net/l4ip/pkg-plist
new file mode 100644
index 000000000000..4c140014c3b6
--- /dev/null
+++ b/net/l4ip/pkg-plist
@@ -0,0 +1,12 @@
+sbin/l4ip
+etc/l4ip.conf
+%%EXAMPLESDIR%%/apache1.conf
+%%EXAMPLESDIR%%/apache2.conf
+%%EXAMPLESDIR%%/dns1.conf
+%%EXAMPLESDIR%%/dns2.conf
+%%EXAMPLESDIR%%/ftp1.conf
+%%EXAMPLESDIR%%/ftp2.conf
+%%EXAMPLESDIR%%/ldap.conf
+%%EXAMPLESDIR%%/ldap1.conf
+%%EXAMPLESDIR%%/ldap2.conf
+@dirrm %%EXAMPLESDIR%%