aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authordumbbell <dumbbell@FreeBSD.org>2018-01-28 03:02:01 +0800
committerdumbbell <dumbbell@FreeBSD.org>2018-01-28 03:02:01 +0800
commit90e4521ee9393da755d620a21a439fa03559b329 (patch)
tree467d37335836db9f62d4f432de803046ec5897cc /net
parentc5898d2a963677d7c53bada1e7805446d1136a39 (diff)
downloadfreebsd-ports-gnome-90e4521ee9393da755d620a21a439fa03559b329.tar.gz
freebsd-ports-gnome-90e4521ee9393da755d620a21a439fa03559b329.tar.zst
freebsd-ports-gnome-90e4521ee9393da755d620a21a439fa03559b329.zip
net/bosh-{bootloader,cli}: New ports for the BOSH CLI v2
The new BOSH CLI is comprised of two executables: `bbl` and `bosh`. They replace the previous version of the CLI (sysutils/rubygem-bosh_cli). Sponsored by: Pivotal
Diffstat (limited to 'net')
-rw-r--r--net/Makefile2
-rw-r--r--net/bosh-bootloader/Makefile25
-rw-r--r--net/bosh-bootloader/distinfo3
-rw-r--r--net/bosh-bootloader/pkg-descr6
-rw-r--r--net/bosh-cli/Makefile29
-rw-r--r--net/bosh-cli/distinfo3
-rw-r--r--net/bosh-cli/pkg-descr4
7 files changed, 72 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 344a7d0e452e..1eb07069e934 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -55,6 +55,8 @@
SUBDIR += boclient
SUBDIR += boinc-client
SUBDIR += boinc_curses
+ SUBDIR += bosh-bootloader
+ SUBDIR += bosh-cli
SUBDIR += bounce
SUBDIR += bsdec2-image-upload
SUBDIR += bsdproxy
diff --git a/net/bosh-bootloader/Makefile b/net/bosh-bootloader/Makefile
new file mode 100644
index 000000000000..d118ace01874
--- /dev/null
+++ b/net/bosh-bootloader/Makefile
@@ -0,0 +1,25 @@
+# $FreeBSD$
+
+PORTNAME= bosh-bootloader
+PORTVERSION= 6.0.0
+CATEGORIES= net sysutils
+
+MAINTAINER= dumbbell@FreeBSD.org
+COMMENT= CLI for standing up CloudFoundry or Concourse on an IAAS
+
+LICENSE= APACHE20
+
+USE_GITHUB= yes
+GH_TUPLE= cloudfoundry:bosh-bootloader:v${PORTVERSION}
+
+USES= go tar:xz
+
+GO_PKGNAME= github.com/cloudfoundry/bosh-bootloader
+GO_TARGET= github.com/cloudfoundry/bosh-bootloader/bbl
+
+PLIST_FILES= bin/bbl
+
+post-patch:
+ ${REINPLACE_CMD} -E -e 's|(Version = )"dev"|\1"${PORTVERSION}"|' ${WRKSRC}/bbl/main.go
+
+.include <bsd.port.mk>
diff --git a/net/bosh-bootloader/distinfo b/net/bosh-bootloader/distinfo
new file mode 100644
index 000000000000..531932ba7c40
--- /dev/null
+++ b/net/bosh-bootloader/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1517077398
+SHA256 (cloudfoundry-bosh-bootloader-6.0.0-v6.0.0_GH0.tar.gz) = 6390b292a60278c5fbeb60582405afd146c7eefc8a5e0a05215b9325a6e15e95
+SIZE (cloudfoundry-bosh-bootloader-6.0.0-v6.0.0_GH0.tar.gz) = 4113792
diff --git a/net/bosh-bootloader/pkg-descr b/net/bosh-bootloader/pkg-descr
new file mode 100644
index 000000000000..1ef34b184e95
--- /dev/null
+++ b/net/bosh-bootloader/pkg-descr
@@ -0,0 +1,6 @@
+This is a command line utility for standing up a CloudFoundry or
+Concourse installation on an IAAS. This CLI is currently under heavy
+development, and the initial goal is to support bootstrapping a
+CloudFoundry installation on AWS.
+
+WWW: https://github.com/cloudfoundry/bosh-bootloader
diff --git a/net/bosh-cli/Makefile b/net/bosh-cli/Makefile
new file mode 100644
index 000000000000..40b656854411
--- /dev/null
+++ b/net/bosh-cli/Makefile
@@ -0,0 +1,29 @@
+# $FreeBSD$
+
+PORTNAME= bosh-cli
+PORTVERSION= 2.0.48
+CATEGORIES= net sysutils
+
+MAINTAINER= dumbbell@FreeBSD.org
+COMMENT= CLI for BOSH
+
+LICENSE= APACHE20
+
+USE_GITHUB= yes
+GH_TUPLE= cloudfoundry:bosh-cli:v${PORTVERSION}
+
+CONFLICTS_INSTALL= rubygem-bosh_cli
+
+USES= go tar:xz
+
+GO_PKGNAME= github.com/cloudfoundry/bosh-cli
+
+PLIST_FILES= bin/bosh
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|\[DEV BUILD\]|${PORTVERSION}|' ${WRKSRC}/cmd/version.go
+
+post-install:
+ ${MV} ${STAGEDIR}${PREFIX}/bin/bosh-cli ${STAGEDIR}${PREFIX}/bin/bosh
+
+.include <bsd.port.mk>
diff --git a/net/bosh-cli/distinfo b/net/bosh-cli/distinfo
new file mode 100644
index 000000000000..02a6801d7972
--- /dev/null
+++ b/net/bosh-cli/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1517077409
+SHA256 (cloudfoundry-bosh-cli-2.0.48-v2.0.48_GH0.tar.gz) = 846840d078d539e8642335511c4ceba941a710e0e65a8c1cc592155ae88d787d
+SIZE (cloudfoundry-bosh-cli-2.0.48-v2.0.48_GH0.tar.gz) = 4182093
diff --git a/net/bosh-cli/pkg-descr b/net/bosh-cli/pkg-descr
new file mode 100644
index 000000000000..c6a87fca896d
--- /dev/null
+++ b/net/bosh-cli/pkg-descr
@@ -0,0 +1,4 @@
+The BOSH Command Line Interface (CLI) is what you use to run BOSH
+commands. CLI v2 is a new major version of CLI.
+
+WWW: https://bosh.io/docs/cli-v2.html