aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2010-11-13 21:40:40 +0800
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2010-11-13 21:40:40 +0800
commit93c5103c48bc32306c1dfe66054fbe9879c904b2 (patch)
tree30f4517498d6f8904ef6b347d09515831d6a1c9f /net
parent887f7e222223c5e577d49c4a01fb28b475d1d4a5 (diff)
downloadfreebsd-ports-gnome-93c5103c48bc32306c1dfe66054fbe9879c904b2.tar.gz
freebsd-ports-gnome-93c5103c48bc32306c1dfe66054fbe9879c904b2.tar.zst
freebsd-ports-gnome-93c5103c48bc32306c1dfe66054fbe9879c904b2.zip
- Add p5-Net-uFTP 0.16
NET::uFTP is a Perl5 module providing a universal interface for FTP-like modules (FTP, SFTP, SCP), in most cases Net::FTP compatible. WWW: http://search.cpan.org/dist/Net-uFTP/ PR: ports/152126 Submitted by: Jase Thew <freebsd@beardz.net>
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-Net-uFTP/Makefile28
-rw-r--r--net/p5-Net-uFTP/distinfo2
-rw-r--r--net/p5-Net-uFTP/pkg-descr4
-rw-r--r--net/p5-Net-uFTP/pkg-plist8
5 files changed, 43 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 60550d84c328..7b7bb479f847 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -668,6 +668,7 @@
SUBDIR += p5-Net-Z3950-SimpleServer
SUBDIR += p5-Net-Z3950-ZOOM
SUBDIR += p5-Net-ext
+ SUBDIR += p5-Net-uFTP
SUBDIR += p5-NetAddr-IP-Count
SUBDIR += p5-NetPacket
SUBDIR += p5-OAI-Harvester
diff --git a/net/p5-Net-uFTP/Makefile b/net/p5-Net-uFTP/Makefile
new file mode 100644
index 000000000000..0ed528c721b7
--- /dev/null
+++ b/net/p5-Net-uFTP/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: Net-uFTP
+# Date created: 2010-11-10
+# Whom: Jase Thew <freebsd@beardz.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-uFTP
+PORTVERSION= 0.16
+CATEGORIES= net devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= freebsd@beardz.net
+COMMENT= A universal interface for FTP-like modules (FTP, SFTP, SCP)
+
+BUILD_DEPENDS= p5-Class-Accessor-Fast-XS>=0:${PORTSDIR}/devel/p5-Class-Accessor-Fast-XS \
+ p5-File-Stat-ModeString>=0:${PORTSDIR}/sysutils/p5-File-Stat-ModeString \
+ p5-Net-FTP-AutoReconnect>=0:${PORTSDIR}/net/p5-Net-FTP-AutoReconnect \
+ p5-Net-SSH2>=0:${PORTSDIR}/net/p5-Net-SSH2 \
+ p5-UNIVERSAL-require>=0:${PORTSDIR}/devel/p5-UNIVERSAL-require
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::uFTP.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-Net-uFTP/distinfo b/net/p5-Net-uFTP/distinfo
new file mode 100644
index 000000000000..6dbb9a4808d0
--- /dev/null
+++ b/net/p5-Net-uFTP/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Net-uFTP-0.16.tar.gz) = a93b1a8df37b21badb035b957f8f793dd7203f99eef12535ae4daaaaa701254a
+SIZE (Net-uFTP-0.16.tar.gz) = 11063
diff --git a/net/p5-Net-uFTP/pkg-descr b/net/p5-Net-uFTP/pkg-descr
new file mode 100644
index 000000000000..bbea8af88a76
--- /dev/null
+++ b/net/p5-Net-uFTP/pkg-descr
@@ -0,0 +1,4 @@
+NET::uFTP is a Perl5 module providing a universal interface for FTP-like
+modules (FTP, SFTP, SCP), in most cases Net::FTP compatible.
+
+WWW: http://search.cpan.org/dist/Net-uFTP/
diff --git a/net/p5-Net-uFTP/pkg-plist b/net/p5-Net-uFTP/pkg-plist
new file mode 100644
index 000000000000..cd51113bbe42
--- /dev/null
+++ b/net/p5-Net-uFTP/pkg-plist
@@ -0,0 +1,8 @@
+%%SITE_PERL%%/Net/uFTP.pm
+%%SITE_PERL%%/Net/uFTP/FTP.pm
+%%SITE_PERL%%/Net/uFTP/SFTP.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/uFTP/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/uFTP
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net
+@dirrm %%SITE_PERL%%/Net/uFTP
+@dirrmtry %%SITE_PERL%%/Net