aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorwxs <wxs@FreeBSD.org>2012-11-19 23:17:56 +0800
committerwxs <wxs@FreeBSD.org>2012-11-19 23:17:56 +0800
commit96ec2a3d804a256b4cfb6e51eba6d4d249c8e9ef (patch)
tree411b649778ae82f407822cf7b760419ea024734f /net
parentad735278265a2c848a85863cb4dbeff743802ac0 (diff)
downloadfreebsd-ports-gnome-96ec2a3d804a256b4cfb6e51eba6d4d249c8e9ef.tar.gz
freebsd-ports-gnome-96ec2a3d804a256b4cfb6e51eba6d4d249c8e9ef.tar.zst
freebsd-ports-gnome-96ec2a3d804a256b4cfb6e51eba6d4d249c8e9ef.zip
Convert to new options.
While here, drop the old libnet10 option. Feature safe: yes
Diffstat (limited to 'net')
-rw-r--r--net/libnids/Makefile26
1 files changed, 14 insertions, 12 deletions
diff --git a/net/libnids/Makefile b/net/libnids/Makefile
index fd76e1b3503f..43740a95dcb2 100644
--- a/net/libnids/Makefile
+++ b/net/libnids/Makefile
@@ -15,30 +15,32 @@ COMMENT= Network monitoring library with TCP/IP reassembly
LICENSE= GPLv2
-OPTIONS= LIBNET "Include code requiring libnet" ON \
- LIBNET10 "Use the old libnet-1.0.x version" ON \
- GLIB2 "Use GLIB2 for multiprocessing support" ON
+OPTIONS_DEFINE= LIBNET GLIB2
+LIBNET_DESC= "Use libnet 1.1.x"
+GLIB2_DESC= "Use GLIB2 for multiprocessing support"
+OPTIONS_DEFAULT= LIBNET GLIB2
WANT_GNOME= yes
GNU_CONFIGURE= yes
MAN3= libnids.3
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_LIBNET)
-.if !defined(WITHOUT_LIBNET10)
-BUILD_DEPENDS+= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet10
-LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet10-config
+.if ${PORT_OPTIONS:MDOCS}
+PLIST_SUB+= PORTDOCS=""
.else
+PLIST_SUB+= PORTDOCS="@comment "
+.endif
+
+.if ${PORT_OPTIONS:MLIBNET}
BUILD_DEPENDS+= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet
LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet11-config
-.endif
.else
CONFIGURE_ARGS+= --disable-libnet
.endif
-.if !defined(WITHOUT_GLIB2)
+.if ${PORT_OPTIONS:MGLIB2}
USE_GNOME+= glib20
.else
CONFIGURE_ARGS+= --disable-libglib
@@ -56,11 +58,11 @@ do-install:
${INSTALL_MAN} ${WRKSRC}/src/libnids.3 ${PREFIX}/man/man3
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
.for i in README doc/*
${INSTALL_DATA} ${WRKSRC}/$i ${DOCSDIR}/
.endfor
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>