aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorpgj <pgj@FreeBSD.org>2011-08-14 09:27:45 +0800
committerpgj <pgj@FreeBSD.org>2011-08-14 09:27:45 +0800
commit9724f793497b8f9ad2d77e4301a8c770fa6d1086 (patch)
treec12065f82f6f49dd4cba9adabe70cdaeff6910e9 /net
parente7b569e15c36f59bf3d9723a2f57cfb4e32f4b20 (diff)
downloadfreebsd-ports-gnome-9724f793497b8f9ad2d77e4301a8c770fa6d1086.tar.gz
freebsd-ports-gnome-9724f793497b8f9ad2d77e4301a8c770fa6d1086.tar.zst
freebsd-ports-gnome-9724f793497b8f9ad2d77e4301a8c770fa6d1086.zip
Cross-platform library for the sendfile() system call. This library tries
to call minimum system calls which are the bottleneck of web servers. WWW: https://github.com/kazu-yamamoto/simple-sendfile/ Obtained from: FreeBSD Haskell
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/hs-simple-sendfile/Makefile21
-rw-r--r--net/hs-simple-sendfile/distinfo2
-rw-r--r--net/hs-simple-sendfile/pkg-descr4
4 files changed, 28 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 36ad12ba1330..e9291ce9c720 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -222,6 +222,7 @@
SUBDIR += hs-network
SUBDIR += hs-pcap
SUBDIR += hs-sendfile
+ SUBDIR += hs-simple-sendfile
SUBDIR += htpdate
SUBDIR += http_ping
SUBDIR += httping
diff --git a/net/hs-simple-sendfile/Makefile b/net/hs-simple-sendfile/Makefile
new file mode 100644
index 000000000000..581edcbf5d2f
--- /dev/null
+++ b/net/hs-simple-sendfile/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: hs-simple-sendfile
+# Date created: July 13, 2011
+# Whom: haskell@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= simple-sendfile
+PORTVERSION= 0.1.2
+CATEGORIES= net haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= Cross-platform library for the sendfile() system call
+
+LICENSE= BSD
+
+CABAL_SETUP= Setup.hs
+USE_CABAL= enumerator network transformers
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/net/hs-simple-sendfile/distinfo b/net/hs-simple-sendfile/distinfo
new file mode 100644
index 000000000000..c242c7b6a6e9
--- /dev/null
+++ b/net/hs-simple-sendfile/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/simple-sendfile-0.1.2.tar.gz) = 126d9e486c33c1ff3ec37c935c79c6eda390626bd388107e4132902e54cc8523
+SIZE (cabal/simple-sendfile-0.1.2.tar.gz) = 3841
diff --git a/net/hs-simple-sendfile/pkg-descr b/net/hs-simple-sendfile/pkg-descr
new file mode 100644
index 000000000000..25cf93ea6d88
--- /dev/null
+++ b/net/hs-simple-sendfile/pkg-descr
@@ -0,0 +1,4 @@
+Cross-platform library for the sendfile() system call. This library tries
+to call minimum system calls which are the bottleneck of web servers.
+
+WWW: https://github.com/kazu-yamamoto/simple-sendfile/