aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorerwin <erwin@FreeBSD.org>2006-08-04 20:34:50 +0800
committererwin <erwin@FreeBSD.org>2006-08-04 20:34:50 +0800
commit983dc15ba8f877d94d8e2b8c777deb8199f4ec99 (patch)
treeb75af0a340e3a5fb325b96ab4419867bc2a7a996 /net
parent0aec5ee33513f1341433ac3950105867e7edbae9 (diff)
downloadfreebsd-ports-gnome-983dc15ba8f877d94d8e2b8c777deb8199f4ec99.tar.gz
freebsd-ports-gnome-983dc15ba8f877d94d8e2b8c777deb8199f4ec99.tar.zst
freebsd-ports-gnome-983dc15ba8f877d94d8e2b8c777deb8199f4ec99.zip
Add support for DESTDIR part I.
This commit should largele be a NOOP as it only adds support for DESTDIR undefined. This does allow us to start testing ports with DESTDIR set, but this is as of yet not supported. Although this has been extensively tested on pointyhat, this is a very intrusive change and some cases may have been overlooked. Please contact Gabor and me if you find any. PR: 100555 Submitted by: gabor Sponsored by: Google Summer of Code 2006
Diffstat (limited to 'net')
-rw-r--r--net/globus4/Makefile2
-rw-r--r--net/libpcap/Makefile2
-rw-r--r--net/mpich/Makefile2
-rw-r--r--net/rrdtool/Makefile2
-rw-r--r--net/rrdtool10/Makefile2
-rw-r--r--net/spread/Makefile2
-rw-r--r--net/spread4/Makefile2
-rw-r--r--net/tcpdump/Makefile2
8 files changed, 8 insertions, 8 deletions
diff --git a/net/globus4/Makefile b/net/globus4/Makefile
index aac3c4f4f2c2..c7d4d3a30915 100644
--- a/net/globus4/Makefile
+++ b/net/globus4/Makefile
@@ -37,7 +37,7 @@ USE_GMAKE= yes
USE_PERL5= yes
GLOBUS_BASE?= globus
-GLOBUS_LOCATION=${PREFIX}/${GLOBUS_BASE}
+GLOBUS_LOCATION=${TARGETDIR}/${GLOBUS_BASE}
TMP_GLOBUS_LOCATION= ${WRKDIR}/globus
TMP_GLOBUS_ENV= GLOBUS_LOCATION=${TMP_GLOBUS_LOCATION} \
GPT_LOCATION=${TMP_GLOBUS_LOCATION}
diff --git a/net/libpcap/Makefile b/net/libpcap/Makefile
index ce8899a25837..d184757d764e 100644
--- a/net/libpcap/Makefile
+++ b/net/libpcap/Makefile
@@ -25,7 +25,7 @@ USE_BISON= yes
.if defined(LIBPCAP_OVERWRITE_BASE)
PREFIX= /usr
PKGNAMESUFFIX= -overwrite-base
-MANPREFIX= ${PREFIX}/share
+MANPREFIX= ${TARGETDIR}/share
CONFIGURE_ARGS+=--mandir=${MANPREFIX}/man
PLIST_SUB+= NOTBASE="@comment "
PLIST_SUB+= BASE=""
diff --git a/net/mpich/Makefile b/net/mpich/Makefile
index 722a8e819daa..be3cbadc95e5 100644
--- a/net/mpich/Makefile
+++ b/net/mpich/Makefile
@@ -62,7 +62,7 @@ HAS_CONFIGURE= yes
ALL_TARGET=
-MANPREFIX= ${PREFIX}/mpich
+MANPREFIX= ${TARGETDIR}/mpich
MAN1= MPI.1 cleanipcs.1 mpiCC.1 mpicc.1 mpif77.1 mpif90.1 mpiman.1 \
mpireconfig.1 mpirun.1 Jumpshots.1 chp4_servs.1 tstmachines.1
diff --git a/net/rrdtool/Makefile b/net/rrdtool/Makefile
index 1a812652c004..291d0017422d 100644
--- a/net/rrdtool/Makefile
+++ b/net/rrdtool/Makefile
@@ -36,7 +36,7 @@ MAN1= bin_dec_hex.1 cdeftutorial.1 rpntutorial.1 rrd-beginners.1 \
rrdthreads.1 rrdtool.1 rrdtune.1 rrdtutorial.1 rrdupdate.1 \
rrdxport.1
MAN3= RRDp.3 RRDs.3
-MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3PREFIX= ${TARGETDIR}/lib/perl5/${PERL_VERSION}
post-extract:
.if defined(NOPORTDOCS)
diff --git a/net/rrdtool10/Makefile b/net/rrdtool10/Makefile
index da30bc4b63a3..9b659fce79de 100644
--- a/net/rrdtool10/Makefile
+++ b/net/rrdtool10/Makefile
@@ -36,7 +36,7 @@ MAN1= RRDp.1 RRDs.1 bin_dec_hex.1 rrdcgi.1 rrdcreate.1 rrddump.1 \
cdeftutorial.1 rpntutorial.1 rrdinfo.1 rrdxport.1 rrd-beginners.1 \
rrdfirst.1
MAN3= RRDp.3 RRDs.3
-MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3PREFIX= ${TARGETDIR}/lib/perl5/${PERL_VERSION}
OPTIONS= "ISO-8859-2 fonts support" off
diff --git a/net/spread/Makefile b/net/spread/Makefile
index 9b29ba36f7d6..5390411bc8df 100644
--- a/net/spread/Makefile
+++ b/net/spread/Makefile
@@ -40,7 +40,7 @@ MAN3= libsp.3 SP_connect.3 SP_disconnect.3 SP_equal_group_ids.3 \
PERL_CONFIGURE_ARGS= CC="${CC}" CCFLAGS="${CFLAGS}" PREFIX="${PREFIX}" \
INSTALLPRIVLIB="${PREFIX}/lib" INSTALLARCHLIB="${PREFIX}/lib"
-_MANPAGES+= ${PREFIX}/lib/perl5/${PERL_VERSION}/man/man3/Spread.3
+_MANPAGES+= ${TARGETDIR}/lib/perl5/${PERL_VERSION}/man/man3/Spread.3
post-configure:
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' \
diff --git a/net/spread4/Makefile b/net/spread4/Makefile
index 9b29ba36f7d6..5390411bc8df 100644
--- a/net/spread4/Makefile
+++ b/net/spread4/Makefile
@@ -40,7 +40,7 @@ MAN3= libsp.3 SP_connect.3 SP_disconnect.3 SP_equal_group_ids.3 \
PERL_CONFIGURE_ARGS= CC="${CC}" CCFLAGS="${CFLAGS}" PREFIX="${PREFIX}" \
INSTALLPRIVLIB="${PREFIX}/lib" INSTALLARCHLIB="${PREFIX}/lib"
-_MANPAGES+= ${PREFIX}/lib/perl5/${PERL_VERSION}/man/man3/Spread.3
+_MANPAGES+= ${TARGETDIR}/lib/perl5/${PERL_VERSION}/man/man3/Spread.3
post-configure:
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' \
diff --git a/net/tcpdump/Makefile b/net/tcpdump/Makefile
index d025b4d16a46..e5097acd9c19 100644
--- a/net/tcpdump/Makefile
+++ b/net/tcpdump/Makefile
@@ -31,7 +31,7 @@ GNU_CONFIGURE= yes
.if defined(TCPDUMP_OVERWRITE_BASE)
PREFIX= /usr
PKGNAMESUFFIX= -overwrite-base
-MANPREFIX= ${PREFIX}/share
+MANPREFIX= ${TARGETDIR}/share
CONFIGURE_ARGS+=--mandir=${MANPREFIX}/man
PLIST_SUB+= NOTBASE="@comment "
PLIST_SUB+= BASE=""