aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2015-04-03 16:02:55 +0800
committerEmanuel Haupt <ehaupt@FreeBSD.org>2015-04-03 16:02:55 +0800
commit99dd8308683dd7685dbef087f9a146e44b9400d0 (patch)
tree4976ff636c61a82ce6a309e59aee2d63ead76b32 /net
parentba7444aaef33daabb91bdc430343d74209ca36f9 (diff)
downloadfreebsd-ports-gnome-99dd8308683dd7685dbef087f9a146e44b9400d0.tar.gz
freebsd-ports-gnome-99dd8308683dd7685dbef087f9a146e44b9400d0.tar.zst
freebsd-ports-gnome-99dd8308683dd7685dbef087f9a146e44b9400d0.zip
Add net/mdns-repeater a Multicast DNS repeater. Multicast DNS uses the
224.0.0.51 address, which is "administratively scoped" and does not leave the subnet. This program re-broadcast mDNS packets from one interface to other interfaces. It can be used to bridge zeroconf devices to work properly across the two subnets.
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/mdns-repeater/Makefile25
-rw-r--r--net/mdns-repeater/distinfo2
-rw-r--r--net/mdns-repeater/pkg-descr9
4 files changed, 37 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index d22ae534bfec..0a643cd97874 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -363,6 +363,7 @@
SUBDIR += mad_fcl
SUBDIR += malo-firmware-kmod
SUBDIR += mcast-tools
+ SUBDIR += mdns-repeater
SUBDIR += mediastreamer
SUBDIR += mediatomb
SUBDIR += megatools
diff --git a/net/mdns-repeater/Makefile b/net/mdns-repeater/Makefile
new file mode 100644
index 000000000000..a954eef022bb
--- /dev/null
+++ b/net/mdns-repeater/Makefile
@@ -0,0 +1,25 @@
+# Created by: Emanuel Haupt <ehaupt@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= mdns-repeater
+PORTVERSION= 1.10
+CATEGORIES= net dns
+MASTER_SITES= LOCAL/ehaupt
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= Multicast DNS repeater to re-broadcast mDNS packets across interfaces
+
+LICENSE= GPLv2
+
+CFLAGS+= -DHGVERSION="\"${PORTVERSION}\""
+
+PLIST_FILES= bin/mdns-repeater
+
+do-build:
+ ${CC} ${CFLAGS} -o ${WRKSRC}/${PORTNAME} ${WRKSRC}/${PORTNAME}.c
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/net/mdns-repeater/distinfo b/net/mdns-repeater/distinfo
new file mode 100644
index 000000000000..930ffab4642c
--- /dev/null
+++ b/net/mdns-repeater/distinfo
@@ -0,0 +1,2 @@
+SHA256 (mdns-repeater-1.10.tar.gz) = 9c49c4256f6a4962c2b3fcb69f05c5f2eb76eb2c0a56f1e6153b2928d1360606
+SIZE (mdns-repeater-1.10.tar.gz) = 10608
diff --git a/net/mdns-repeater/pkg-descr b/net/mdns-repeater/pkg-descr
new file mode 100644
index 000000000000..17933a82bd7f
--- /dev/null
+++ b/net/mdns-repeater/pkg-descr
@@ -0,0 +1,9 @@
+mdns-repeater is a Multicast DNS repeater. Multicast DNS uses the 224.0.0.51
+address, which is "administratively scoped" and does not leave the subnet.
+
+This program re-broadcast mDNS packets from one interface to other interfaces.
+
+It can be used to bridge zeroconf devices to work properly across the two
+subnets.
+
+WWW: https://bitbucket.org/geekman/mdns-repeater/