aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorzi <zi@FreeBSD.org>2014-04-03 06:19:50 +0800
committerzi <zi@FreeBSD.org>2014-04-03 06:19:50 +0800
commit9b0efbf3d0493b979d75730960c094d6d28bf0c8 (patch)
tree01b8cd0ff17b36b6e53b332c8abcb0c944f05e8a /net
parent1ad9e24f5bc242c62f9cd3c528bf517176fb0b17 (diff)
downloadfreebsd-ports-gnome-9b0efbf3d0493b979d75730960c094d6d28bf0c8.tar.gz
freebsd-ports-gnome-9b0efbf3d0493b979d75730960c094d6d28bf0c8.tar.zst
freebsd-ports-gnome-9b0efbf3d0493b979d75730960c094d6d28bf0c8.zip
- Fix build when devel/libexecinfo is present
- Bump PORTREVISION PR: ports/188089 Submitted by: Lawrence "The Dreamer" Chen <beastie@tardisi.com>, feld@, Konstantin Belousov <kostikbel@gmail.com>
Diffstat (limited to 'net')
-rw-r--r--net/freeradius2/Makefile4
-rw-r--r--net/freeradius3/Makefile4
2 files changed, 8 insertions, 0 deletions
diff --git a/net/freeradius2/Makefile b/net/freeradius2/Makefile
index adc26cdf58ec..1af4956f041d 100644
--- a/net/freeradius2/Makefile
+++ b/net/freeradius2/Makefile
@@ -3,6 +3,7 @@
PORTNAME= freeradius
DISTVERSION= 2.2.4
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= ftp://ftp.freeradius.org/pub/freeradius/%SUBDIR%/ \
ftp://ftp.ntua.gr/pub/net/radius/freeradius/%SUBDIR%/ \
@@ -331,6 +332,9 @@ MAN8= radiusd.8 radmin.8 raddebug.8 radrelay.8 radsqlrelay.8 \
SUB_LIST+= REQUIRE="${_REQUIRE}"
post-patch:
+# never try to find execinfo.h (needed until we can enable/disable backtrace
+ @${REINPLACE_CMD} -e '/execinfo.h/d' ${WRKSRC}/configure \
+ ${WRKSRC}/configure.in
# Patch Makefile / Makefile.in throughout the source tree to install raddb
# contents in ${EXAMPLESDIR}/raddb rather than the raddbdir from configure
@${FIND} -E ${WRKSRC} -regex '.*/Makefile(\.in)?$$' -exec \
diff --git a/net/freeradius3/Makefile b/net/freeradius3/Makefile
index c47afeca1663..d6e246e743d0 100644
--- a/net/freeradius3/Makefile
+++ b/net/freeradius3/Makefile
@@ -3,6 +3,7 @@
PORTNAME= freeradius
DISTVERSION= 3.0.2
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= ftp://ftp.freeradius.org/pub/freeradius/%SUBDIR%/ \
ftp://ftp.ntua.gr/pub/net/radius/freeradius/%SUBDIR%/ \
@@ -358,6 +359,9 @@ MAN8= radiusd.8 radmin.8 raddebug.8 radrelay.8 radsqlrelay.8 \
SUB_LIST+= REQUIRE="${_REQUIRE}"
post-patch:
+# never try to find execinfo.h (needed until we can enable/disable backtrace
+ @${REINPLACE_CMD} -e '/execinfo.h/d' ${WRKSRC}/configure \
+ ${WRKSRC}/configure.in
@${REINPLACE_CMD} -Ee "s:tests/all.mk ::" ${WRKSRC}/src/all.mk
@${CP} ${WRKSRC}/m4/ax_with_prog.m4 ${WRKSRC}
@${REINPLACE_CMD} -Ee "s:^make:${GMAKE}:" \