aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorzi <zi@FreeBSD.org>2015-07-04 09:00:38 +0800
committerzi <zi@FreeBSD.org>2015-07-04 09:00:38 +0800
commit9eea23cbecba39dbdefe629d8dd05123880cc75b (patch)
tree155357535742bab40e0197a71a5638196b89d231 /net
parent4ea03c99bafacc566aa064ebf6c7401dd2e4e413 (diff)
downloadfreebsd-ports-gnome-9eea23cbecba39dbdefe629d8dd05123880cc75b.tar.gz
freebsd-ports-gnome-9eea23cbecba39dbdefe629d8dd05123880cc75b.tar.zst
freebsd-ports-gnome-9eea23cbecba39dbdefe629d8dd05123880cc75b.zip
- Fix rc script when running nslcd on host and within a jail
PR: 201298 Submitted by: Kan Sasaki (sasaki@fcc.ad.jp)
Diffstat (limited to 'net')
-rw-r--r--net/nss-pam-ldapd/Makefile2
-rw-r--r--net/nss-pam-ldapd/files/nslcd.in7
2 files changed, 5 insertions, 4 deletions
diff --git a/net/nss-pam-ldapd/Makefile b/net/nss-pam-ldapd/Makefile
index bbc37c492673..690a0a5b6440 100644
--- a/net/nss-pam-ldapd/Makefile
+++ b/net/nss-pam-ldapd/Makefile
@@ -3,7 +3,7 @@
PORTNAME= nss-pam-ldapd
PORTVERSION= 0.8.14
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net
MASTER_SITES= http://arthurdejong.org/nss-pam-ldapd/ \
http://mirrors.rit.edu/zi/
diff --git a/net/nss-pam-ldapd/files/nslcd.in b/net/nss-pam-ldapd/files/nslcd.in
index ad9e1cb9989e..9dea064b36fb 100644
--- a/net/nss-pam-ldapd/files/nslcd.in
+++ b/net/nss-pam-ldapd/files/nslcd.in
@@ -80,10 +80,11 @@ nslcd_stop()
nslcd_findpid()
{
- if ! checkyesno nslcd_supervisor && $(%%PREFIX%%/sbin/nslcd -c && pgrep -F /var/run/nslcd.pid > /dev/null); then
+ if %%PREFIX%%/sbin/nslcd -c && pgrep -q -F /var/run/nslcd.pid; then
mypid=$(cat /var/run/nslcd.pid)
- else
- mypid=$(pgrep -f "daemon: %%PREFIX%%/sbin/nslcd")
+ if checkyesno nslcd_supervisor; then
+ mypid=$(pgrep -f "daemon: %%PREFIX%%/sbin/nslcd\[${mypid}\]")
+ fi
fi
}