aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authornovel <novel@FreeBSD.org>2015-08-02 03:00:11 +0800
committernovel <novel@FreeBSD.org>2015-08-02 03:00:11 +0800
commit9f5b250d4361b7ecade8ae912f0cb7e34810d405 (patch)
treece4419ebb8ced4d334ad7b4a6bcabf55f7bd6e5e /net
parente70ba9a8f26824897212bf4b1219c2bf5a7c4e67 (diff)
downloadfreebsd-ports-gnome-9f5b250d4361b7ecade8ae912f0cb7e34810d405.tar.gz
freebsd-ports-gnome-9f5b250d4361b7ecade8ae912f0cb7e34810d405.tar.zst
freebsd-ports-gnome-9f5b250d4361b7ecade8ae912f0cb7e34810d405.zip
Drop backports.ssl-match-hostname from requirements. We're not using it
since r389589 anyway. PR: 201901 Submitted by: Kurt Jaeger
Diffstat (limited to 'net')
-rw-r--r--net/py-libcloud/Makefile2
-rw-r--r--net/py-libcloud/files/patch-setup.py29
2 files changed, 30 insertions, 1 deletions
diff --git a/net/py-libcloud/Makefile b/net/py-libcloud/Makefile
index a1c25835a6b2..c570073b4eb0 100644
--- a/net/py-libcloud/Makefile
+++ b/net/py-libcloud/Makefile
@@ -3,7 +3,7 @@
PORTNAME= libcloud
PORTVERSION= 0.17.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net python
MASTER_SITES= APACHE/${PORTNAME}
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/net/py-libcloud/files/patch-setup.py b/net/py-libcloud/files/patch-setup.py
new file mode 100644
index 000000000000..66fe556a2838
--- /dev/null
+++ b/net/py-libcloud/files/patch-setup.py
@@ -0,0 +1,29 @@
+--- setup.py.orig 2014-11-19 16:00:24 UTC
++++ setup.py
+@@ -47,7 +47,6 @@ DOC_TEST_MODULES = ['libcloud.compute.dr
+ SUPPORTED_VERSIONS = ['2.5', '2.6', '2.7', 'PyPy', '3.x']
+
+ TEST_REQUIREMENTS = [
+- 'backports.ssl_match_hostname',
+ 'mock'
+ ]
+
+@@ -222,10 +221,6 @@ class CoverageCommand(Command):
+
+ forbid_publish()
+
+-install_requires = ['backports.ssl_match_hostname']
+-if pre_python26:
+- install_requires.extend(['ssl', 'simplejson'])
+-
+ setup(
+ name='apache-libcloud',
+ version=read_version_string(),
+@@ -234,7 +229,6 @@ setup(
+ ' and documentation, please see http://libcloud.apache.org',
+ author='Apache Software Foundation',
+ author_email='dev@libcloud.apache.org',
+- install_requires=install_requires,
+ packages=get_packages('libcloud'),
+ package_dir={
+ 'libcloud': 'libcloud',