aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authoraz <az@FreeBSD.org>2013-09-05 15:29:05 +0800
committeraz <az@FreeBSD.org>2013-09-05 15:29:05 +0800
commita09da98df1b3a5bed3c993e9e75014c03e1790e0 (patch)
tree0265fe44e2e8b525ce586385590e09f52eff9e23 /net
parent6741a733d57a46465e151cd9258765bb5885a9a3 (diff)
downloadfreebsd-ports-gnome-a09da98df1b3a5bed3c993e9e75014c03e1790e0.tar.gz
freebsd-ports-gnome-a09da98df1b3a5bed3c993e9e75014c03e1790e0.tar.zst
freebsd-ports-gnome-a09da98df1b3a5bed3c993e9e75014c03e1790e0.zip
- convert to the new perl5 framework
Approved by: portmgr (bapt@, blanket)
Diffstat (limited to 'net')
-rw-r--r--net/p5-Net-ARP/Makefile3
-rw-r--r--net/p5-Net-Write/Makefile3
-rw-r--r--net/sendsms/Makefile2
-rw-r--r--net/x2goclient-cli/Makefile2
4 files changed, 6 insertions, 4 deletions
diff --git a/net/p5-Net-ARP/Makefile b/net/p5-Net-ARP/Makefile
index 966d98c246c5..9d20c9b3083c 100644
--- a/net/p5-Net-ARP/Makefile
+++ b/net/p5-Net-ARP/Makefile
@@ -17,7 +17,8 @@ COMMENT= Perl extension for creating ARP packets
BUILD_DEPENDS= p5-Net-Pcap>=0:${PORTSDIR}/net/p5-Net-Pcap
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
WRKSRC= ${WRKDIR}/${PORTNAME}
diff --git a/net/p5-Net-Write/Makefile b/net/p5-Net-Write/Makefile
index 86dcacce432b..da4511dc0c12 100644
--- a/net/p5-Net-Write/Makefile
+++ b/net/p5-Net-Write/Makefile
@@ -19,7 +19,8 @@ BUILD_DEPENDS= p5-Class-Gomor>=1.00:${PORTSDIR}/devel/p5-Class-Gomor \
p5-Net-Pcap>=0.14:${PORTSDIR}/net/p5-Net-Pcap
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Net::Write.3 \
Net::Write::Layer.3 \
diff --git a/net/sendsms/Makefile b/net/sendsms/Makefile
index 7dd5d7ca164b..e5435638bef6 100644
--- a/net/sendsms/Makefile
+++ b/net/sendsms/Makefile
@@ -22,7 +22,7 @@ CONFLICTS= gnokii-[0-9]* smstools-[0-9]*
NO_BUILD= yes
NO_WRKSUBDIR= yes
-USE_PERL5= yes
+USES= perl5
post-patch:
@${REINPLACE_CMD} -e "s,/usr/bin/perl,${PERL},g" ${WRKSRC}/${PORTNAME}
diff --git a/net/x2goclient-cli/Makefile b/net/x2goclient-cli/Makefile
index 26621bcbac88..031681110328 100644
--- a/net/x2goclient-cli/Makefile
+++ b/net/x2goclient-cli/Makefile
@@ -20,7 +20,7 @@ RUN_DEPENDS= p5-Proc-Simple>=0:${PORTSDIR}/devel/p5-Proc-Simple \
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE
-USE_PERL5= yes
+USES= perl5
PLIST_FILES= bin/x2goclient-cli
WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION:S,-1.2,,}
NO_BUILD= yes