aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2013-10-13 21:03:03 +0800
committermakc <makc@FreeBSD.org>2013-10-13 21:03:03 +0800
commita24b5a9439576d52b7a1e94d6c4dd3f0e5d8c13e (patch)
tree9d348bd41c93dc07e16d63761a277862fca2beec /net
parent59c0a46aa2540ee31e961d5f970ecb9f7804f01e (diff)
downloadfreebsd-ports-gnome-a24b5a9439576d52b7a1e94d6c4dd3f0e5d8c13e.tar.gz
freebsd-ports-gnome-a24b5a9439576d52b7a1e94d6c4dd3f0e5d8c13e.tar.zst
freebsd-ports-gnome-a24b5a9439576d52b7a1e94d6c4dd3f0e5d8c13e.zip
- Convert unmaintained ports to USES=qmake
- Add stage support - Convert LIB_DEPENDS to new syntax - Minor changes/fixes
Diffstat (limited to 'net')
-rw-r--r--net/x2goclient/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/net/x2goclient/Makefile b/net/x2goclient/Makefile
index 56a099e5b6ad..281b0803ab37 100644
--- a/net/x2goclient/Makefile
+++ b/net/x2goclient/Makefile
@@ -11,6 +11,8 @@ COMMENT= Qt client for the X2Go system
LICENSE= GPLv2
+# Avoid clash with libssh from base
+BUILD_DEPENDS= ${LOCALBASE}/lib/libssh.so:${PORTSDIR}/security/libssh
LIB_DEPENDS= libcups.so:${PORTSDIR}/print/cups-client \
libssh.so:${PORTSDIR}/security/libssh
RUN_DEPENDS= nxproxy:${PORTSDIR}/net/nxproxy \
@@ -19,10 +21,11 @@ RUN_DEPENDS= nxproxy:${PORTSDIR}/net/nxproxy \
OPTIONS_DEFINE= LDAP DOCS
OPTIONS_DEFAULT=LDAP
+USES= qmake
USE_XORG= xpm
USE_QT4= gui network svg \
linguist_build moc_build qmake_build rcc_build uic_build
-QMAKEFLAGS= QMAKE_LRELEASE="${QT_PREFIX}/bin/lrelease-qt4"
+QMAKE_ARGS= QMAKE_LRELEASE="${QT_PREFIX}/bin/lrelease-qt4"
INSTALLS_ICONS= yes
.include <bsd.port.options.mk>
@@ -30,9 +33,9 @@ INSTALLS_ICONS= yes
.if ${PORT_OPTIONS:MLDAP}
USE_OPENLDAP= yes
CFLAGS+= -DUSELDAP
-QMAKEFLAGS+= LIBS+="-lX11 -lXpm -lcups -lldap"
+QMAKE_ARGS+= LIBS+="-lX11 -lXpm -lcups -lldap"
.else
-QMAKEFLAGS+= LIBS+="-lX11 -lXpm -lcups"
+QMAKE_ARGS+= LIBS+="-lX11 -lXpm -lcups"
.endif
post-patch:
@@ -42,9 +45,6 @@ post-patch:
/<linux\/fs.h>/s|^|//| ; \
/#define USELDAP/s|^|//|'
-do-configure:
- @(cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ${QMAKE} ${QMAKEFLAGS})
-
pre-build:
@(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_FLAGS} \
${MAKEFILE} compiler_TSQM_make_all)