aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authormadpilot <madpilot@FreeBSD.org>2017-04-16 15:45:33 +0800
committermadpilot <madpilot@FreeBSD.org>2017-04-16 15:45:33 +0800
commita3ee54683ff63fe002b8ad34e21db054005112cd (patch)
treef52d2da8117e059d7bbd33c7df5ddb6ed2e475f4 /net
parentaab36617760979a9625a611b82e9940541e76e73 (diff)
downloadfreebsd-ports-gnome-a3ee54683ff63fe002b8ad34e21db054005112cd.tar.gz
freebsd-ports-gnome-a3ee54683ff63fe002b8ad34e21db054005112cd.tar.zst
freebsd-ports-gnome-a3ee54683ff63fe002b8ad34e21db054005112cd.zip
- Add patches to fix build with LibreSSL [1]
- Add dependencies and new SHEBANG_FILE to per stage-qa warnings - Stop istalling python script to avoid stage-qa error about wrong python shabang(adding a python dependency just for a contributed python script seems overkill) PR: 218599 [1] Submitted by: OlivierW <olivierw1+bugzilla-freebsd@hotmail.com> Obtained from: https://cvsweb.openbsd.org/cgi-bin/cvsweb/ports/telephony/asterisk/patches/ [1]
Diffstat (limited to 'net')
-rw-r--r--net/asterisk13/Makefile15
-rw-r--r--net/asterisk13/files/patch-contrib_Makefile15
-rw-r--r--net/asterisk13/files/patch-main_libasteriskssl.c20
-rw-r--r--net/asterisk13/files/patch-main_tcptls.c18
-rw-r--r--net/asterisk13/pkg-plist1
5 files changed, 64 insertions, 5 deletions
diff --git a/net/asterisk13/Makefile b/net/asterisk13/Makefile
index a230cf12e096..37b2d4158661 100644
--- a/net/asterisk13/Makefile
+++ b/net/asterisk13/Makefile
@@ -2,6 +2,7 @@
PORTNAME= asterisk
PORTVERSION= 13.15.0
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://downloads.asterisk.org/pub/telephony/%SUBDIR%/:DEFAULT,g729
MASTER_SITE_SUBDIR= asterisk/ \
@@ -171,6 +172,8 @@ PGSQL_USES= pgsql
PJSIP_CONFIGURE_WITH= pjproject
PJSIP_USES= pkgconfig
+PJSIP_LIB_DEPENDS= libspeex.so:audio/speex \
+ libspeexdsp.so:audio/speexdsp
PORTAUDIO_CONFIGURE_WITH= portaudio
PORTAUDIO_LIB_DEPENDS= libportaudio.so:audio/portaudio
@@ -179,13 +182,16 @@ RADIUS_CONFIGURE_WITH= radius
RADIUS_LIB_DEPENDS= libradiusclient-ng.so:net/radiusclient
SNMP_CONFIGURE_WITH= netsnmp
-SNMP_LIB_DEPENDS= libnetsnmp.so:net-mgmt/net-snmp
+SNMP_LIB_DEPENDS= libnetsnmp.so:net-mgmt/net-snmp \
+ libpkg.so:ports-mgmt/pkg
SPANDSP_CONFIGURE_WITH= spandsp
-SPANDSP_LIB_DEPENDS= libspandsp.so:comms/spandsp
+SPANDSP_LIB_DEPENDS= libspandsp.so:comms/spandsp \
+ libtiff.so:graphics/tiff
SPEEX_CONFIGURE_WITH= speex
-SPEEX_LIB_DEPENDS= libspeex.so:audio/speex
+SPEEX_LIB_DEPENDS= libspeex.so:audio/speex \
+ libspeexdsp.so:audio/speexdsp
SQLITE2_CONFIGURE_WITH= sqlite
SQLITE2_LIB_DEPENDS= libsqlite.so:databases/sqlite2
@@ -195,7 +201,8 @@ SRTP_CONFIGURE_WITH= srtp
SYSINFO_LIB_DEPENDS= libsysinfo.so:devel/libsysinfo
VORBIS_CONFIGURE_WITH= ogg
-VORBIS_LIB_DEPENDS= libvorbis.so:audio/libvorbis
+VORBIS_LIB_DEPENDS= libvorbis.so:audio/libvorbis \
+ libogg.so:audio/libogg
XMPP_CONFIGURE_WITH= iksemel
XMPP_LIB_DEPENDS= libiksemel.so:textproc/iksemel
diff --git a/net/asterisk13/files/patch-contrib_Makefile b/net/asterisk13/files/patch-contrib_Makefile
new file mode 100644
index 000000000000..1b2e67909406
--- /dev/null
+++ b/net/asterisk13/files/patch-contrib_Makefile
@@ -0,0 +1,15 @@
+--- contrib/Makefile.orig 2017-04-12 21:47:53 UTC
++++ contrib/Makefile
+@@ -24,10 +24,10 @@ install:
+ $(INSTALL) -m 755 scripts/ast_logescalator "$(DESTDIR)$(ASTDATADIR)/scripts/ast_logescalator"
+ $(INSTALL) -m 755 scripts/ast_loggrabber "$(DESTDIR)$(ASTDATADIR)/scripts/ast_loggrabber"
+ $(INSTALL) -m 755 scripts/ast_coredumper "$(DESTDIR)$(ASTDATADIR)/scripts/ast_coredumper"
+- $(INSTALL) -m 755 scripts/refcounter.py "$(DESTDIR)$(ASTDATADIR)/scripts/refcounter.py"
++# $(INSTALL) -m 755 scripts/refcounter.py "$(DESTDIR)$(ASTDATADIR)/scripts/refcounter.py"
+
+ uninstall:
+ -rm -f "$(DESTDIR)$(ASTDATADIR)/scripts/ast_logescalator"
+ -rm -f "$(DESTDIR)$(ASTDATADIR)/scripts/ast_loggrabber"
+ -rm -f "$(DESTDIR)$(ASTDATADIR)/scripts/ast_coredumper"
+- -rm -f "$(DESTDIR)$(ASTDATADIR)/scripts/refcounter.py"
++# -rm -f "$(DESTDIR)$(ASTDATADIR)/scripts/refcounter.py"
diff --git a/net/asterisk13/files/patch-main_libasteriskssl.c b/net/asterisk13/files/patch-main_libasteriskssl.c
new file mode 100644
index 000000000000..083eb6365a0a
--- /dev/null
+++ b/net/asterisk13/files/patch-main_libasteriskssl.c
@@ -0,0 +1,20 @@
+--- main/libasteriskssl.c.orig 2017-04-12 21:07:31 UTC
++++ main/libasteriskssl.c
+@@ -74,7 +74,7 @@ static void ssl_lock(int mode, int n, const char *file
+ }
+ }
+
+-#if !defined(OPENSSL_VERSION_NUMBER) || OPENSSL_VERSION_NUMBER < 0x10100000L
++#if !defined(OPENSSL_VERSION_NUMBER) || OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER)
+ int SSL_library_init(void)
+ {
+ #if defined(AST_DEVMODE)
+@@ -129,7 +129,7 @@ void ERR_free_strings(void)
+ int ast_ssl_init(void)
+ {
+ #if defined(HAVE_OPENSSL) && defined(OPENSSL_VERSION_NUMBER) && \
+- OPENSSL_VERSION_NUMBER < 0x10100000L
++ (OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER))
+ unsigned int i;
+ int (*real_SSL_library_init)(void);
+ void (*real_CRYPTO_set_id_callback)(unsigned long (*)(void));
diff --git a/net/asterisk13/files/patch-main_tcptls.c b/net/asterisk13/files/patch-main_tcptls.c
new file mode 100644
index 000000000000..77fe09c0c272
--- /dev/null
+++ b/net/asterisk13/files/patch-main_tcptls.c
@@ -0,0 +1,18 @@
+--- main/tcptls.c.orig 2017-04-12 21:06:16 UTC
++++ main/tcptls.c
+@@ -400,13 +400,13 @@ static int tcptls_stream_close(void *cookie)
+ SSL_get_error(stream->ssl, res));
+ }
+
+-#if defined(OPENSSL_VERSION_NUMBER) && OPENSSL_VERSION_NUMBER >= 0x10100000L
++#if defined(OPENSSL_VERSION_NUMBER) && OPENSSL_VERSION_NUMBER >= 0x10100000L && !defined(LIBRESSL_VERSION_NUMBER)
+ if (!SSL_is_server(stream->ssl)) {
+ #else
+ if (!stream->ssl->server) {
+ #endif
+ /* For client threads, ensure that the error stack is cleared */
+-#if !defined(OPENSSL_VERSION_NUMBER) || OPENSSL_VERSION_NUMBER < 0x10100000L
++#if !defined(OPENSSL_VERSION_NUMBER) || OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER)
+ #if defined(OPENSSL_VERSION_NUMBER) && OPENSSL_VERSION_NUMBER >= 0x10000000L
+ ERR_remove_thread_state(NULL);
+ #else
diff --git a/net/asterisk13/pkg-plist b/net/asterisk13/pkg-plist
index e926b90f8fe2..9089464704be 100644
--- a/net/asterisk13/pkg-plist
+++ b/net/asterisk13/pkg-plist
@@ -364,7 +364,6 @@ sbin/safe_asterisk
%%DATADIR%%/scripts/ast_coredumper
%%DATADIR%%/scripts/ast_logescalator
%%DATADIR%%/scripts/ast_loggrabber
-%%DATADIR%%/scripts/refcounter.py
%%DATADIR%%/static-http/appdocsxml.xslt
%%DATADIR%%/static-http/ajamdemo.html
%%DATADIR%%/static-http/astman.css