aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authormnag <mnag@FreeBSD.org>2005-10-22 07:34:09 +0800
committermnag <mnag@FreeBSD.org>2005-10-22 07:34:09 +0800
commita5c4d009b50613c6072df8ad3589bf071b7e158f (patch)
tree279fab41f7a662097fca37f7d67844a3d6104943 /net
parent86c69bbff442cddbe829526d7b41d7a72e5262c1 (diff)
downloadfreebsd-ports-gnome-a5c4d009b50613c6072df8ad3589bf071b7e158f.tar.gz
freebsd-ports-gnome-a5c4d009b50613c6072df8ad3589bf071b7e158f.tar.zst
freebsd-ports-gnome-a5c4d009b50613c6072df8ad3589bf071b7e158f.zip
Update to 0.5.a.20050918
PR: 87560 Submitted by: Denis Shaposhnikov <dsh@vlink.ru> (maintainer)
Diffstat (limited to 'net')
-rw-r--r--net/sulci/Makefile17
-rw-r--r--net/sulci/distinfo4
-rw-r--r--net/sulci/files/patch-doc-sulci-cmdlist.en.txt20
-rw-r--r--net/sulci/files/patch-doc-sulci-cmdlist.ru.txt21
-rw-r--r--net/sulci/files/patch-sulci-plugin_cerberus.ml20
-rw-r--r--net/sulci/files/patch-sulci-sulci.conf.example35
-rw-r--r--net/sulci/files/pkg-message.in (renamed from net/sulci/pkg-message)6
-rw-r--r--net/sulci/files/sulci.sh.in2
-rw-r--r--net/sulci/pkg-plist1
9 files changed, 87 insertions, 39 deletions
diff --git a/net/sulci/Makefile b/net/sulci/Makefile
index 49bdef53d2e8..f88b770fc422 100644
--- a/net/sulci/Makefile
+++ b/net/sulci/Makefile
@@ -6,10 +6,11 @@
#
PORTNAME= sulci
-PORTVERSION= 0.5.a.20050723
+PORTVERSION= 0.5.a.20050918
PORTEPOCH= 1
CATEGORIES= net
-MASTER_SITES= http://neva.vlink.ru/distfiles/
+MASTER_SITES= http://www.jabber.ru/files/sulci/
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/.a./-alpha-/}
MAINTAINER= dsh@vlink.ru
COMMENT= A Jabber bot
@@ -19,20 +20,22 @@ BUILD_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml \
${OCAML_SITELIBDIR}/ulex/ulexing.a:${PORTSDIR}/devel/ocaml-ulex \
ocamlfind:${PORTSDIR}/devel/ocaml-findlib \
${OCAML_SITELIBDIR}/netstring/netstring.a:${PORTSDIR}/www/ocaml-net \
+ ${OCAML_SITELIBDIR}/netclient/netclient.a:${PORTSDIR}/net/ocaml-netclient \
${OCAML_SITELIBDIR}/pcre/pcre.a:${PORTSDIR}/devel/ocaml-pcre
LIB_DEPENDS= sqlite.2:${PORTSDIR}/databases/sqlite2 \
pcre.0:${PORTSDIR}/devel/pcre-utf8
RUN_DEPENDS= ${OCAML_SITELIBDIR}/netstring/netstring.a:${PORTSDIR}/www/ocaml-net \
- ${OCAML_SITELIBDIR}/pcre/pcre.a:${PORTSDIR}/devel/ocaml-pcre \
mueller:${PORTSDIR}/russian/mueller-dic
-OCAML_SITELIBDIR= ${LOCALBASE}/lib/ocaml/site-lib
-
USE_BZIP2= yes
USE_GMAKE= yes
USE_RC_SUBR= ${PORTNAME}.sh
ALL_TARGET= subdirs
+PKGMESSAGE= ${WRKDIR}/pkg-message
+SUB_FILES= pkg-message
+
+OCAML_SITELIBDIR= ${LOCALBASE}/lib/ocaml/site-lib
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME}/${PORTNAME} ${PREFIX}/sbin
@@ -47,12 +50,12 @@ do-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
-. for i in COPYING ChangeLog
+. for i in COPYING
${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
. endfor
. for i in cmdlist.en.txt cmdlist.ru.txt
- ${INSTALL_DATA} ${WRKSRC}/doc/sulci/${i} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/docs/sulci/${i} ${DOCSDIR}
. endfor
.endif
diff --git a/net/sulci/distinfo b/net/sulci/distinfo
index f426372c985c..b7b8f3a0eb31 100644
--- a/net/sulci/distinfo
+++ b/net/sulci/distinfo
@@ -1,2 +1,2 @@
-MD5 (sulci-0.5.a.20050723.tar.bz2) = 5aec17e5dea265c25e0819d19bc96ad0
-SIZE (sulci-0.5.a.20050723.tar.bz2) = 156778
+MD5 (sulci-0.5-alpha-20050918.tar.bz2) = cfcb70be47815ebb54e9722469d5403d
+SIZE (sulci-0.5-alpha-20050918.tar.bz2) = 351692
diff --git a/net/sulci/files/patch-doc-sulci-cmdlist.en.txt b/net/sulci/files/patch-doc-sulci-cmdlist.en.txt
new file mode 100644
index 000000000000..8d37819075d0
--- /dev/null
+++ b/net/sulci/files/patch-doc-sulci-cmdlist.en.txt
@@ -0,0 +1,20 @@
+--- docs/sulci/cmdlist.en.txt.orig Thu Aug 4 17:10:21 2005
++++ docs/sulci/cmdlist.en.txt Fri Aug 5 12:17:58 2005
+@@ -157,3 +157,17 @@
+
+ Show wheater status from http://weather.noaa.gov/ for city by given
+ 4 symbols code.
++
++
++* tr list
++
++ Show list of language codes for translating.
++
++* tr lang text
++
++ Translate text via http://www.translate.ru/ as language code say.
++
++
++* vcard nick
++
++ Show nick's vCard, if any.
diff --git a/net/sulci/files/patch-doc-sulci-cmdlist.ru.txt b/net/sulci/files/patch-doc-sulci-cmdlist.ru.txt
new file mode 100644
index 000000000000..13c0e8025bd9
--- /dev/null
+++ b/net/sulci/files/patch-doc-sulci-cmdlist.ru.txt
@@ -0,0 +1,21 @@
+--- docs/sulci/cmdlist.ru.txt.orig Thu Aug 4 17:10:22 2005
++++ docs/sulci/cmdlist.ru.txt Fri Aug 5 12:17:27 2005
+@@ -169,3 +169,18 @@
+
+ Выводит прогноз погоды с http://weather.noaa.gov/ для города,
+ обозначенного 4-х буквенным кодом code.
++
++
++* tr list
++
++ Выводит список кодов языков, для перевода.
++
++* tr lang text
++
++ Переводит указанный текст через http://www.translate.ru/ в
++ соответствии с кодом языка.
++
++
++* vcard nick
++
++ Выводит vCard указанного ника, если есть.
diff --git a/net/sulci/files/patch-sulci-plugin_cerberus.ml b/net/sulci/files/patch-sulci-plugin_cerberus.ml
new file mode 100644
index 000000000000..dbd2dbfe1934
--- /dev/null
+++ b/net/sulci/files/patch-sulci-plugin_cerberus.ml
@@ -0,0 +1,20 @@
+--- sulci/plugin_cerberus.ml.orig Sun Sep 18 16:10:16 2005
++++ sulci/plugin_cerberus.ml Tue Sep 20 16:23:52 2005
+@@ -10,7 +10,7 @@
+ open Hooks
+
+ let regexp ca = 0x430 | 0x410 | 'a' | 'A'
+-let regexp cb = 0x431 | 0x411 | '6'
++let regexp cb = 0x431 | 0x411
+ let regexp cv = 0x432 | 0x412 | 'B'
+ let regexp cg = 0x433 | 0x413
+ let regexp cd = 0x434 | 0x414
+@@ -45,7 +45,7 @@
+
+ let regexp cyrillic = [0x410-0x44F 0x451 0x401 '0' '3' 'a''A' 'e' 'E' 'H'
+ 'o' 'O' 'c' 'C' 'k' 'K' 'T' 'x' 'X' 'y' 'Y' 'p'
+- 'P' '6' '0'] | "|/|" | "bl" | "bI"
++ 'P' '0'] | "|/|" | "bl" | "bI"
+
+ let regexp ci_ie_io = ci | cie | cio
+ let regexp cie_io = cie | cio
diff --git a/net/sulci/files/patch-sulci-sulci.conf.example b/net/sulci/files/patch-sulci-sulci.conf.example
index 89fa0f9fa7d1..48aa0b4d8b40 100644
--- a/net/sulci/files/patch-sulci-sulci.conf.example
+++ b/net/sulci/files/patch-sulci-sulci.conf.example
@@ -1,5 +1,5 @@
---- sulci/sulci.conf.example.orig Mon Jul 25 12:52:33 2005
-+++ sulci/sulci.conf.example Mon Jul 25 14:34:06 2005
+--- sulci/sulci.conf.example.orig Sun Sep 18 18:32:13 2005
++++ sulci/sulci.conf.example Tue Sep 20 16:02:07 2005
@@ -1,6 +1,6 @@
<sulci>
<jabber>
@@ -8,9 +8,9 @@
<port>5222</port>
<user>sxxxx</user>
<resource>Ocaml</resource>
-@@ -14,20 +14,22 @@
- -->
- <reconnect interval='10' count='3' />
+@@ -15,13 +15,13 @@
+
+ <lifelog>./sulci_life.log</lifelog>
- <lang dir="./lang" default="ru"/>
+ <lang dir="/usr/local/share/sulci/lang" default="ru"/>
@@ -25,30 +25,15 @@
<chatlogs>./chatlogs</chatlogs>
</muc>
-
-+ <!--
- <debug>
- <logfile>log.log</logfile>
- </debug>
-+ -->
-
- <plugins>
-
-@@ -37,7 +39,7 @@
+@@ -40,9 +40,9 @@
<vocabulary name="vocabulary"/>
- <mueller file="/path/to/Mueller24.koi" hashext=".hash" />
+ <mueller file="/usr/local/share/mueller-dic/Mueller7accentGPL.koi" hashext=".h" />
- <markov dir="./markov_db" msg_limit="20" />
-
-@@ -59,7 +61,7 @@
- -->
-
- <cerberus kick="true">
-- <notify jid="jid@jabber.server"/>
-+ <notify jid="admin@localhost"/>
- </cerberus>
+- <markov dir="./markov_db" msg_limit="20" />
++ <markov dir="./markov_db/" msg_limit="20" />
- </plugins>
+ <!-- it used on http://ejabberd.jabber.ru/ to display total registered users
+ and users online using ejabberd -->
diff --git a/net/sulci/pkg-message b/net/sulci/files/pkg-message.in
index 1adb1ef4ad9e..34422d382941 100644
--- a/net/sulci/pkg-message
+++ b/net/sulci/files/pkg-message.in
@@ -2,11 +2,11 @@ You have to do something like bellow before starting up the bot.
# mkdir home/of/the/sulci/the/bot
# cd home/of/the/sulci/the/bot
- # cp ${PREFIX}/share/examples/sulci/sulci.conf.example sulci.conf
+ # cp %%PREFIX%%/share/examples/sulci/sulci.conf.example sulci.conf
# vi sulci.conf
- # ln -s ${PREFIX}/share/sulci/tlds.db .
+ # ln -s %%PREFIX%%/share/sulci/tlds.db .
- # echo sulci_enable=\"YES"\ >> /etc/rc.conf
+ # echo sulci_enable=\"YES\" >> /etc/rc.conf
# echo sulci_chdir=\"home/of/the/sulci/the/bot\" >> /etc/rc.conf
diff --git a/net/sulci/files/sulci.sh.in b/net/sulci/files/sulci.sh.in
index 95e1a144f903..549e2173acc9 100644
--- a/net/sulci/files/sulci.sh.in
+++ b/net/sulci/files/sulci.sh.in
@@ -21,7 +21,7 @@ sulci_precmd=":"
name="sulci"
rcvar=`set_rcvar`
command="%%PREFIX%%/sbin/sulci"
-command_args="> /dev/null 2>&1 &"
+command_args="&"
load_rc_config $name
diff --git a/net/sulci/pkg-plist b/net/sulci/pkg-plist
index b4f860e3c2f6..1fde11e85fe6 100644
--- a/net/sulci/pkg-plist
+++ b/net/sulci/pkg-plist
@@ -13,7 +13,6 @@ sbin/sulci
%%DATADIR%%/lang/ru_time.ml
%%EXAMPLESDIR%%/sulci.conf.example
%%PORTDOCS%%%%DOCSDIR%%/COPYING
-%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
%%PORTDOCS%%%%DOCSDIR%%/cmdlist.en.txt
%%PORTDOCS%%%%DOCSDIR%%/cmdlist.ru.txt
%%PORTDOCS%%@dirrm %%DOCSDIR%%