aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2011-03-03 22:36:57 +0800
committerclsung <clsung@FreeBSD.org>2011-03-03 22:36:57 +0800
commita5f620ffd8a0e0bd703c8c66b334e4b1a63296b0 (patch)
tree3e262f6540e156e9ad5c0960c54ad533db6998e0 /net
parentcad80fdcdad1fc9e7d0ac4b9d6bd987244d0c30b (diff)
downloadfreebsd-ports-gnome-a5f620ffd8a0e0bd703c8c66b334e4b1a63296b0.tar.gz
freebsd-ports-gnome-a5f620ffd8a0e0bd703c8c66b334e4b1a63296b0.tar.zst
freebsd-ports-gnome-a5f620ffd8a0e0bd703c8c66b334e4b1a63296b0.zip
Rubygem-simple_oauth is a RubyGem for simply builds and
verifies OAuth headers. WWW: http://github.com/laserlemon/simple_oauth
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/rubygem-simple_oauth/Makefile22
-rw-r--r--net/rubygem-simple_oauth/distinfo2
-rw-r--r--net/rubygem-simple_oauth/pkg-descr4
4 files changed, 29 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 11c6272818d9..1074ee6c8a0d 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -974,6 +974,7 @@
SUBDIR += rubygem-righthttpconnection
SUBDIR += rubygem-rightslicehost
SUBDIR += rubygem-rubytter
+ SUBDIR += rubygem-simple_oauth
SUBDIR += rubygem-tweetstream
SUBDIR += rubygem-twitter
SUBDIR += rubygem-twitter-stream
diff --git a/net/rubygem-simple_oauth/Makefile b/net/rubygem-simple_oauth/Makefile
new file mode 100644
index 000000000000..29fdde03ff6a
--- /dev/null
+++ b/net/rubygem-simple_oauth/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: simple_oauth
+# Date created: Mar 03, 2011
+# Whom: Cheng-Lung Sung <clsung@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= simple_oauth
+PORTVERSION= 0.1.2
+CATEGORIES= net rubygems
+MASTER_SITES= RG
+
+MAINTAINER= clsung@FreeBSD.org
+COMMENT= Rubygem for Simply builds and verifies OAuth headers
+
+RUN_DEPENDS= rubygem-mocha>=0:${PORTSDIR}/devel/rubygem-mocha
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/net/rubygem-simple_oauth/distinfo b/net/rubygem-simple_oauth/distinfo
new file mode 100644
index 000000000000..9fefbf3d60f8
--- /dev/null
+++ b/net/rubygem-simple_oauth/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/simple_oauth-0.1.2.gem) = 6eecce2e23f32a0f83a6e56528c4609fdc5cc50a18379bf961a059582f2598da
+SIZE (rubygem/simple_oauth-0.1.2.gem) = 11264
diff --git a/net/rubygem-simple_oauth/pkg-descr b/net/rubygem-simple_oauth/pkg-descr
new file mode 100644
index 000000000000..ba1f327a7272
--- /dev/null
+++ b/net/rubygem-simple_oauth/pkg-descr
@@ -0,0 +1,4 @@
+Rubygem-simple_oauth is a RubyGem for simply builds and
+verifies OAuth headers.
+
+WWW: http://github.com/laserlemon/simple_oauth