aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorTorsten Zuehlsdorff <tz@FreeBSD.org>2016-07-27 23:43:11 +0800
committerTorsten Zuehlsdorff <tz@FreeBSD.org>2016-07-27 23:43:11 +0800
commita83cd5bf9217dc109b33c57916756e222663548d (patch)
treed985f847a54238cb9d429e74ef061d0c435c6602 /net
parent8fd86c68b009d78a0081af326bef03851ba6af00 (diff)
downloadfreebsd-ports-gnome-a83cd5bf9217dc109b33c57916756e222663548d.tar.gz
freebsd-ports-gnome-a83cd5bf9217dc109b33c57916756e222663548d.tar.zst
freebsd-ports-gnome-a83cd5bf9217dc109b33c57916756e222663548d.zip
New port: net/rubygem-fog-azure
This library can be used as a module for `fog` or as standalone provider to use the Azure cloud services in applications. WWW: http://github.com/fog/fog-azure Approved by: swills (mentor)
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/rubygem-fog-azure/Makefile24
-rw-r--r--net/rubygem-fog-azure/distinfo3
-rw-r--r--net/rubygem-fog-azure/pkg-descr4
4 files changed, 32 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index b0ee9ff67825..42bbdfca84ee 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -1114,6 +1114,7 @@
SUBDIR += rubygem-fog-aliyun
SUBDIR += rubygem-fog-atmos
SUBDIR += rubygem-fog-aws
+ SUBDIR += rubygem-fog-azure
SUBDIR += rubygem-fog-brightbox
SUBDIR += rubygem-fog-cloudatcost
SUBDIR += rubygem-fog-dynect
diff --git a/net/rubygem-fog-azure/Makefile b/net/rubygem-fog-azure/Makefile
new file mode 100644
index 000000000000..b1cc3dff4bd3
--- /dev/null
+++ b/net/rubygem-fog-azure/Makefile
@@ -0,0 +1,24 @@
+# Created by: Torsten Zuehlsdorff <tz@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= fog-azure
+PORTVERSION= 0.0.2
+CATEGORIES= net rubygems
+MASTER_SITES= RG
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= Module for the 'fog' gem to support Microsoft Azure
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.md
+
+RUN_DEPENDS= rubygem-azure>=0.6:net/rubygem-azure \
+ rubygem-fog-core>=1.38:devel/rubygem-fog-core \
+ rubygem-fog-json>=1.0:devel/rubygem-fog-json \
+ rubygem-fog-xml>=0.1:textproc/rubygem-fog-xml
+
+NO_ARCH= yes
+USE_RUBY= yes
+USES= gem
+
+.include <bsd.port.mk>
diff --git a/net/rubygem-fog-azure/distinfo b/net/rubygem-fog-azure/distinfo
new file mode 100644
index 000000000000..344dce0ba65e
--- /dev/null
+++ b/net/rubygem-fog-azure/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1469629146
+SHA256 (rubygem/fog-azure-0.0.2.gem) = 94b9bc361f7dfecf0066c884dab78c0da577ff331a6ab55d6ee9fca082fdafad
+SIZE (rubygem/fog-azure-0.0.2.gem) = 15872
diff --git a/net/rubygem-fog-azure/pkg-descr b/net/rubygem-fog-azure/pkg-descr
new file mode 100644
index 000000000000..43f888abe689
--- /dev/null
+++ b/net/rubygem-fog-azure/pkg-descr
@@ -0,0 +1,4 @@
+This library can be used as a module for `fog` or as standalone provider to use
+the Azure cloud services in applications.
+
+WWW: http://github.com/fog/fog-azure