aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2006-03-16 04:14:52 +0800
committeredwin <edwin@FreeBSD.org>2006-03-16 04:14:52 +0800
commitaa03c050cc6d3982772c238903b7ba2ef4bd2d01 (patch)
tree4ab856b719b2364bd7226c815a302ed0c36680be /net
parent11eb4e8bc3a424bcf17d5cce0f559da2df26e3cb (diff)
downloadfreebsd-ports-gnome-aa03c050cc6d3982772c238903b7ba2ef4bd2d01.tar.gz
freebsd-ports-gnome-aa03c050cc6d3982772c238903b7ba2ef4bd2d01.tar.zst
freebsd-ports-gnome-aa03c050cc6d3982772c238903b7ba2ef4bd2d01.zip
New port: net/penguintv
PenguinTV is not just another RSS feed reader. It is designed from the ground up to work seamlessly with podcasts and video blogs, allowing you to easily enjoy the audio, music, and video published around the web in RSS format. WWW: http://penguintv.sourceforge.net/ Author: Owen Williams <ywwg@usa.net>
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/penguintv/Makefile34
-rw-r--r--net/penguintv/distinfo3
-rw-r--r--net/penguintv/pkg-descr22
-rw-r--r--net/penguintv/pkg-message2
-rw-r--r--net/penguintv/pkg-plist101
6 files changed, 163 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index f8cc43e52d7d..fcb5414d9469 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -501,6 +501,7 @@
SUBDIR += pecl-radius
SUBDIR += pecl-yaz
SUBDIR += pen
+ SUBDIR += penguintv
SUBDIR += perldap
SUBDIR += pfflowd
SUBDIR += pfinger
diff --git a/net/penguintv/Makefile b/net/penguintv/Makefile
new file mode 100644
index 000000000000..d57994c78954
--- /dev/null
+++ b/net/penguintv/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: PenguinTV
+# Date created: 14 March 2006
+# Whom: Edwin Groothuis <edwin@mavetju.org>
+#
+# $FreeBSD$
+
+PORTNAME= PenguinTV
+PORTVERSION= 1.05
+CATEGORIES= net audio multimedia
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= penguintv
+
+MAINTAINER= edwin@mavetju.org
+COMMENT= Graphical RSS feed reader with incorperated playback functions
+
+BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/pysqlite2/_sqlite.so:${PORTSDIR}/databases/py-pysqlite21 \
+ ${PYTHON_SITELIBDIR}/pycurl.so:${PORTSDIR}/ftp/py-curl
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_GNOME= pygnomeextras pygnome2
+USE_PYTHON= yes
+
+CONFLICTS= PenguinTV-devel-1.*
+
+do-build:
+ cd ${WRKSRC} && ${PYTHON_CMD} setup.py build
+
+do-install:
+ cd ${WRKSRC} && ${PYTHON_CMD} setup.py install
+
+post-install:
+ ${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/net/penguintv/distinfo b/net/penguintv/distinfo
new file mode 100644
index 000000000000..51bf9c5e4d7c
--- /dev/null
+++ b/net/penguintv/distinfo
@@ -0,0 +1,3 @@
+MD5 (PenguinTV-1.05.tar.gz) = 51c69065821d42e609ba3e400ebbca9d
+SHA256 (PenguinTV-1.05.tar.gz) = e963cb6bfa89809309afbdb07343933498052b420e890b860d164a46bd684fef
+SIZE (PenguinTV-1.05.tar.gz) = 138196
diff --git a/net/penguintv/pkg-descr b/net/penguintv/pkg-descr
new file mode 100644
index 000000000000..a3dbcda7fe92
--- /dev/null
+++ b/net/penguintv/pkg-descr
@@ -0,0 +1,22 @@
+PenguinTV is not just another RSS feed reader. It is designed from
+the ground up to work seamlessly with podcasts and video blogs,
+allowing you to easily enjoy the audio, music, and video published
+around the web in RSS format.
+
+Until now, the only solutions for listening to podcasts on Linux
+have been clunky apps and unreliable bash scripts. Many solutions
+require the user to browse file directories named by date to find
+media files. With the large amount of information in podcasts and
+videos, a user needs help to keep track of everything.
+
+PenguinTV eliminates all of these problems with a light-weight but
+powerful interface that shows you what you need to know, and hides
+what you don't. You can immediately see what you've watched, what's
+available to view, and which media are downloading. You don't have
+to worry about where files are stored, what their names are, or
+what format they are in. Rather than try to reinvent the wheel by
+coding its own media player, PenguinTV launches the media player
+of your choice to view your downloads.
+
+WWW: http://penguintv.sourceforge.net/
+Author: Owen Williams <ywwg@usa.net>
diff --git a/net/penguintv/pkg-message b/net/penguintv/pkg-message
new file mode 100644
index 000000000000..84ccb550311d
--- /dev/null
+++ b/net/penguintv/pkg-message
@@ -0,0 +1,2 @@
+When you run PenguinTV for the first time, you have to drag the
+panes of the main window down before you can see the feeds.
diff --git a/net/penguintv/pkg-plist b/net/penguintv/pkg-plist
new file mode 100644
index 000000000000..ccf0d72bca1a
--- /dev/null
+++ b/net/penguintv/pkg-plist
@@ -0,0 +1,101 @@
+%%PYTHON_SITELIBDIR%%/penguintv/utils.pyc
+%%PYTHON_SITELIBDIR%%/penguintv/utils.py
+%%PYTHON_SITELIBDIR%%/penguintv/timeoutsocket.pyc
+%%PYTHON_SITELIBDIR%%/penguintv/timeoutsocket.py
+%%PYTHON_SITELIBDIR%%/penguintv/subProcess.pyc
+%%PYTHON_SITELIBDIR%%/penguintv/subProcess.py
+%%PYTHON_SITELIBDIR%%/penguintv/ptvbittorrent/zurllib.pyc
+%%PYTHON_SITELIBDIR%%/penguintv/ptvbittorrent/zurllib.py
+%%PYTHON_SITELIBDIR%%/penguintv/ptvbittorrent/track.pyc
+%%PYTHON_SITELIBDIR%%/penguintv/ptvbittorrent/track.py
+%%PYTHON_SITELIBDIR%%/penguintv/ptvbittorrent/testtest.pyc
+%%PYTHON_SITELIBDIR%%/penguintv/ptvbittorrent/testtest.py
+%%PYTHON_SITELIBDIR%%/penguintv/ptvbittorrent/spewout.pyc
+%%PYTHON_SITELIBDIR%%/penguintv/ptvbittorrent/spewout.py
+%%PYTHON_SITELIBDIR%%/penguintv/ptvbittorrent/selectpoll.pyc
+%%PYTHON_SITELIBDIR%%/penguintv/ptvbittorrent/selectpoll.py
+%%PYTHON_SITELIBDIR%%/penguintv/ptvbittorrent/parseargs.pyc
+%%PYTHON_SITELIBDIR%%/penguintv/ptvbittorrent/parseargs.py
+%%PYTHON_SITELIBDIR%%/penguintv/ptvbittorrent/fakeopen.pyc
+%%PYTHON_SITELIBDIR%%/penguintv/ptvbittorrent/fakeopen.py
+%%PYTHON_SITELIBDIR%%/penguintv/ptvbittorrent/download.pyc
+%%PYTHON_SITELIBDIR%%/penguintv/ptvbittorrent/download.py
+%%PYTHON_SITELIBDIR%%/penguintv/ptvbittorrent/btmakemetafile.pyc
+%%PYTHON_SITELIBDIR%%/penguintv/ptvbittorrent/btmakemetafile.py
+%%PYTHON_SITELIBDIR%%/penguintv/ptvbittorrent/btformats.pyc
+%%PYTHON_SITELIBDIR%%/penguintv/ptvbittorrent/btformats.py
+%%PYTHON_SITELIBDIR%%/penguintv/ptvbittorrent/btcompletedir.pyc
+%%PYTHON_SITELIBDIR%%/penguintv/ptvbittorrent/btcompletedir.py
+%%PYTHON_SITELIBDIR%%/penguintv/ptvbittorrent/bitfield.pyc
+%%PYTHON_SITELIBDIR%%/penguintv/ptvbittorrent/bitfield.py
+%%PYTHON_SITELIBDIR%%/penguintv/ptvbittorrent/bencode.pyc
+%%PYTHON_SITELIBDIR%%/penguintv/ptvbittorrent/bencode.py
+%%PYTHON_SITELIBDIR%%/penguintv/ptvbittorrent/__init__.pyc
+%%PYTHON_SITELIBDIR%%/penguintv/ptvbittorrent/__init__.py
+%%PYTHON_SITELIBDIR%%/penguintv/ptvbittorrent/Uploader.pyc
+%%PYTHON_SITELIBDIR%%/penguintv/ptvbittorrent/Uploader.py
+%%PYTHON_SITELIBDIR%%/penguintv/ptvbittorrent/StorageWrapper.pyc
+%%PYTHON_SITELIBDIR%%/penguintv/ptvbittorrent/StorageWrapper.py
+%%PYTHON_SITELIBDIR%%/penguintv/ptvbittorrent/Storage.pyc
+%%PYTHON_SITELIBDIR%%/penguintv/ptvbittorrent/Storage.py
+%%PYTHON_SITELIBDIR%%/penguintv/ptvbittorrent/Rerequester.pyc
+%%PYTHON_SITELIBDIR%%/penguintv/ptvbittorrent/Rerequester.py
+%%PYTHON_SITELIBDIR%%/penguintv/ptvbittorrent/RawServer.pyc
+%%PYTHON_SITELIBDIR%%/penguintv/ptvbittorrent/RawServer.py
+%%PYTHON_SITELIBDIR%%/penguintv/ptvbittorrent/RateMeasure.pyc
+%%PYTHON_SITELIBDIR%%/penguintv/ptvbittorrent/RateMeasure.py
+%%PYTHON_SITELIBDIR%%/penguintv/ptvbittorrent/PiecePicker.pyc
+%%PYTHON_SITELIBDIR%%/penguintv/ptvbittorrent/PiecePicker.py
+%%PYTHON_SITELIBDIR%%/penguintv/ptvbittorrent/NatCheck.pyc
+%%PYTHON_SITELIBDIR%%/penguintv/ptvbittorrent/NatCheck.py
+%%PYTHON_SITELIBDIR%%/penguintv/ptvbittorrent/HTTPHandler.pyc
+%%PYTHON_SITELIBDIR%%/penguintv/ptvbittorrent/HTTPHandler.py
+%%PYTHON_SITELIBDIR%%/penguintv/ptvbittorrent/Encrypter.pyc
+%%PYTHON_SITELIBDIR%%/penguintv/ptvbittorrent/Encrypter.py
+%%PYTHON_SITELIBDIR%%/penguintv/ptvbittorrent/DownloaderFeedback.pyc
+%%PYTHON_SITELIBDIR%%/penguintv/ptvbittorrent/DownloaderFeedback.py
+%%PYTHON_SITELIBDIR%%/penguintv/ptvbittorrent/Downloader.pyc
+%%PYTHON_SITELIBDIR%%/penguintv/ptvbittorrent/Downloader.py
+%%PYTHON_SITELIBDIR%%/penguintv/ptvbittorrent/CurrentRateMeasure.pyc
+%%PYTHON_SITELIBDIR%%/penguintv/ptvbittorrent/CurrentRateMeasure.py
+%%PYTHON_SITELIBDIR%%/penguintv/ptvbittorrent/Connecter.pyc
+%%PYTHON_SITELIBDIR%%/penguintv/ptvbittorrent/Connecter.py
+%%PYTHON_SITELIBDIR%%/penguintv/ptvbittorrent/Choker.pyc
+%%PYTHON_SITELIBDIR%%/penguintv/ptvbittorrent/Choker.py
+@dirrm %%PYTHON_SITELIBDIR%%/penguintv/ptvbittorrent
+%%PYTHON_SITELIBDIR%%/penguintv/ptvDB.pyc
+%%PYTHON_SITELIBDIR%%/penguintv/ptvDB.py
+%%PYTHON_SITELIBDIR%%/penguintv/penguintv.pyc
+%%PYTHON_SITELIBDIR%%/penguintv/penguintv.py
+%%PYTHON_SITELIBDIR%%/penguintv/feedparser.pyc
+%%PYTHON_SITELIBDIR%%/penguintv/feedparser.py
+%%PYTHON_SITELIBDIR%%/penguintv/__init__.pyc
+%%PYTHON_SITELIBDIR%%/penguintv/__init__.py
+%%PYTHON_SITELIBDIR%%/penguintv/UpdateTasksManager.pyc
+%%PYTHON_SITELIBDIR%%/penguintv/UpdateTasksManager.py
+%%PYTHON_SITELIBDIR%%/penguintv/ThreadPool.pyc
+%%PYTHON_SITELIBDIR%%/penguintv/ThreadPool.py
+%%PYTHON_SITELIBDIR%%/penguintv/SimpleImageCache.pyc
+%%PYTHON_SITELIBDIR%%/penguintv/SimpleImageCache.py
+%%PYTHON_SITELIBDIR%%/penguintv/RenameFeedDialog.pyc
+%%PYTHON_SITELIBDIR%%/penguintv/RenameFeedDialog.py
+%%PYTHON_SITELIBDIR%%/penguintv/PreferencesDialog.pyc
+%%PYTHON_SITELIBDIR%%/penguintv/PreferencesDialog.py
+%%PYTHON_SITELIBDIR%%/penguintv/Player.pyc
+%%PYTHON_SITELIBDIR%%/penguintv/Player.py
+%%PYTHON_SITELIBDIR%%/penguintv/OPML.pyc
+%%PYTHON_SITELIBDIR%%/penguintv/OPML.py
+%%PYTHON_SITELIBDIR%%/penguintv/MediaManager.pyc
+%%PYTHON_SITELIBDIR%%/penguintv/MediaManager.py
+%%PYTHON_SITELIBDIR%%/penguintv/BTDownloader.pyc
+%%PYTHON_SITELIBDIR%%/penguintv/BTDownloader.py
+%%PYTHON_SITELIBDIR%%/penguintv/AddFeedDialog.pyc
+%%PYTHON_SITELIBDIR%%/penguintv/AddFeedDialog.py
+@dirrm %%PYTHON_SITELIBDIR%%/penguintv
+bin/PenguinTV
+share/penguintv/penguintv.glade
+share/penguintv/defaultsubs.opml
+share/penguintv/penguintvicon.png
+share/pixmaps/penguintvicon.png
+share/applications/penguintv.desktop
+@dirrm share/penguintv