aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authornaddy <naddy@FreeBSD.org>2009-09-18 23:24:01 +0800
committernaddy <naddy@FreeBSD.org>2009-09-18 23:24:01 +0800
commitac1c0f07020096827b01610dc69d284186363f74 (patch)
treed6049f57b040d67b2370f0835f49bcb7ce956f1f /net
parentaa515bcac56ca1a0e028a2714b1d48a82e85addd (diff)
downloadfreebsd-ports-gnome-ac1c0f07020096827b01610dc69d284186363f74.tar.gz
freebsd-ports-gnome-ac1c0f07020096827b01610dc69d284186363f74.tar.zst
freebsd-ports-gnome-ac1c0f07020096827b01610dc69d284186363f74.zip
convert to USERS/GROUPS
Feature safe: yes
Diffstat (limited to 'net')
-rw-r--r--net/openntpd/Makefile5
-rw-r--r--net/openntpd/pkg-install35
2 files changed, 4 insertions, 36 deletions
diff --git a/net/openntpd/Makefile b/net/openntpd/Makefile
index 87550f78fe39..5c6f2978eb90 100644
--- a/net/openntpd/Makefile
+++ b/net/openntpd/Makefile
@@ -7,6 +7,7 @@
PORTNAME= openntpd
PORTVERSION= 4.4
+PORTREVISION= 1
PORTEPOCH= 2
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_OPENBSD}
@@ -16,6 +17,9 @@ EXTRACT_SUFX= .tgz
MAINTAINER= naddy@FreeBSD.org
COMMENT= OpenBSD's Network Time Protocol daemon
+USERS= _ntp
+GROUPS= _ntp
+
USE_RC_SUBR= openntpd
WRKSRC= ${WRKDIR}/ntpd
@@ -41,7 +45,6 @@ pre-build:
${WRKSRC}/ntpd.h ${WRKSRC}/ntpd.conf.5 ${WRKSRC}/ntpd.8
do-install:
- @PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
${INSTALL_PROGRAM} ${WRKSRC}/ntpd ${PREFIX}/sbin
${INSTALL_MAN} ${WRKSRC}/ntpd.conf.5 ${PREFIX}/man/man5
${INSTALL_MAN} ${WRKSRC}/ntpd.8 ${PREFIX}/man/man8
diff --git a/net/openntpd/pkg-install b/net/openntpd/pkg-install
deleted file mode 100644
index 62ded74d3b34..000000000000
--- a/net/openntpd/pkg-install
+++ /dev/null
@@ -1,35 +0,0 @@
-#!/bin/sh
-# $FreeBSD$
-#
-
-if [ "$2" != "PRE-INSTALL" ]; then
- exit 0
-fi
-
-USER=_ntp
-GROUP=${USER}
-UID=123
-GID=${UID}
-
-if ! pw groupshow "${GROUP}" 2>/dev/null 1>&2; then
- if pw groupadd ${GROUP} -g ${GID}; then
- echo "Added group \"${GROUP}\"."
- else
- echo "Adding group \"${GROUP}\" failed..."
- exit 1
- fi
-fi
-
-if ! pw usershow "${USER}" 2>/dev/null 1>&2; then
- if pw useradd ${USER} -u ${UID} -g ${GROUP} -h - \
- -s "/sbin/nologin" -d "/var/empty" \
- -c "NTP daemon"; \
- then
- echo "Added user \"${USER}\"."
- else
- echo "Adding user \"${USER}\" failed..."
- exit 1
- fi
-fi
-
-exit 0