aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authoreadler <eadler@FreeBSD.org>2013-06-02 07:28:05 +0800
committereadler <eadler@FreeBSD.org>2013-06-02 07:28:05 +0800
commitaccd46c219fd952375272150d06a91e43ec82102 (patch)
tree2951d1638b15b6fa17bafcc3594971288c013c0d /net
parentbb2507ee9768f7dbf5718c5e592ffd6fc3c1d831 (diff)
downloadfreebsd-ports-gnome-accd46c219fd952375272150d06a91e43ec82102.tar.gz
freebsd-ports-gnome-accd46c219fd952375272150d06a91e43ec82102.tar.zst
freebsd-ports-gnome-accd46c219fd952375272150d06a91e43ec82102.zip
- Convert to OptionsNG
- Reset maintainer due to lack of input. - Clean up other constructs while here
Diffstat (limited to 'net')
-rw-r--r--net/xorp/Makefile42
1 files changed, 16 insertions, 26 deletions
diff --git a/net/xorp/Makefile b/net/xorp/Makefile
index 05728cfc89df..0f2d1be62806 100644
--- a/net/xorp/Makefile
+++ b/net/xorp/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: xorp
-# Date created: 22nd September 2006
-# Whom: Bruce M Simpson <bms@FreeBSD.org>
-#
+# Created by: Bruce M Simpson <bms@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= xorp
PORTVERSION= 1.6
@@ -14,17 +10,13 @@ MASTER_SITES= http://www.xorp.org/releases/${PORTVERSION}/ \
http://www5.xorp.org/releases/${PORTVERSION}/ \
http://www3.xorp.org/releases/${PORTVERSION}/
-MAINTAINER= acc@hexadecagram.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= The eXtensible Open Router Platform
-OPTIONS= \
- ADVMCAST "Build with Advanced Multicast API" On \
- IPV6 "Build with IPv6 support" On \
- SNMP "Build with SNMP MIB support" Off \
- OPTIMIZATION "Build with optimization" On \
- CHECK "Build with regression test dependencies " Off \
- DEBUGGING "Enable debugging" Off \
- PROFILING "Enable profiling" Off
+OPTIONS_DEFINE= ADVMCAST IPV6 SNMP OPTIMIZED_CFLAGS TEST DEBUG PROFILE
+OPTIONS_DEFAULT= ADVMCAST IPV6 SNMP OPTIMIZED_CFLAGS TEST PROFILE
+
+ADVMCAST_DESC= Build with Advanced Multicast API
USE_GMAKE= yes
USE_OPENSSL= yes
@@ -34,7 +26,7 @@ CONFIGURE_ARGS= --prefix=${PREFIX}/${PORTNAME} \
--with-comment='FreeBSD port: ${PKGNAME}' \
--with-openssl=${OPENSSLBASE}
-CXXFLAGS="-Wno-uninitialized"
+CXXFLAGS+= -Wno-uninitialized
NOMAN= defined
XORP_GROUP= xorp
@@ -42,17 +34,17 @@ USE_RC_SUBR= xorp
.include <bsd.port.options.mk>
-.if defined(WITH_ADVMCAST)
+.if ${PORT_OPTIONS:MADVMCAST}
CONFIGURE_ARGS+= --enable-advanced-mcast-api
.endif
-.if defined(WITH_IPV6)
+.if ${PORT_OPTIONS:MIPV6}
CONFIGURE_ARGS+= --enable-ipv6
.else
CONFIGURE_ARGS+= --disable-ipv6
.endif
-.if defined(WITH_SNMP)
+.if ${PORT_OPTIONS:MSNMP}
BUILD_DEPENDS+= ${LOCALBASE}/sbin/snmpd:${PORTSDIR}/net-mgmt/net-snmp
CONFIGURE_ARGS+= --with-snmp \
--with-path-to-snmpd=${LOCALBASE}/sbin \
@@ -64,28 +56,26 @@ USE_LDCONFIG= ${PREFIX}/mibs
PLIST_SUB+= XORP_SNMP="@comment "
.endif
-.if defined(WITH_OPTIMIZATION)
+.if ${PORT_OPTIONS:MOPTIMIZED_CFLAGS}
CONFIGURE_ARGS+= --enable-optimize --disable-debug
.endif
-# Bash and Python are only required if running the regression tests.
-.if defined(WITH_CHECK)
+.if ${PORT_OPTIONS:MTEST}
BUILD_DEPENDS+= ${LOCALBASE}/bin/python:${PORTSDIR}/lang/python \
${LOCALBASE}/bin/bash:${PORTSDIR}/shells/bash
.endif
-.if defined(WITH_DEBUGGING)
+.if ${PORT_OPTIONS:MDEBUG}
CONFIGURE_ARGS+= --enable-debug-msgs --enable-debug-fnames
.endif
-.if defined(WITH_PROFILING)
+.if ${PORT_OPTIONS:MPROFILE}
CONFIGURE_ARGS+= --enable-profile
.endif
+NOT_FOR_ARCH= sparc64
+
.include <bsd.port.pre.mk>
-.if ${ARCH} == "sparc64"
-BROKEN= Does not compile on sparc64
-.endif
pre-everything::
.if !defined(PREFIX) || ${PREFIX} == "/usr/local"