aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2004-04-07 03:17:39 +0800
committerthierry <thierry@FreeBSD.org>2004-04-07 03:17:39 +0800
commitb25a09180a450ff6f2c5438d3b049534d251798c (patch)
tree94760d8f50bdcb654d43aca74ca11a9d358e8361 /net
parentb17b8b214c53e7b3a6ea686f237cd3d3f06d5624 (diff)
downloadfreebsd-ports-gnome-b25a09180a450ff6f2c5438d3b049534d251798c.tar.gz
freebsd-ports-gnome-b25a09180a450ff6f2c5438d3b049534d251798c.tar.zst
freebsd-ports-gnome-b25a09180a450ff6f2c5438d3b049534d251798c.zip
Add pear-SOAP 0.8, SOAP Client/Server for PHP.
Approved by: pav (mentor).
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/pear-SOAP/Makefile37
-rw-r--r--net/pear-SOAP/distinfo2
-rw-r--r--net/pear-SOAP/pkg-descr3
4 files changed, 43 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 59492dd9714d..8ce8cbb45655 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -485,6 +485,7 @@
SUBDIR += pear-Net_Sieve
SUBDIR += pear-Net_Socket
SUBDIR += pear-Net_URL
+ SUBDIR += pear-SOAP
SUBDIR += pebrot
SUBDIR += pen
SUBDIR += perldap
diff --git a/net/pear-SOAP/Makefile b/net/pear-SOAP/Makefile
new file mode 100644
index 000000000000..41e3d1de1c6b
--- /dev/null
+++ b/net/pear-SOAP/Makefile
@@ -0,0 +1,37 @@
+# Ports collection makefile for: pear-SOAP
+# Date created: 05 April 2004
+# Whom: Thierry Thomas (<thierry@FreeBSD.org>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= SOAP
+PORTVERSION= 0.8
+CATEGORIES= net www pear
+DISTNAME= ${PORTNAME}-${PORTVERSION}RC3
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= SOAP Client/Server for PHP
+
+BUILD_DEPENDS= ${PEARDIR}/Mail/mime.php:${PORTSDIR}/mail/pear-Mail_Mime \
+ ${PEARDIR}/HTTP/Request.php:${PORTSDIR}/www/pear-HTTP_Request \
+ ${PEARDIR}/Net/DIME.php:${PORTSDIR}/net/pear-Net_DIME
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+CATEGORY= SOAP
+FILES= Base.php Client.php Disco.php Fault.php Parser.php Server.php \
+ Transport.php Value.php WSDL.php tools/genproxy.php \
+ Transport/HTTP.php Transport/SMTP.php Transport/TCP.php \
+ Server/Email.php Server/Email_Gateway.php Server/TCP.php \
+ Type/dateTime.php Type/duration.php Type/hexBinary.php
+EXAMPLES= attachment.php client.php com_client.php disco_server.php \
+ email_client.php email_gateway.php email_pop_gateway.php \
+ email_pop_server.php email_server.php example_server.php \
+ example_types.php server.php server2.php smtp.php \
+ stockquote.php tcp_client.php tcp_daemon.pl tcp_server.php \
+ wsdl_client.php
+_EXAMPLESDIR= example
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
+.include <bsd.port.post.mk>
diff --git a/net/pear-SOAP/distinfo b/net/pear-SOAP/distinfo
new file mode 100644
index 000000000000..8d6d787b32ad
--- /dev/null
+++ b/net/pear-SOAP/distinfo
@@ -0,0 +1,2 @@
+MD5 (PEAR/SOAP-0.8RC3.tgz) = 1181071986f31a89ecc5a4aa5fd8c9c4
+SIZE (PEAR/SOAP-0.8RC3.tgz) = 67608
diff --git a/net/pear-SOAP/pkg-descr b/net/pear-SOAP/pkg-descr
new file mode 100644
index 000000000000..19f779e3c672
--- /dev/null
+++ b/net/pear-SOAP/pkg-descr
@@ -0,0 +1,3 @@
+PEAR implementation of SOAP protocol and services.
+
+WWW: http://pear.php.net/package/SOAP/