aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authordemon <demon@FreeBSD.org>2001-04-06 21:15:51 +0800
committerdemon <demon@FreeBSD.org>2001-04-06 21:15:51 +0800
commitb57d9340f8248622e9d15c2ac32567cbea1d7c34 (patch)
tree8ee1b0508d00e6c1b8c1f6c2ff2d8fa334894a45 /net
parentf11f65972d206c6a1595dd0ebebd690562f3e1a1 (diff)
downloadfreebsd-ports-gnome-b57d9340f8248622e9d15c2ac32567cbea1d7c34.tar.gz
freebsd-ports-gnome-b57d9340f8248622e9d15c2ac32567cbea1d7c34.tar.zst
freebsd-ports-gnome-b57d9340f8248622e9d15c2ac32567cbea1d7c34.zip
New port: kxicq2: ICQ client for KDE2
Submitted by: Andrey Novikov <andrey@novikov.com>
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/kxicq2/Makefile19
-rw-r--r--net/kxicq2/distinfo1
-rw-r--r--net/kxicq2/files/patch-aa64
-rw-r--r--net/kxicq2/files/patch-ac63
-rw-r--r--net/kxicq2/files/patch-ad10
-rw-r--r--net/kxicq2/files/patch-ae77
-rw-r--r--net/kxicq2/pkg-comment1
-rw-r--r--net/kxicq2/pkg-descr6
-rw-r--r--net/kxicq2/pkg-plist19
10 files changed, 261 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index b6d27c0bec99..b9951004cfab 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -147,6 +147,7 @@
SUBDIR += kmud
SUBDIR += ksamba
SUBDIR += kxicq
+ SUBDIR += kxicq2
SUBDIR += lambdamoo
SUBDIR += ldapmodule
SUBDIR += ldapsdk
diff --git a/net/kxicq2/Makefile b/net/kxicq2/Makefile
new file mode 100644
index 000000000000..ff229cc22fb2
--- /dev/null
+++ b/net/kxicq2/Makefile
@@ -0,0 +1,19 @@
+# New ports collection makefile for: kxicq2
+# Date created: 15 December 2000
+# Whom: Andrey Novikov <andrey@novikov.com>
+#
+# $FreeBSD$
+
+PORTNAME= kxicq2
+PORTVERSION= 0.0.6
+CATEGORIES= net kde
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= kxicq
+
+MAINTAINER= andrey@novikov.com
+
+USE_KDELIBS_VER=2
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/net/kxicq2/distinfo b/net/kxicq2/distinfo
new file mode 100644
index 000000000000..a3a51dbc7c7c
--- /dev/null
+++ b/net/kxicq2/distinfo
@@ -0,0 +1 @@
+MD5 (kxicq2-0.0.6.tar.gz) = 4baad94467a624e2f03236a496c94d34
diff --git a/net/kxicq2/files/patch-aa b/net/kxicq2/files/patch-aa
new file mode 100644
index 000000000000..8c5ebef0696a
--- /dev/null
+++ b/net/kxicq2/files/patch-aa
@@ -0,0 +1,64 @@
+--- acinclude.m4.orig Sun Mar 4 17:23:28 2001
++++ acinclude.m4 Thu Apr 5 16:06:32 2001
+@@ -804,9 +804,9 @@
+ AC_REQUIRE([KDE_USE_QT])
+ kde_qt_was_given=yes
+ if test -z "$LIBQT"; then
+- LIBQT="-lqt"
++ LIBQT="-lqt2"
+ kde_qt_was_given=no
+- kde_int_qt="-lqt"
++ kde_int_qt="-lqt2"
+ else
+ kde_int_qt="$LIBQT"
+ fi
+--- aclocal.m4.orig Sun Mar 4 17:23:29 2001
++++ aclocal.m4 Thu Apr 5 16:06:47 2001
+@@ -815,9 +815,9 @@
+ AC_REQUIRE([KDE_USE_QT])
+ kde_qt_was_given=yes
+ if test -z "$LIBQT"; then
+- LIBQT="-lqt"
++ LIBQT="-lqt2"
+ kde_qt_was_given=no
+- kde_int_qt="-lqt"
++ kde_int_qt="-lqt2"
+ else
+ kde_int_qt="$LIBQT"
+ fi
+--- configure.orig Sun Mar 4 17:23:32 2001
++++ configure Thu Apr 5 16:07:10 2001
+@@ -5049,9 +5049,9 @@
+
+ kde_qt_was_given=yes
+ if test -z "$LIBQT"; then
+- LIBQT="-lqt"
++ LIBQT="-lqt2"
+ kde_qt_was_given=no
+- kde_int_qt="-lqt"
++ kde_int_qt="-lqt2"
+ else
+ kde_int_qt="$LIBQT"
+ fi
+--- kxicq/Makefile.am.orig Sun Mar 4 17:25:54 2001
++++ kxicq/Makefile.am Thu Apr 5 16:07:44 2001
+@@ -17,7 +17,7 @@
+ -lX11 $\
+ -lpng -lz -lm\
+ -ljpeg\
+- -lqt $ $ -lXext $ $\
++ -lqt2 $ $ -lXext $ $\
+ -lkdecore\
+ -lkdeui\
+ -lkfile
+--- kxicq/Makefile.in.orig Sun Mar 4 17:29:43 2001
++++ kxicq/Makefile.in Thu Apr 5 16:07:31 2001
+@@ -202,7 +202,7 @@
+ bin_PROGRAMS = kxicq
+
+ kxicq_LDFLAGS = $(all_libraries)
+-kxicq_LDADD = $(top_srcdir)/kxicq/widgets/libwidgets.a $(top_srcdir)/kxicq/widgets/checklistbox/libchecklistbox.a $(top_srcdir)/kxicq/engine/libengine.a $(top_srcdir)/kxicq/ui/libui.a -lX11 $ -lpng -lz -lm -ljpeg -lqt $ $ -lXext $ $ -lkdecore -lkdeui -lkfile
++kxicq_LDADD = $(top_srcdir)/kxicq/widgets/libwidgets.a $(top_srcdir)/kxicq/widgets/checklistbox/libchecklistbox.a $(top_srcdir)/kxicq/engine/libengine.a $(top_srcdir)/kxicq/ui/libui.a -lX11 $ -lpng -lz -lm -ljpeg -lqt2 $ $ -lXext $ $ -lkdecore -lkdeui -lkfile
+
+ LDFLAGS =
+ INCLUDES = $(all_includes) -I$(top_srcdir)/ -I$(top_srcdir)/kxicq -I$(top_srcdir)/kxicq/ui -I$(top_srcdir)/kxicq/engine -I$(top_srcdir)/kxicq/widgets -I$(top_srcdir)/kxicq/widgets/checklistbox
diff --git a/net/kxicq2/files/patch-ac b/net/kxicq2/files/patch-ac
new file mode 100644
index 000000000000..d62e57b721ca
--- /dev/null
+++ b/net/kxicq2/files/patch-ac
@@ -0,0 +1,63 @@
+--- kxicq/engine/kxengine.cpp.orig Sat Mar 3 22:27:29 2001
++++ kxicq/engine/kxengine.cpp Wed Mar 28 11:19:25 2001
+@@ -6,6 +6,7 @@
+ #include "kxcontact.h"
+ #include <kxudp.h>
+ #include <kxtcp.h>
++#include "cyrrilic.h"
+
+ kxEngine *kxEngine::ptr=0L;
+
+@@ -194,6 +195,23 @@
+
+ void kxEngine::SlotNewMessage(UIN _uin, kxMessageStruct _msg)
+ {
++ // HACK - recode Cyrrilic chars
++ const char *tt = new char[_msg.message.length()+1];
++ strcpy((char *)tt,(char *)_msg.message.data());
++
++ unsigned char *c = (unsigned char*)tt;
++ unsigned char *d = (unsigned char*)tt;
++ while (*c) {
++ if (*c>=0xA0) *d = trnTablWIN2KOI[*c];
++ else *d = *c;
++ c++;d++;
++ }
++ *d=0x0;
++
++ _msg.message = QString::fromLocal8Bit(tt);
++ debug("RECODED FOR RECEIVE: [%s]",_msg.message.data());
++ delete tt;
++ // END OF HACK
+ emit SignalNewMessage(_uin, _msg);
+ emit SignalUpdateDock();
+ }
+@@ -237,8 +255,28 @@
+ }
+ kxSend *kxEngine::sendMessage(UIN _uin, QString _msg, bool _server)
+ {
+ sendSeq++;
+ kxSend *send;
++
++ // HACK - recode Cyrrilic chars
++ _msg = _msg.local8Bit().data();
++ const char *tt = new char[_msg.length()+1];
++ strcpy((char *)tt,(char *)_msg.data());
++
++ unsigned char *c = (unsigned char*)tt;
++ unsigned char *d = (unsigned char*)tt;
++ while (*c) {
++ if (*c>=0xA0) *d = trnTablKOI2WIN[*c];
++ else *d = *c;
++ c++;d++;
++ }
++ *d=0x0;
++
++ _msg = QString(tt);
++ delete tt;
++ // END OF HACK
++
++ debug("RECODED FOR SENDING: [%s]",_msg.data());
+ send=new kxSend(MESSAGE_TYPE, sendSeq, _uin, _msg,"",_server);
+ return send;
+ }
diff --git a/net/kxicq2/files/patch-ad b/net/kxicq2/files/patch-ad
new file mode 100644
index 000000000000..22f6ae7cac87
--- /dev/null
+++ b/net/kxicq2/files/patch-ad
@@ -0,0 +1,10 @@
+--- kxicq/engine/kxmessage.cpp.orig Sat Nov 11 00:24:55 2000
++++ kxicq/engine/kxmessage.cpp Wed Mar 28 11:19:33 2001
+@@ -100,6 +100,7 @@
+ tw << size;
+ file.at(file.size());
+ QTextStream t ( &file );
++ t.setEncoding(QTextStream::Locale);
+ kxMessageInfoStruct *info;
+ info=new kxMessageInfoStruct;
+ info->uin=_uin;
diff --git a/net/kxicq2/files/patch-ae b/net/kxicq2/files/patch-ae
new file mode 100644
index 000000000000..1efd464548c4
--- /dev/null
+++ b/net/kxicq2/files/patch-ae
@@ -0,0 +1,77 @@
+--- kxicq/engine/cyrrilic.h.orig Thu Jan 1 03:00:00 1970
++++ kxicq/engine/cyrrilic.h Wed Mar 28 11:06:23 2001
+@@ -0,0 +1,74 @@
++#ifndef CYRRILIC_H
++#define CYRRILIC_H
++
++static unsigned char trnTablWIN2KOI[]={
++ '\x00', '\x01', '\x02', '\x03', '\x04', '\x05', '\x06', '\x07',
++ '\x08', '\x09', '\x0a', '\x0b', '\x0c', '\x0d', '\x0e', '\x0f',
++ '\x10', '\x11', '\x12', '\x13', '\x14', '\x15', '\x16', '\x17',
++ '\x18', '\x19', '\x1a', '\x1b', '\x1c', '\x1d', '\x1e', '\x1f',
++ '\x20', '\x21', '\x22', '\x23', '\x24', '\x25', '\x26', '\x27',
++ '\x28', '\x29', '\x2a', '\x2b', '\x2c', '\x2d', '\x2e', '\x2f',
++ '\x30', '\x31', '\x32', '\x33', '\x34', '\x35', '\x36', '\x37',
++ '\x38', '\x39', '\x3a', '\x3b', '\x3c', '\x3d', '\x3e', '\x3f',
++ '\x40', '\x41', '\x42', '\x43', '\x44', '\x45', '\x46', '\x47',
++ '\x48', '\x49', '\x4a', '\x4b', '\x4c', '\x4d', '\x4e', '\x4f',
++ '\x50', '\x51', '\x52', '\x53', '\x54', '\x55', '\x56', '\x57',
++ '\x58', '\x59', '\x5a', '\x5b', '\x5c', '\x5d', '\x5e', '\x5f',
++ '\x60', '\x61', '\x62', '\x63', '\x64', '\x65', '\x66', '\x67',
++ '\x68', '\x69', '\x6a', '\x6b', '\x6c', '\x6d', '\x6e', '\x6f',
++ '\x70', '\x71', '\x72', '\x73', '\x74', '\x75', '\x76', '\x77',
++ '\x78', '\x79', '\x7a', '\x7b', '\x7c', '\x7d', '\x7e', '\x7f',
++ '\x80', '\x81', '\x82', '\x83', '\x84', '\x85', '\x86', '\x87',
++ '\x88', '\x89', '\x8a', '\x8b', '\x8c', '\x8d', '\x8e', '\x8f',
++ '\x90', '\x91', '\x92', '\x93', '\x94', '\x95', '\x96', '\x97',
++ '\x98', '\x99', '\x9a', '\x9b', '\x9c', '\x9d', '\x9e', '\x9f',
++ '\xa0', '\xa1', '\xa2', '\xa3', '\xa4', '\xa5', '\xa6', '\xa7',
++ '\xb3', '\xa9', '\xaa', '\xab', '\xac', '\xad', '\xae', '\xaf',
++ '\xb0', '\xb1', '\xb2', '\xb3', '\xb4', '\xb5', '\xb6', '\xb7',
++ '\xa3', '\xb9', '\xba', '\xbb', '\xbc', '\xbd', '\xbe', '\xbf',
++ '\xe1', '\xe2', '\xf7', '\xe7', '\xe4', '\xe5', '\xf6', '\xfa',
++ '\xe9', '\xea', '\xeb', '\xec', '\xed', '\xee', '\xef', '\xf0',
++ '\xf2', '\xf3', '\xf4', '\xf5', '\xe6', '\xe8', '\xe3', '\xfe',
++ '\xfb', '\xfd', '\xff', '\xf9', '\xf8', '\xfc', '\xe0', '\xf1',
++ '\xc1', '\xc2', '\xd7', '\xc7', '\xc4', '\xc5', '\xd6', '\xda',
++ '\xc9', '\xca', '\xcb', '\xcc', '\xcd', '\xce', '\xcf', '\xd0',
++ '\xd2', '\xd3', '\xd4', '\xd5', '\xc6', '\xc8', '\xc3', '\xde',
++ '\xdb', '\xdd', '\xdf', '\xd9', '\xd8', '\xdc', '\xc0', '\xd1'
++ };
++
++static unsigned char trnTablKOI2WIN[]={
++ '\x00', '\x01', '\x02', '\x03', '\x04', '\x05', '\x06', '\x07',
++ '\x08', '\x09', '\x0a', '\x0b', '\x0c', '\x0d', '\x0e', '\x0f',
++ '\x10', '\x11', '\x12', '\x13', '\x14', '\x15', '\x16', '\x17',
++ '\x18', '\x19', '\x1a', '\x1b', '\x1c', '\x1d', '\x1e', '\x1f',
++ '\x20', '\x21', '\x22', '\x23', '\x24', '\x25', '\x26', '\x27',
++ '\x28', '\x29', '\x2a', '\x2b', '\x2c', '\x2d', '\x2e', '\x2f',
++ '\x30', '\x31', '\x32', '\x33', '\x34', '\x35', '\x36', '\x37',
++ '\x38', '\x39', '\x3a', '\x3b', '\x3c', '\x3d', '\x3e', '\x3f',
++ '\x40', '\x41', '\x42', '\x43', '\x44', '\x45', '\x46', '\x47',
++ '\x48', '\x49', '\x4a', '\x4b', '\x4c', '\x4d', '\x4e', '\x4f',
++ '\x50', '\x51', '\x52', '\x53', '\x54', '\x55', '\x56', '\x57',
++ '\x58', '\x59', '\x5a', '\x5b', '\x5c', '\x5d', '\x5e', '\x5f',
++ '\x60', '\x61', '\x62', '\x63', '\x64', '\x65', '\x66', '\x67',
++ '\x68', '\x69', '\x6a', '\x6b', '\x6c', '\x6d', '\x6e', '\x6f',
++ '\x70', '\x71', '\x72', '\x73', '\x74', '\x75', '\x76', '\x77',
++ '\x78', '\x79', '\x7a', '\x7b', '\x7c', '\x7d', '\x7e', '\x7f',
++ '\x80', '\x81', '\x82', '\x83', '\x84', '\x85', '\x86', '\x87',
++ '\x88', '\x89', '\x8a', '\x8b', '\x8c', '\x8d', '\x8e', '\x8f',
++ '\x90', '\x91', '\x92', '\x93', '\x94', '\x95', '\x96', '\x97',
++ '\x98', '\x99', '\x9a', '\x9b', '\x9c', '\x9d', '\x9e', '\x9f',
++ '\xa0', '\xa1', '\xa2', '\xb8', '\xa4', '\xa5', '\xa6', '\xa7',
++ '\xa8', '\xa9', '\xaa', '\xab', '\xac', '\xad', '\xae', '\xaf',
++ '\xb0', '\xb1', '\xb2', '\xa8', '\xb4', '\xb5', '\xb6', '\xb7',
++ '\xb8', '\xb9', '\xba', '\xbb', '\xbc', '\xbd', '\xbe', '\xbf',
++ '\xfe', '\xe0', '\xe1', '\xf6', '\xe4', '\xe5', '\xf4', '\xe3',
++ '\xf5', '\xe8', '\xe9', '\xea', '\xeb', '\xec', '\xed', '\xee',
++ '\xef', '\xff', '\xf0', '\xf1', '\xf2', '\xf3', '\xe6', '\xe2',
++ '\xfc', '\xfb', '\xe7', '\xf8', '\xfd', '\xf9', '\xf7', '\xfa',
++ '\xde', '\xc0', '\xc1', '\xd6', '\xc4', '\xc5', '\xd4', '\xc3',
++ '\xd5', '\xc8', '\xc9', '\xca', '\xcb', '\xcc', '\xcd', '\xce',
++ '\xcf', '\xdf', '\xd0', '\xd1', '\xd2', '\xd3', '\xc6', '\xc2',
++ '\xdc', '\xdb', '\xc7', '\xd8', '\xdd', '\xd9', '\xd7', '\xda'
++};
++
++#endif
diff --git a/net/kxicq2/pkg-comment b/net/kxicq2/pkg-comment
new file mode 100644
index 000000000000..ae5b589e8e7e
--- /dev/null
+++ b/net/kxicq2/pkg-comment
@@ -0,0 +1 @@
+ICQ client for KDE2
diff --git a/net/kxicq2/pkg-descr b/net/kxicq2/pkg-descr
new file mode 100644
index 000000000000..4264bab49028
--- /dev/null
+++ b/net/kxicq2/pkg-descr
@@ -0,0 +1,6 @@
+This is the beta release of KDE2 version of outstanding ICQ client
+for KDE - kxicq.
+
+WWW: http://www.kxicq.org/
+
+- Andrey Novikov <andrey@novikov.com>
diff --git a/net/kxicq2/pkg-plist b/net/kxicq2/pkg-plist
new file mode 100644
index 000000000000..c176f95c0a90
--- /dev/null
+++ b/net/kxicq2/pkg-plist
@@ -0,0 +1,19 @@
+bin/kxicq
+share/apps/kxicq2/pics/available.xpm
+share/apps/kxicq2/pics/away.xpm
+share/apps/kxicq2/pics/dnd.xpm
+share/apps/kxicq2/pics/exit.xpm
+share/apps/kxicq2/pics/ffc.xpm
+share/apps/kxicq2/pics/history.xpm
+share/apps/kxicq2/pics/invisible.xpm
+share/apps/kxicq2/pics/na.xpm
+share/apps/kxicq2/pics/newmsg.xpm
+share/apps/kxicq2/pics/occupied.xpm
+share/apps/kxicq2/pics/offline.xpm
+share/apps/kxicq2/pics/online.xpm
+share/apps/kxicq2/pics/selectcolor.xpm
+share/apps/kxicq2/pics/selecttext.xpm
+share/apps/kxicq2/pics/send.xpm
+share/applnk/Internet/kxicq2.desktop
+@dirrm share/apps/kxicq2/pics
+@dirrm share/apps/kxicq2