aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2000-10-29 07:22:16 +0800
committerwill <will@FreeBSD.org>2000-10-29 07:22:16 +0800
commitb644b097737cea11dc72ddbe882d198d29d8cc6d (patch)
tree4b57b5b6ccaf02ebecc714733b8f7ed7ba0543b6 /net
parentf0dba4368e7e5aca622482ec55fcdb9eb575f85e (diff)
downloadfreebsd-ports-gnome-b644b097737cea11dc72ddbe882d198d29d8cc6d.tar.gz
freebsd-ports-gnome-b644b097737cea11dc72ddbe882d198d29d8cc6d.tar.zst
freebsd-ports-gnome-b644b097737cea11dc72ddbe882d198d29d8cc6d.zip
Implement fix for configure scripts in regards to finding X libs on
XFree86 4.0.1. Submitted by: PW (thanks)
Diffstat (limited to 'net')
-rw-r--r--net/kdenetwork2/Makefile4
-rw-r--r--net/kdenetwork3/Makefile4
-rw-r--r--net/kdenetwork4/Makefile4
3 files changed, 6 insertions, 6 deletions
diff --git a/net/kdenetwork2/Makefile b/net/kdenetwork2/Makefile
index ce0540846e6c..4d12a417c584 100644
--- a/net/kdenetwork2/Makefile
+++ b/net/kdenetwork2/Makefile
@@ -26,8 +26,8 @@ CONFIGURE_ARGS+=--with-qt-dir=${X11BASE} \
--with-qt-libraries=${X11BASE}/lib \
--with-extra-libs=${LOCALBASE}/lib
CONFIGURE_ENV+= LIBQT="-lqt2" MOC="${MOC}" LIBQTFILE="libqt2" \
- CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include -D_XOPEN_UNIX" \
- LIBS="-Wl,-export-dynamic -L${LOCALBASE}/lib -L${X11BASE}/lib -lqt2 -ljpeg -lgcc -lstdc++"
+ CPPFLAGS="-I${LOCALBASE}/include -D_XOPEN_UNIX" \
+ LIBS="-Wl,-export-dynamic -L${LOCALBASE}/lib -lqt2 -ljpeg -lgcc -lstdc++"
USE_GMAKE= yes
pre-configure:
diff --git a/net/kdenetwork3/Makefile b/net/kdenetwork3/Makefile
index ce0540846e6c..4d12a417c584 100644
--- a/net/kdenetwork3/Makefile
+++ b/net/kdenetwork3/Makefile
@@ -26,8 +26,8 @@ CONFIGURE_ARGS+=--with-qt-dir=${X11BASE} \
--with-qt-libraries=${X11BASE}/lib \
--with-extra-libs=${LOCALBASE}/lib
CONFIGURE_ENV+= LIBQT="-lqt2" MOC="${MOC}" LIBQTFILE="libqt2" \
- CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include -D_XOPEN_UNIX" \
- LIBS="-Wl,-export-dynamic -L${LOCALBASE}/lib -L${X11BASE}/lib -lqt2 -ljpeg -lgcc -lstdc++"
+ CPPFLAGS="-I${LOCALBASE}/include -D_XOPEN_UNIX" \
+ LIBS="-Wl,-export-dynamic -L${LOCALBASE}/lib -lqt2 -ljpeg -lgcc -lstdc++"
USE_GMAKE= yes
pre-configure:
diff --git a/net/kdenetwork4/Makefile b/net/kdenetwork4/Makefile
index ce0540846e6c..4d12a417c584 100644
--- a/net/kdenetwork4/Makefile
+++ b/net/kdenetwork4/Makefile
@@ -26,8 +26,8 @@ CONFIGURE_ARGS+=--with-qt-dir=${X11BASE} \
--with-qt-libraries=${X11BASE}/lib \
--with-extra-libs=${LOCALBASE}/lib
CONFIGURE_ENV+= LIBQT="-lqt2" MOC="${MOC}" LIBQTFILE="libqt2" \
- CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include -D_XOPEN_UNIX" \
- LIBS="-Wl,-export-dynamic -L${LOCALBASE}/lib -L${X11BASE}/lib -lqt2 -ljpeg -lgcc -lstdc++"
+ CPPFLAGS="-I${LOCALBASE}/include -D_XOPEN_UNIX" \
+ LIBS="-Wl,-export-dynamic -L${LOCALBASE}/lib -lqt2 -ljpeg -lgcc -lstdc++"
USE_GMAKE= yes
pre-configure: